summaryrefslogtreecommitdiffstats
path: root/recipes-extended/diffutils
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/diffutils')
-rw-r--r--recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch27
-rw-r--r--recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch31
-rw-r--r--recipes-extended/diffutils/diffutils.inc18
-rw-r--r--recipes-extended/diffutils/diffutils_2.8.1.bb17
4 files changed, 93 insertions, 0 deletions
diff --git a/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch b/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch
new file mode 100644
index 0000000..f8638bb
--- /dev/null
+++ b/recipes-extended/diffutils/diffutils-2.8.1/diffutils_fix_for_automake-1.12.patch
@@ -0,0 +1,27 @@
1Upstream-Status: Pending
2
3automake 1.12 has depricated automatic de-ANSI-fication support
4
5this patch avoids these kinds of errors:
6
7| configure.ac:90: error: automatic de-ANSI-fication support has been removed
8| /srv/home/nitin/builds/build-gcc47/tmp/sysroots/x86_64-linux/usr/share/aclocal-1.12/protos.m4:12: AM_C_PROTOTYPES is expanded from...
9| /srv/home/nitin/builds/build-gcc47/tmp/work/i586-poky-linux/diffutils-2.8.1-r4/diffutils-2.8.1/m4/prereq.m4:110: jm_PREREQ_QUOTEARG is expanded from...
10| configure.ac:90: the top level
11| autom4te: m4 failed with exit status: 1
12
13Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
142012/05/04
15
16Index: diffutils-2.8.1/m4/prereq.m4
17===================================================================
18--- diffutils-2.8.1.orig/m4/prereq.m4
19+++ diffutils-2.8.1/m4/prereq.m4
20@@ -115,7 +115,6 @@ AC_DEFUN([jm_PREREQ_QUOTEARG],
21 AC_HEADER_STDC
22 AC_C_BACKSLASH_A
23 AC_MBSTATE_T
24- AM_C_PROTOTYPES
25 ])
26
27 AC_DEFUN([jm_PREREQ_REGEX],
diff --git a/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch b/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch
new file mode 100644
index 0000000..f915287
--- /dev/null
+++ b/recipes-extended/diffutils/diffutils-2.8.1/fix_gcc6.patch
@@ -0,0 +1,31 @@
1Fixes to allow diffutils to build with gcc v6.
2
3RP
42016/5/25
5
6Index: diffutils-2.8.1/lib/posix/regex.h
7===================================================================
8--- diffutils-2.8.1.orig/lib/posix/regex.h
9+++ diffutils-2.8.1/lib/posix/regex.h
10@@ -529,7 +529,9 @@ extern int re_exec _RE_ARGS ((const char
11 /* For now unconditionally define __restrict_arr to expand to nothing.
12 Ideally we would have a test for the compiler which allows defining
13 it to restrict. */
14+#ifndef __restrict_arr
15 #define __restrict_arr
16+#endif
17
18 /* POSIX compatibility. */
19 extern int regcomp _RE_ARGS ((regex_t *__restrict __preg,
20Index: diffutils-2.8.1/src/diff.c
21===================================================================
22--- diffutils-2.8.1.orig/src/diff.c
23+++ diffutils-2.8.1/src/diff.c
24@@ -71,6 +71,7 @@ static void usage (void);
25 static bool recursive;
26
27 /* In context diffs, show previous lines that match these regexps. */
28+struct re_pattern_buffer function_regexp;
29 static struct regexp_list function_regexp_list;
30
31 /* Ignore changes affecting only lines that match these regexps. */
diff --git a/recipes-extended/diffutils/diffutils.inc b/recipes-extended/diffutils/diffutils.inc
new file mode 100644
index 0000000..243341a
--- /dev/null
+++ b/recipes-extended/diffutils/diffutils.inc
@@ -0,0 +1,18 @@
1SUMMARY = "Diffutils contains tools used for finding differences between files"
2DESCRIPTION = "Diffutils contains the GNU diff, diff3, \
3sdiff, and cmp utilities. These programs are usually \
4used for creating patch files."
5SECTION = "base"
6
7inherit autotools texinfo update-alternatives gettext
8
9# diffutils assumes non-glibc compilation with uclibc and
10# this causes it to generate its own implementations of
11# standard functionality. regex.c actually breaks compilation
12# because it uses __mempcpy, there are other things (TBD:
13# see diffutils.mk in buildroot)
14EXTRA_OECONF_libc-uclibc = "--without-included-regex"
15
16ALTERNATIVE_${PN} = "diff cmp"
17ALTERNATIVE_PRIORITY = "100"
18
diff --git a/recipes-extended/diffutils/diffutils_2.8.1.bb b/recipes-extended/diffutils/diffutils_2.8.1.bb
new file mode 100644
index 0000000..fe56f9c
--- /dev/null
+++ b/recipes-extended/diffutils/diffutils_2.8.1.bb
@@ -0,0 +1,17 @@
1LICENSE = "GPLv2+"
2LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
3
4require diffutils.inc
5
6PR = "r7.0"
7
8SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \
9 file://diffutils_fix_for_automake-1.12.patch \
10 file://fix_gcc6.patch"
11
12SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428"
13SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a"
14
15do_configure_prepend () {
16 chmod u+w ${S}/po/Makefile.in.in
17}