summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/elfutils/elfutils_0.148.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/elfutils/elfutils_0.148.bb')
-rw-r--r--recipes-devtools/elfutils/elfutils_0.148.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/recipes-devtools/elfutils/elfutils_0.148.bb b/recipes-devtools/elfutils/elfutils_0.148.bb
index 3c0f9f0..848e2cf 100644
--- a/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -42,11 +42,11 @@ SRC_URI += "\
42" 42"
43 43
44# Only apply when building musl based target recipe 44# Only apply when building musl based target recipe
45SRC_URI_append_libc-musl = " file://musl-support-for-elfutils-0.148.patch" 45SRC_URI:append:libc-musl = " file://musl-support-for-elfutils-0.148.patch"
46 46
47# The buildsystem wants to generate 2 .h files from source using a binary it just built, 47# The buildsystem wants to generate 2 .h files from source using a binary it just built,
48# which can not pass the cross compiling, so let's work around it by adding 2 .h files 48# which can not pass the cross compiling, so let's work around it by adding 2 .h files
49# along with the do_configure_prepend() 49# along with the do_configure:prepend()
50 50
51SRC_URI += "\ 51SRC_URI += "\
52 file://i386_dis.h \ 52 file://i386_dis.h \
@@ -67,9 +67,9 @@ CFLAGS += "-Wno-error=format-truncation="
67CFLAGS += "-Wno-error=stringop-overflow=" 67CFLAGS += "-Wno-error=stringop-overflow="
68 68
69EXTRA_OECONF = "--program-prefix=eu- --without-lzma" 69EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
70EXTRA_OECONF_append_class-native = " --without-bzlib" 70EXTRA_OECONF:append:class-native = " --without-bzlib"
71 71
72do_configure_prepend() { 72do_configure:prepend() {
73 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am 73 sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am
74 74
75 cp ${WORKDIR}/*dis.h ${S}/libcpu 75 cp ${WORKDIR}/*dis.h ${S}/libcpu
@@ -79,15 +79,15 @@ do_configure_prepend() {
79# but some recipes e.g. gcc 4.5 depends on libelf so we 79# but some recipes e.g. gcc 4.5 depends on libelf so we
80# build only libelf for musl cases 80# build only libelf for musl cases
81 81
82EXTRA_OEMAKE_libc-musl = "-C libelf" 82EXTRA_OEMAKE:libc-musl = "-C libelf"
83EXTRA_OEMAKE_class-native = "" 83EXTRA_OEMAKE:class-native = ""
84EXTRA_OEMAKE_class-nativesdk = "" 84EXTRA_OEMAKE:class-nativesdk = ""
85 85
86BBCLASSEXTEND = "native nativesdk" 86BBCLASSEXTEND = "native nativesdk"
87 87
88# Package utilities separately 88# Package utilities separately
89PACKAGES =+ "${PN}-binutils libelf libasm libdw" 89PACKAGES =+ "${PN}-binutils libelf libasm libdw"
90FILES_${PN}-binutils = "\ 90FILES:${PN}-binutils = "\
91 ${bindir}/eu-addr2line \ 91 ${bindir}/eu-addr2line \
92 ${bindir}/eu-ld \ 92 ${bindir}/eu-ld \
93 ${bindir}/eu-nm \ 93 ${bindir}/eu-nm \
@@ -95,13 +95,13 @@ FILES_${PN}-binutils = "\
95 ${bindir}/eu-size \ 95 ${bindir}/eu-size \
96 ${bindir}/eu-strip" 96 ${bindir}/eu-strip"
97 97
98FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*" 98FILES:libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
99FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*" 99FILES:libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
100FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*" 100FILES:libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
101# Some packages have the version preceeding the .so instead properly 101# Some packages have the version preceeding the .so instead properly
102# versioned .so.<version>, so we need to reorder and repackage. 102# versioned .so.<version>, so we need to reorder and repackage.
103#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so" 103#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
104#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so" 104#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
105 105
106# The package contains symlinks that trip up insane 106# The package contains symlinks that trip up insane
107INSANE_SKIP_${MLPREFIX}libdw = "dev-so" 107INSANE_SKIP:${MLPREFIX}libdw = "dev-so"