diff options
-rw-r--r-- | recipes-devtools/bison/bison/bison-2.3_m4.patch | 591 |
1 files changed, 591 insertions, 0 deletions
diff --git a/recipes-devtools/bison/bison/bison-2.3_m4.patch b/recipes-devtools/bison/bison/bison-2.3_m4.patch new file mode 100644 index 0000000..348ce1d --- /dev/null +++ b/recipes-devtools/bison/bison/bison-2.3_m4.patch | |||
@@ -0,0 +1,591 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | # | ||
4 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
5 | # | ||
6 | |||
7 | --- /dev/null | ||
8 | +++ bison-1.875/m4/inttypes-pri.m4 | ||
9 | @@ -0,0 +1,32 @@ | ||
10 | +# inttypes-pri.m4 serial 1 (gettext-0.11.4) | ||
11 | +dnl Copyright (C) 1997-2002 Free Software Foundation, Inc. | ||
12 | +dnl This file is free software, distributed under the terms of the GNU | ||
13 | +dnl General Public License. As a special exception to the GNU General | ||
14 | +dnl Public License, this file may be distributed as part of a program | ||
15 | +dnl that contains a configuration script generated by Autoconf, under | ||
16 | +dnl the same distribution terms as the rest of that program. | ||
17 | + | ||
18 | +dnl From Bruno Haible. | ||
19 | + | ||
20 | +# Define PRI_MACROS_BROKEN if <inttypes.h> exists and defines the PRI* | ||
21 | +# macros to non-string values. This is the case on AIX 4.3.3. | ||
22 | + | ||
23 | +AC_DEFUN([gt_INTTYPES_PRI], | ||
24 | +[ | ||
25 | + AC_REQUIRE([gt_HEADER_INTTYPES_H]) | ||
26 | + if test $gt_cv_header_inttypes_h = yes; then | ||
27 | + AC_CACHE_CHECK([whether the inttypes.h PRIxNN macros are broken], | ||
28 | + gt_cv_inttypes_pri_broken, | ||
29 | + [ | ||
30 | + AC_TRY_COMPILE([#include <inttypes.h> | ||
31 | +#ifdef PRId32 | ||
32 | +char *p = PRId32; | ||
33 | +#endif | ||
34 | +], [], gt_cv_inttypes_pri_broken=no, gt_cv_inttypes_pri_broken=yes) | ||
35 | + ]) | ||
36 | + fi | ||
37 | + if test "$gt_cv_inttypes_pri_broken" = yes; then | ||
38 | + AC_DEFINE_UNQUOTED(PRI_MACROS_BROKEN, 1, | ||
39 | + [Define if <inttypes.h> exists and defines unusable PRI* macros.]) | ||
40 | + fi | ||
41 | +]) | ||
42 | --- /dev/null | ||
43 | +++ bison-1.875/m4/lcmessage.m4 | ||
44 | @@ -0,0 +1,32 @@ | ||
45 | +# lcmessage.m4 serial 3 (gettext-0.11.3) | ||
46 | +dnl Copyright (C) 1995-2002 Free Software Foundation, Inc. | ||
47 | +dnl This file is free software, distributed under the terms of the GNU | ||
48 | +dnl General Public License. As a special exception to the GNU General | ||
49 | +dnl Public License, this file may be distributed as part of a program | ||
50 | +dnl that contains a configuration script generated by Autoconf, under | ||
51 | +dnl the same distribution terms as the rest of that program. | ||
52 | +dnl | ||
53 | +dnl This file can can be used in projects which are not available under | ||
54 | +dnl the GNU General Public License or the GNU Library General Public | ||
55 | +dnl License but which still want to provide support for the GNU gettext | ||
56 | +dnl functionality. | ||
57 | +dnl Please note that the actual code of the GNU gettext library is covered | ||
58 | +dnl by the GNU Library General Public License, and the rest of the GNU | ||
59 | +dnl gettext package package is covered by the GNU General Public License. | ||
60 | +dnl They are *not* in the public domain. | ||
61 | + | ||
62 | +dnl Authors: | ||
63 | +dnl Ulrich Drepper <drepper@cygnus.com>, 1995. | ||
64 | + | ||
65 | +# Check whether LC_MESSAGES is available in <locale.h>. | ||
66 | + | ||
67 | +AC_DEFUN([AM_LC_MESSAGES], | ||
68 | +[ | ||
69 | + AC_CACHE_CHECK([for LC_MESSAGES], am_cv_val_LC_MESSAGES, | ||
70 | + [AC_TRY_LINK([#include <locale.h>], [return LC_MESSAGES], | ||
71 | + am_cv_val_LC_MESSAGES=yes, am_cv_val_LC_MESSAGES=no)]) | ||
72 | + if test $am_cv_val_LC_MESSAGES = yes; then | ||
73 | + AC_DEFINE(HAVE_LC_MESSAGES, 1, | ||
74 | + [Define if your <locale.h> file defines LC_MESSAGES.]) | ||
75 | + fi | ||
76 | +]) | ||
77 | --- /dev/null | ||
78 | +++ bison-1.875/m4/uintmax_t.m4 | ||
79 | @@ -0,0 +1,29 @@ | ||
80 | +# uintmax_t.m4 serial 6 (gettext-0.11) | ||
81 | +dnl Copyright (C) 1997-2002 Free Software Foundation, Inc. | ||
82 | +dnl This file is free software, distributed under the terms of the GNU | ||
83 | +dnl General Public License. As a special exception to the GNU General | ||
84 | +dnl Public License, this file may be distributed as part of a program | ||
85 | +dnl that contains a configuration script generated by Autoconf, under | ||
86 | +dnl the same distribution terms as the rest of that program. | ||
87 | + | ||
88 | +dnl From Paul Eggert. | ||
89 | + | ||
90 | +AC_PREREQ(2.13) | ||
91 | + | ||
92 | +# Define uintmax_t to `unsigned long' or `unsigned long long' | ||
93 | +# if <inttypes.h> does not exist. | ||
94 | + | ||
95 | +AC_DEFUN([jm_AC_TYPE_UINTMAX_T], | ||
96 | +[ | ||
97 | + AC_REQUIRE([jm_AC_HEADER_INTTYPES_H]) | ||
98 | + AC_REQUIRE([jm_AC_HEADER_STDINT_H]) | ||
99 | + if test $jm_ac_cv_header_inttypes_h = no && test $jm_ac_cv_header_stdint_h = no; then | ||
100 | + AC_REQUIRE([jm_AC_TYPE_UNSIGNED_LONG_LONG]) | ||
101 | + test $ac_cv_type_unsigned_long_long = yes \ | ||
102 | + && ac_type='unsigned long long' \ | ||
103 | + || ac_type='unsigned long' | ||
104 | + AC_DEFINE_UNQUOTED(uintmax_t, $ac_type, | ||
105 | + [Define to unsigned long or unsigned long long | ||
106 | + if <inttypes.h> and <stdint.h> don't define.]) | ||
107 | + fi | ||
108 | +]) | ||
109 | --- /dev/null | ||
110 | +++ bison-1.875/m4/glibc21.m4 | ||
111 | @@ -0,0 +1,32 @@ | ||
112 | +# glibc21.m4 serial 2 (fileutils-4.1.3, gettext-0.10.40) | ||
113 | +dnl Copyright (C) 2000-2002 Free Software Foundation, Inc. | ||
114 | +dnl This file is free software, distributed under the terms of the GNU | ||
115 | +dnl General Public License. As a special exception to the GNU General | ||
116 | +dnl Public License, this file may be distributed as part of a program | ||
117 | +dnl that contains a configuration script generated by Autoconf, under | ||
118 | +dnl the same distribution terms as the rest of that program. | ||
119 | + | ||
120 | +# Test for the GNU C Library, version 2.1 or newer. | ||
121 | +# From Bruno Haible. | ||
122 | + | ||
123 | +AC_DEFUN([jm_GLIBC21], | ||
124 | + [ | ||
125 | + AC_CACHE_CHECK(whether we are using the GNU C Library 2.1 or newer, | ||
126 | + ac_cv_gnu_library_2_1, | ||
127 | + [AC_EGREP_CPP([Lucky GNU user], | ||
128 | + [ | ||
129 | +#include <features.h> | ||
130 | +#ifdef __GNU_LIBRARY__ | ||
131 | + #if (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1) || (__GLIBC__ > 2) | ||
132 | + Lucky GNU user | ||
133 | + #endif | ||
134 | +#endif | ||
135 | + ], | ||
136 | + ac_cv_gnu_library_2_1=yes, | ||
137 | + ac_cv_gnu_library_2_1=no) | ||
138 | + ] | ||
139 | + ) | ||
140 | + AC_SUBST(GLIBC21) | ||
141 | + GLIBC21="$ac_cv_gnu_library_2_1" | ||
142 | + ] | ||
143 | +) | ||
144 | --- /dev/null | ||
145 | +++ bison-1.875/m4/stdint_h.m4 | ||
146 | @@ -0,0 +1,28 @@ | ||
147 | +# stdint_h.m4 serial 2 (gettext-0.11.4) | ||
148 | +dnl Copyright (C) 1997-2002 Free Software Foundation, Inc. | ||
149 | +dnl This file is free software, distributed under the terms of the GNU | ||
150 | +dnl General Public License. As a special exception to the GNU General | ||
151 | +dnl Public License, this file may be distributed as part of a program | ||
152 | +dnl that contains a configuration script generated by Autoconf, under | ||
153 | +dnl the same distribution terms as the rest of that program. | ||
154 | + | ||
155 | +dnl From Paul Eggert. | ||
156 | + | ||
157 | +# Define HAVE_STDINT_H_WITH_UINTMAX if <stdint.h> exists, | ||
158 | +# doesn't clash with <sys/types.h>, and declares uintmax_t. | ||
159 | + | ||
160 | +AC_DEFUN([jm_AC_HEADER_STDINT_H], | ||
161 | +[ | ||
162 | + AC_CACHE_CHECK([for stdint.h], jm_ac_cv_header_stdint_h, | ||
163 | + [AC_TRY_COMPILE( | ||
164 | + [#include <sys/types.h> | ||
165 | +#include <stdint.h>], | ||
166 | + [uintmax_t i = (uintmax_t) -1;], | ||
167 | + jm_ac_cv_header_stdint_h=yes, | ||
168 | + jm_ac_cv_header_stdint_h=no)]) | ||
169 | + if test $jm_ac_cv_header_stdint_h = yes; then | ||
170 | + AC_DEFINE_UNQUOTED(HAVE_STDINT_H_WITH_UINTMAX, 1, | ||
171 | +[Define if <stdint.h> exists, doesn't clash with <sys/types.h>, | ||
172 | + and declares uintmax_t. ]) | ||
173 | + fi | ||
174 | +]) | ||
175 | --- /dev/null | ||
176 | +++ bison-1.875/m4/inttypes_h.m4 | ||
177 | @@ -0,0 +1,28 @@ | ||
178 | +# inttypes_h.m4 serial 4 (gettext-0.11.4) | ||
179 | +dnl Copyright (C) 1997-2002 Free Software Foundation, Inc. | ||
180 | +dnl This file is free software, distributed under the terms of the GNU | ||
181 | +dnl General Public License. As a special exception to the GNU General | ||
182 | +dnl Public License, this file may be distributed as part of a program | ||
183 | +dnl that contains a configuration script generated by Autoconf, under | ||
184 | +dnl the same distribution terms as the rest of that program. | ||
185 | + | ||
186 | +dnl From Paul Eggert. | ||
187 | + | ||
188 | +# Define HAVE_INTTYPES_H_WITH_UINTMAX if <inttypes.h> exists, | ||
189 | +# doesn't clash with <sys/types.h>, and declares uintmax_t. | ||
190 | + | ||
191 | +AC_DEFUN([jm_AC_HEADER_INTTYPES_H], | ||
192 | +[ | ||
193 | + AC_CACHE_CHECK([for inttypes.h], jm_ac_cv_header_inttypes_h, | ||
194 | + [AC_TRY_COMPILE( | ||
195 | + [#include <sys/types.h> | ||
196 | +#include <inttypes.h>], | ||
197 | + [uintmax_t i = (uintmax_t) -1;], | ||
198 | + jm_ac_cv_header_inttypes_h=yes, | ||
199 | + jm_ac_cv_header_inttypes_h=no)]) | ||
200 | + if test $jm_ac_cv_header_inttypes_h = yes; then | ||
201 | + AC_DEFINE_UNQUOTED(HAVE_INTTYPES_H_WITH_UINTMAX, 1, | ||
202 | +[Define if <inttypes.h> exists, doesn't clash with <sys/types.h>, | ||
203 | + and declares uintmax_t. ]) | ||
204 | + fi | ||
205 | +]) | ||
206 | --- /dev/null | ||
207 | +++ bison-1.875/m4/ulonglong.m4 | ||
208 | @@ -0,0 +1,23 @@ | ||
209 | +# ulonglong.m4 serial 2 (fileutils-4.0.32, gettext-0.10.40) | ||
210 | +dnl Copyright (C) 1999-2002 Free Software Foundation, Inc. | ||
211 | +dnl This file is free software, distributed under the terms of the GNU | ||
212 | +dnl General Public License. As a special exception to the GNU General | ||
213 | +dnl Public License, this file may be distributed as part of a program | ||
214 | +dnl that contains a configuration script generated by Autoconf, under | ||
215 | +dnl the same distribution terms as the rest of that program. | ||
216 | + | ||
217 | +dnl From Paul Eggert. | ||
218 | + | ||
219 | +AC_DEFUN([jm_AC_TYPE_UNSIGNED_LONG_LONG], | ||
220 | +[ | ||
221 | + AC_CACHE_CHECK([for unsigned long long], ac_cv_type_unsigned_long_long, | ||
222 | + [AC_TRY_LINK([unsigned long long ull = 1; int i = 63;], | ||
223 | + [unsigned long long ullmax = (unsigned long long) -1; | ||
224 | + return ull << i | ull >> i | ullmax / ull | ullmax % ull;], | ||
225 | + ac_cv_type_unsigned_long_long=yes, | ||
226 | + ac_cv_type_unsigned_long_long=no)]) | ||
227 | + if test $ac_cv_type_unsigned_long_long = yes; then | ||
228 | + AC_DEFINE(HAVE_UNSIGNED_LONG_LONG, 1, | ||
229 | + [Define if you have the unsigned long long type.]) | ||
230 | + fi | ||
231 | +]) | ||
232 | --- /dev/null | ||
233 | +++ bison-1.875/m4/codeset.m4 | ||
234 | @@ -0,0 +1,23 @@ | ||
235 | +# codeset.m4 serial AM1 (gettext-0.10.40) | ||
236 | +dnl Copyright (C) 2000-2002 Free Software Foundation, Inc. | ||
237 | +dnl This file is free software, distributed under the terms of the GNU | ||
238 | +dnl General Public License. As a special exception to the GNU General | ||
239 | +dnl Public License, this file may be distributed as part of a program | ||
240 | +dnl that contains a configuration script generated by Autoconf, under | ||
241 | +dnl the same distribution terms as the rest of that program. | ||
242 | + | ||
243 | +dnl From Bruno Haible. | ||
244 | + | ||
245 | +AC_DEFUN([AM_LANGINFO_CODESET], | ||
246 | +[ | ||
247 | + AC_CACHE_CHECK([for nl_langinfo and CODESET], am_cv_langinfo_codeset, | ||
248 | + [AC_TRY_LINK([#include <langinfo.h>], | ||
249 | + [char* cs = nl_langinfo(CODESET);], | ||
250 | + am_cv_langinfo_codeset=yes, | ||
251 | + am_cv_langinfo_codeset=no) | ||
252 | + ]) | ||
253 | + if test $am_cv_langinfo_codeset = yes; then | ||
254 | + AC_DEFINE(HAVE_LANGINFO_CODESET, 1, | ||
255 | + [Define if you have <langinfo.h> and nl_langinfo(CODESET).]) | ||
256 | + fi | ||
257 | +]) | ||
258 | --- /dev/null | ||
259 | +++ bison-1.875/m4/intdiv0.m4 | ||
260 | @@ -0,0 +1,72 @@ | ||
261 | +# intdiv0.m4 serial 1 (gettext-0.11.3) | ||
262 | +dnl Copyright (C) 2002 Free Software Foundation, Inc. | ||
263 | +dnl This file is free software, distributed under the terms of the GNU | ||
264 | +dnl General Public License. As a special exception to the GNU General | ||
265 | +dnl Public License, this file may be distributed as part of a program | ||
266 | +dnl that contains a configuration script generated by Autoconf, under | ||
267 | +dnl the same distribution terms as the rest of that program. | ||
268 | + | ||
269 | +dnl From Bruno Haible. | ||
270 | + | ||
271 | +AC_DEFUN([gt_INTDIV0], | ||
272 | +[ | ||
273 | + AC_REQUIRE([AC_PROG_CC])dnl | ||
274 | + AC_REQUIRE([AC_CANONICAL_HOST])dnl | ||
275 | + | ||
276 | + AC_CACHE_CHECK([whether integer division by zero raises SIGFPE], | ||
277 | + gt_cv_int_divbyzero_sigfpe, | ||
278 | + [ | ||
279 | + AC_TRY_RUN([ | ||
280 | +#include <stdlib.h> | ||
281 | +#include <signal.h> | ||
282 | + | ||
283 | +static void | ||
284 | +#ifdef __cplusplus | ||
285 | +sigfpe_handler (int sig) | ||
286 | +#else | ||
287 | +sigfpe_handler (sig) int sig; | ||
288 | +#endif | ||
289 | +{ | ||
290 | + /* Exit with code 0 if SIGFPE, with code 1 if any other signal. */ | ||
291 | + exit (sig != SIGFPE); | ||
292 | +} | ||
293 | + | ||
294 | +int x = 1; | ||
295 | +int y = 0; | ||
296 | +int z; | ||
297 | +int nan; | ||
298 | + | ||
299 | +int main () | ||
300 | +{ | ||
301 | + signal (SIGFPE, sigfpe_handler); | ||
302 | +/* IRIX and AIX (when "xlc -qcheck" is used) yield signal SIGTRAP. */ | ||
303 | +#if (defined (__sgi) || defined (_AIX)) && defined (SIGTRAP) | ||
304 | + signal (SIGTRAP, sigfpe_handler); | ||
305 | +#endif | ||
306 | +/* Linux/SPARC yields signal SIGILL. */ | ||
307 | +#if defined (__sparc__) && defined (__linux__) | ||
308 | + signal (SIGILL, sigfpe_handler); | ||
309 | +#endif | ||
310 | + | ||
311 | + z = x / y; | ||
312 | + nan = y / y; | ||
313 | + exit (1); | ||
314 | +} | ||
315 | +], gt_cv_int_divbyzero_sigfpe=yes, gt_cv_int_divbyzero_sigfpe=no, | ||
316 | + [ | ||
317 | + # Guess based on the CPU. | ||
318 | + case "$host_cpu" in | ||
319 | + alpha* | i[34567]86 | m68k | s390*) | ||
320 | + gt_cv_int_divbyzero_sigfpe="guessing yes";; | ||
321 | + *) | ||
322 | + gt_cv_int_divbyzero_sigfpe="guessing no";; | ||
323 | + esac | ||
324 | + ]) | ||
325 | + ]) | ||
326 | + case "$gt_cv_int_divbyzero_sigfpe" in | ||
327 | + *yes) value=1;; | ||
328 | + *) value=0;; | ||
329 | + esac | ||
330 | + AC_DEFINE_UNQUOTED(INTDIV0_RAISES_SIGFPE, $value, | ||
331 | + [Define if integer division by zero raises signal SIGFPE.]) | ||
332 | +]) | ||
333 | --- /dev/null | ||
334 | +++ bison-1.875/m4/glib.m4 | ||
335 | @@ -0,0 +1,196 @@ | ||
336 | +# Configure paths for GLIB | ||
337 | +# Owen Taylor 97-11-3 | ||
338 | + | ||
339 | +dnl AM_PATH_GLIB([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]]) | ||
340 | +dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or | ||
341 | +dnl gthread is specified in MODULES, pass to glib-config | ||
342 | +dnl | ||
343 | +AC_DEFUN(AM_PATH_GLIB, | ||
344 | +[dnl | ||
345 | +dnl Get the cflags and libraries from the glib-config script | ||
346 | +dnl | ||
347 | +AC_ARG_WITH(glib-prefix,[ --with-glib-prefix=PFX Prefix where GLIB is installed (optional)], | ||
348 | + glib_config_prefix="$withval", glib_config_prefix="") | ||
349 | +AC_ARG_WITH(glib-exec-prefix,[ --with-glib-exec-prefix=PFX Exec prefix where GLIB is installed (optional)], | ||
350 | + glib_config_exec_prefix="$withval", glib_config_exec_prefix="") | ||
351 | +AC_ARG_ENABLE(glibtest, [ --disable-glibtest Do not try to compile and run a test GLIB program], | ||
352 | + , enable_glibtest=yes) | ||
353 | + | ||
354 | + if test x$glib_config_exec_prefix != x ; then | ||
355 | + glib_config_args="$glib_config_args --exec-prefix=$glib_config_exec_prefix" | ||
356 | + if test x${GLIB_CONFIG+set} != xset ; then | ||
357 | + GLIB_CONFIG=$glib_config_exec_prefix/bin/glib-config | ||
358 | + fi | ||
359 | + fi | ||
360 | + if test x$glib_config_prefix != x ; then | ||
361 | + glib_config_args="$glib_config_args --prefix=$glib_config_prefix" | ||
362 | + if test x${GLIB_CONFIG+set} != xset ; then | ||
363 | + GLIB_CONFIG=$glib_config_prefix/bin/glib-config | ||
364 | + fi | ||
365 | + fi | ||
366 | + | ||
367 | + for module in . $4 | ||
368 | + do | ||
369 | + case "$module" in | ||
370 | + gmodule) | ||
371 | + glib_config_args="$glib_config_args gmodule" | ||
372 | + ;; | ||
373 | + gthread) | ||
374 | + glib_config_args="$glib_config_args gthread" | ||
375 | + ;; | ||
376 | + esac | ||
377 | + done | ||
378 | + | ||
379 | + AC_PATH_PROG(GLIB_CONFIG, glib-config, no) | ||
380 | + min_glib_version=ifelse([$1], ,0.99.7,$1) | ||
381 | + AC_MSG_CHECKING(for GLIB - version >= $min_glib_version) | ||
382 | + no_glib="" | ||
383 | + if test "$GLIB_CONFIG" = "no" ; then | ||
384 | + no_glib=yes | ||
385 | + else | ||
386 | + GLIB_CFLAGS=`$GLIB_CONFIG $glib_config_args --cflags` | ||
387 | + GLIB_LIBS=`$GLIB_CONFIG $glib_config_args --libs` | ||
388 | + glib_config_major_version=`$GLIB_CONFIG $glib_config_args --version | \ | ||
389 | + sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'` | ||
390 | + glib_config_minor_version=`$GLIB_CONFIG $glib_config_args --version | \ | ||
391 | + sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'` | ||
392 | + glib_config_micro_version=`$GLIB_CONFIG $glib_config_args --version | \ | ||
393 | + sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'` | ||
394 | + if test "x$enable_glibtest" = "xyes" ; then | ||
395 | + ac_save_CFLAGS="$CFLAGS" | ||
396 | + ac_save_LIBS="$LIBS" | ||
397 | + CFLAGS="$CFLAGS $GLIB_CFLAGS" | ||
398 | + LIBS="$GLIB_LIBS $LIBS" | ||
399 | +dnl | ||
400 | +dnl Now check if the installed GLIB is sufficiently new. (Also sanity | ||
401 | +dnl checks the results of glib-config to some extent | ||
402 | +dnl | ||
403 | + rm -f conf.glibtest | ||
404 | + AC_TRY_RUN([ | ||
405 | +#include <glib.h> | ||
406 | +#include <stdio.h> | ||
407 | +#include <stdlib.h> | ||
408 | + | ||
409 | +int | ||
410 | +main () | ||
411 | +{ | ||
412 | + int major, minor, micro; | ||
413 | + char *tmp_version; | ||
414 | + | ||
415 | + system ("touch conf.glibtest"); | ||
416 | + | ||
417 | + /* HP/UX 9 (%@#!) writes to sscanf strings */ | ||
418 | + tmp_version = g_strdup("$min_glib_version"); | ||
419 | + if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, µ) != 3) { | ||
420 | + printf("%s, bad version string\n", "$min_glib_version"); | ||
421 | + exit(1); | ||
422 | + } | ||
423 | + | ||
424 | + if ((glib_major_version != $glib_config_major_version) || | ||
425 | + (glib_minor_version != $glib_config_minor_version) || | ||
426 | + (glib_micro_version != $glib_config_micro_version)) | ||
427 | + { | ||
428 | + printf("\n*** 'glib-config --version' returned %d.%d.%d, but GLIB (%d.%d.%d)\n", | ||
429 | + $glib_config_major_version, $glib_config_minor_version, $glib_config_micro_version, | ||
430 | + glib_major_version, glib_minor_version, glib_micro_version); | ||
431 | + printf ("*** was found! If glib-config was correct, then it is best\n"); | ||
432 | + printf ("*** to remove the old version of GLIB. You may also be able to fix the error\n"); | ||
433 | + printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n"); | ||
434 | + printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n"); | ||
435 | + printf("*** required on your system.\n"); | ||
436 | + printf("*** If glib-config was wrong, set the environment variable GLIB_CONFIG\n"); | ||
437 | + printf("*** to point to the correct copy of glib-config, and remove the file config.cache\n"); | ||
438 | + printf("*** before re-running configure\n"); | ||
439 | + } | ||
440 | + else if ((glib_major_version != GLIB_MAJOR_VERSION) || | ||
441 | + (glib_minor_version != GLIB_MINOR_VERSION) || | ||
442 | + (glib_micro_version != GLIB_MICRO_VERSION)) | ||
443 | + { | ||
444 | + printf("*** GLIB header files (version %d.%d.%d) do not match\n", | ||
445 | + GLIB_MAJOR_VERSION, GLIB_MINOR_VERSION, GLIB_MICRO_VERSION); | ||
446 | + printf("*** library (version %d.%d.%d)\n", | ||
447 | + glib_major_version, glib_minor_version, glib_micro_version); | ||
448 | + } | ||
449 | + else | ||
450 | + { | ||
451 | + if ((glib_major_version > major) || | ||
452 | + ((glib_major_version == major) && (glib_minor_version > minor)) || | ||
453 | + ((glib_major_version == major) && (glib_minor_version == minor) && (glib_micro_version >= micro))) | ||
454 | + { | ||
455 | + return 0; | ||
456 | + } | ||
457 | + else | ||
458 | + { | ||
459 | + printf("\n*** An old version of GLIB (%d.%d.%d) was found.\n", | ||
460 | + glib_major_version, glib_minor_version, glib_micro_version); | ||
461 | + printf("*** You need a version of GLIB newer than %d.%d.%d. The latest version of\n", | ||
462 | + major, minor, micro); | ||
463 | + printf("*** GLIB is always available from ftp://ftp.gtk.org.\n"); | ||
464 | + printf("***\n"); | ||
465 | + printf("*** If you have already installed a sufficiently new version, this error\n"); | ||
466 | + printf("*** probably means that the wrong copy of the glib-config shell script is\n"); | ||
467 | + printf("*** being found. The easiest way to fix this is to remove the old version\n"); | ||
468 | + printf("*** of GLIB, but you can also set the GLIB_CONFIG environment to point to the\n"); | ||
469 | + printf("*** correct copy of glib-config. (In this case, you will have to\n"); | ||
470 | + printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n"); | ||
471 | + printf("*** so that the correct libraries are found at run-time))\n"); | ||
472 | + } | ||
473 | + } | ||
474 | + return 1; | ||
475 | +} | ||
476 | +],, no_glib=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"]) | ||
477 | + CFLAGS="$ac_save_CFLAGS" | ||
478 | + LIBS="$ac_save_LIBS" | ||
479 | + fi | ||
480 | + fi | ||
481 | + if test "x$no_glib" = x ; then | ||
482 | + AC_MSG_RESULT(yes) | ||
483 | + ifelse([$2], , :, [$2]) | ||
484 | + else | ||
485 | + AC_MSG_RESULT(no) | ||
486 | + if test "$GLIB_CONFIG" = "no" ; then | ||
487 | + echo "*** The glib-config script installed by GLIB could not be found" | ||
488 | + echo "*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in" | ||
489 | + echo "*** your path, or set the GLIB_CONFIG environment variable to the" | ||
490 | + echo "*** full path to glib-config." | ||
491 | + else | ||
492 | + if test -f conf.glibtest ; then | ||
493 | + : | ||
494 | + else | ||
495 | + echo "*** Could not run GLIB test program, checking why..." | ||
496 | + CFLAGS="$CFLAGS $GLIB_CFLAGS" | ||
497 | + LIBS="$LIBS $GLIB_LIBS" | ||
498 | + AC_TRY_LINK([ | ||
499 | +#include <glib.h> | ||
500 | +#include <stdio.h> | ||
501 | +], [ return ((glib_major_version) || (glib_minor_version) || (glib_micro_version)); ], | ||
502 | + [ echo "*** The test program compiled, but did not run. This usually means" | ||
503 | + echo "*** that the run-time linker is not finding GLIB or finding the wrong" | ||
504 | + echo "*** version of GLIB. If it is not finding GLIB, you'll need to set your" | ||
505 | + echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point" | ||
506 | + echo "*** to the installed location Also, make sure you have run ldconfig if that" | ||
507 | + echo "*** is required on your system" | ||
508 | + echo "***" | ||
509 | + echo "*** If you have an old version installed, it is best to remove it, although" | ||
510 | + echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" | ||
511 | + echo "***" | ||
512 | + echo "*** If you have a RedHat 5.0 system, you should remove the GTK package that" | ||
513 | + echo "*** came with the system with the command" | ||
514 | + echo "***" | ||
515 | + echo "*** rpm --erase --nodeps gtk gtk-devel" ], | ||
516 | + [ echo "*** The test program failed to compile or link. See the file config.log for the" | ||
517 | + echo "*** exact error that occured. This usually means GLIB was incorrectly installed" | ||
518 | + echo "*** or that you have moved GLIB since it was installed. In the latter case, you" | ||
519 | + echo "*** may want to edit the glib-config script: $GLIB_CONFIG" ]) | ||
520 | + CFLAGS="$ac_save_CFLAGS" | ||
521 | + LIBS="$ac_save_LIBS" | ||
522 | + fi | ||
523 | + fi | ||
524 | + GLIB_CFLAGS="" | ||
525 | + GLIB_LIBS="" | ||
526 | + ifelse([$3], , :, [$3]) | ||
527 | + fi | ||
528 | + AC_SUBST(GLIB_CFLAGS) | ||
529 | + AC_SUBST(GLIB_LIBS) | ||
530 | + rm -f conf.glibtest | ||
531 | +]) | ||
532 | --- /dev/null | ||
533 | +++ bison-1.875/m4/inttypes.m4 | ||
534 | @@ -0,0 +1,27 @@ | ||
535 | +# inttypes.m4 serial 1 (gettext-0.11.4) | ||
536 | +dnl Copyright (C) 1997-2002 Free Software Foundation, Inc. | ||
537 | +dnl This file is free software, distributed under the terms of the GNU | ||
538 | +dnl General Public License. As a special exception to the GNU General | ||
539 | +dnl Public License, this file may be distributed as part of a program | ||
540 | +dnl that contains a configuration script generated by Autoconf, under | ||
541 | +dnl the same distribution terms as the rest of that program. | ||
542 | + | ||
543 | +dnl From Paul Eggert. | ||
544 | + | ||
545 | +# Define HAVE_INTTYPES_H if <inttypes.h> exists and doesn't clash with | ||
546 | +# <sys/types.h>. | ||
547 | + | ||
548 | +AC_DEFUN([gt_HEADER_INTTYPES_H], | ||
549 | +[ | ||
550 | + AC_CACHE_CHECK([for inttypes.h], gt_cv_header_inttypes_h, | ||
551 | + [ | ||
552 | + AC_TRY_COMPILE( | ||
553 | + [#include <sys/types.h> | ||
554 | +#include <inttypes.h>], | ||
555 | + [], gt_cv_header_inttypes_h=yes, gt_cv_header_inttypes_h=no) | ||
556 | + ]) | ||
557 | + if test $gt_cv_header_inttypes_h = yes; then | ||
558 | + AC_DEFINE_UNQUOTED(HAVE_INTTYPES_H, 1, | ||
559 | + [Define if <inttypes.h> exists and doesn't clash with <sys/types.h>.]) | ||
560 | + fi | ||
561 | +]) | ||
562 | --- /dev/null | ||
563 | +++ bison-1.875/m4/isc-posix.m4 | ||
564 | @@ -0,0 +1,26 @@ | ||
565 | +# isc-posix.m4 serial 2 (gettext-0.11.2) | ||
566 | +dnl Copyright (C) 1995-2002 Free Software Foundation, Inc. | ||
567 | +dnl This file is free software, distributed under the terms of the GNU | ||
568 | +dnl General Public License. As a special exception to the GNU General | ||
569 | +dnl Public License, this file may be distributed as part of a program | ||
570 | +dnl that contains a configuration script generated by Autoconf, under | ||
571 | +dnl the same distribution terms as the rest of that program. | ||
572 | + | ||
573 | +# This file is not needed with autoconf-2.53 and newer. Remove it in 2005. | ||
574 | + | ||
575 | +# This test replaces the one in autoconf. | ||
576 | +# Currently this macro should have the same name as the autoconf macro | ||
577 | +# because gettext's gettext.m4 (distributed in the automake package) | ||
578 | +# still uses it. Otherwise, the use in gettext.m4 makes autoheader | ||
579 | +# give these diagnostics: | ||
580 | +# configure.in:556: AC_TRY_COMPILE was called before AC_ISC_POSIX | ||
581 | +# configure.in:556: AC_TRY_RUN was called before AC_ISC_POSIX | ||
582 | + | ||
583 | +undefine([AC_ISC_POSIX]) | ||
584 | + | ||
585 | +AC_DEFUN([AC_ISC_POSIX], | ||
586 | + [ | ||
587 | + dnl This test replaces the obsolescent AC_ISC_POSIX kludge. | ||
588 | + AC_CHECK_LIB(cposix, strerror, [LIBS="$LIBS -lcposix"]) | ||
589 | + ] | ||
590 | +) | ||
591 | |||