diff options
-rw-r--r-- | recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch | 32 | ||||
-rw-r--r-- | recipes-extended/diffutils/diffutils_2.8.1.bb | 4 |
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch b/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch new file mode 100644 index 0000000..dc03aa6 --- /dev/null +++ b/recipes-extended/diffutils/diffutils-2.8.1/0001-Make-it-build-with-compile-time-hardening-enabled.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 7448c928240aafbfec08a92530a150bc206673bf Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Kjellerstedt <pkj@axis.com> | ||
3 | Date: Thu, 26 Apr 2018 02:40:52 +0200 | ||
4 | Subject: [PATCH] Make it build with compile time hardening enabled | ||
5 | |||
6 | This avoids the following error: | ||
7 | |||
8 | src/diff3.c: In function 'output_diff3': | ||
9 | src/diff3.c:1405:5: error: format not a string literal and no format | ||
10 | arguments [-Werror=format-security] | ||
11 | fprintf (outputfile, line_prefix); | ||
12 | ^~~~~~~ | ||
13 | |||
14 | Upstream-Status: Inappropriate [legacy version] | ||
15 | Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> | ||
16 | --- | ||
17 | src/diff3.c | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/src/diff3.c b/src/diff3.c | ||
21 | index f3d3dcf..7237dea 100644 | ||
22 | --- a/src/diff3.c | ||
23 | +++ b/src/diff3.c | ||
24 | @@ -1402,7 +1402,7 @@ output_diff3 (FILE *outputfile, struct diff3_block *diff, | ||
25 | line = 0; | ||
26 | do | ||
27 | { | ||
28 | - fprintf (outputfile, line_prefix); | ||
29 | + fprintf (outputfile, "%s", line_prefix); | ||
30 | cp = D_RELNUM (ptr, realfile, line); | ||
31 | length = D_RELLEN (ptr, realfile, line); | ||
32 | fwrite (cp, sizeof (char), length, outputfile); | ||
diff --git a/recipes-extended/diffutils/diffutils_2.8.1.bb b/recipes-extended/diffutils/diffutils_2.8.1.bb index fe56f9c..466bf28 100644 --- a/recipes-extended/diffutils/diffutils_2.8.1.bb +++ b/recipes-extended/diffutils/diffutils_2.8.1.bb | |||
@@ -7,7 +7,9 @@ PR = "r7.0" | |||
7 | 7 | ||
8 | SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \ | 8 | SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.gz \ |
9 | file://diffutils_fix_for_automake-1.12.patch \ | 9 | file://diffutils_fix_for_automake-1.12.patch \ |
10 | file://fix_gcc6.patch" | 10 | file://fix_gcc6.patch \ |
11 | file://0001-Make-it-build-with-compile-time-hardening-enabled.patch \ | ||
12 | " | ||
11 | 13 | ||
12 | SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428" | 14 | SRC_URI[md5sum] = "71f9c5ae19b60608f6c7f162da86a428" |
13 | SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a" | 15 | SRC_URI[sha256sum] = "c5001748b069224dd98bf1bb9ee877321c7de8b332c8aad5af3e2a7372d23f5a" |