diff options
-rw-r--r-- | recipes-extended/bc/bc_1.06.bb | 26 | ||||
-rw-r--r-- | recipes-extended/bc/files/fix-segment-fault.patch | 28 |
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-extended/bc/bc_1.06.bb b/recipes-extended/bc/bc_1.06.bb new file mode 100644 index 0000000..d8c8a86 --- /dev/null +++ b/recipes-extended/bc/bc_1.06.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "Arbitrary precision calculator language" | ||
2 | HOMEPAGE = "http://www.gnu.org/software/bc/bc.html" | ||
3 | |||
4 | LICENSE = "GPLv2+ & LGPLv2.1" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
6 | file://COPYING.LIB;md5=d8045f3b8f929c1cb29a1e3fd737b499 \ | ||
7 | file://bc/bcdefs.h;endline=31;md5=46dffdaf10a99728dd8ce358e45d46d8 \ | ||
8 | file://dc/dc.h;endline=25;md5=2f9c558cdd80e31b4d904e48c2374328 \ | ||
9 | file://lib/number.c;endline=31;md5=99434a0898abca7784acfd36b8191199" | ||
10 | |||
11 | SECTION = "base" | ||
12 | DEPENDS = "flex" | ||
13 | PR = "r3" | ||
14 | |||
15 | SRC_URI = "${GNU_MIRROR}/bc/bc-${PV}.tar.gz \ | ||
16 | file://fix-segment-fault.patch " | ||
17 | |||
18 | SRC_URI[md5sum] = "d44b5dddebd8a7a7309aea6c36fda117" | ||
19 | SRC_URI[sha256sum] = "4ef6d9f17c3c0d92d8798e35666175ecd3d8efac4009d6457b5c99cea72c0e33" | ||
20 | |||
21 | inherit autotools texinfo update-alternatives | ||
22 | |||
23 | ALTERNATIVE_${PN} = "dc" | ||
24 | ALTERNATIVE_PRIORITY = "100" | ||
25 | |||
26 | BBCLASSEXTEND = "native" | ||
diff --git a/recipes-extended/bc/files/fix-segment-fault.patch b/recipes-extended/bc/files/fix-segment-fault.patch new file mode 100644 index 0000000..20c0da2 --- /dev/null +++ b/recipes-extended/bc/files/fix-segment-fault.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | when run command such as 'echo "a = 13" | bc -l', it segmentation faults. | ||
4 | This patch is from http://www.mail-archive.com/blfs-support@linuxfromscratch.org/msg04602.html. | ||
5 | |||
6 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
7 | |||
8 | --- bc-1.06/lib/number.c.orig 2003-09-26 21:14:02.000000000 +0000 | ||
9 | +++ bc-1.06/lib/number.c 2003-09-26 21:14:26.000000000 +0000 | ||
10 | @@ -34,6 +34,7 @@ | ||
11 | #include <number.h> | ||
12 | #include <assert.h> | ||
13 | #include <stdlib.h> | ||
14 | +#include <string.h> | ||
15 | #include <ctype.h>/* Prototypes needed for external utility routines. */ | ||
16 | |||
17 | #define bc_rt_warn rt_warn | ||
18 | --- bc-1.06/bc/load.c.orig 2003-09-26 21:14:14.000000000 +0000 | ||
19 | +++ bc-1.06/bc/load.c 2003-09-26 21:14:26.000000000 +0000 | ||
20 | @@ -156,7 +156,7 @@ | ||
21 | long label_no; | ||
22 | long vaf_name; /* variable, array or function number. */ | ||
23 | long func; | ||
24 | - program_counter save_adr; | ||
25 | + static program_counter save_adr; | ||
26 | |||
27 | /* Initialize. */ | ||
28 | str = code; | ||