diff options
-rw-r--r-- | recipes-core/gettext/gettext_0.16.1.bb | 8 | ||||
-rw-r--r-- | recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch | 91 | ||||
-rw-r--r-- | recipes-devtools/elfutils/elfutils_0.148.bb | 9 | ||||
-rw-r--r-- | recipes-devtools/m4/m4.inc | 1 | ||||
-rw-r--r-- | recipes-devtools/mtools/mtools_3.9.9.bb | 2 | ||||
-rw-r--r-- | recipes-extended/findutils/findutils.inc | 7 | ||||
-rw-r--r-- | recipes-support/gnutls/gnutls.inc | 1 |
7 files changed, 2 insertions, 117 deletions
diff --git a/recipes-core/gettext/gettext_0.16.1.bb b/recipes-core/gettext/gettext_0.16.1.bb index dacdfd3..1907ea5 100644 --- a/recipes-core/gettext/gettext_0.16.1.bb +++ b/recipes-core/gettext/gettext_0.16.1.bb | |||
@@ -27,8 +27,6 @@ SRC_URI[sha256sum] = "0bf850d1a079fb5a61f0a47b1a9efd35eb44032255375e1cedb0253bc2 | |||
27 | 27 | ||
28 | PARALLEL_MAKE = "" | 28 | PARALLEL_MAKE = "" |
29 | 29 | ||
30 | LDFLAGS_prepend_libc-uclibc = " -lrt -lpthread " | ||
31 | |||
32 | inherit autotools texinfo | 30 | inherit autotools texinfo |
33 | 31 | ||
34 | EXTRA_OECONF += "--without-lispdir \ | 32 | EXTRA_OECONF += "--without-lispdir \ |
@@ -81,15 +79,9 @@ FILES_gettext-runtime = "${bindir}/gettext \ | |||
81 | ${libdir}/libasprintf${SODEV} \ | 79 | ${libdir}/libasprintf${SODEV} \ |
82 | ${libdir}/GNU.Gettext.dll \ | 80 | ${libdir}/GNU.Gettext.dll \ |
83 | " | 81 | " |
84 | FILES_gettext-runtime_append_libc-uclibc = " ${libdir}/libintl.so.* \ | ||
85 | ${libdir}/charset.alias \ | ||
86 | " | ||
87 | FILES_gettext-runtime-staticdev += "${libdir}/libasprintf.a" | 82 | FILES_gettext-runtime-staticdev += "${libdir}/libasprintf.a" |
88 | FILES_gettext-runtime-dev += "${includedir}/autosprintf.h \ | 83 | FILES_gettext-runtime-dev += "${includedir}/autosprintf.h \ |
89 | ${libdir}/libasprintf${SOLIBDEV}" | 84 | ${libdir}/libasprintf${SOLIBDEV}" |
90 | FILES_gettext-runtime-dev_append_libc-uclibc = " ${libdir}/libintl.so \ | ||
91 | ${includedir}/libintl.h \ | ||
92 | " | ||
93 | FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \ | 85 | FILES_gettext-runtime-doc = "${mandir}/man1/gettext.* \ |
94 | ${mandir}/man1/ngettext.* \ | 86 | ${mandir}/man1/ngettext.* \ |
95 | ${mandir}/man1/envsubst.* \ | 87 | ${mandir}/man1/envsubst.* \ |
diff --git a/recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch b/recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch deleted file mode 100644 index 3cf16ac..0000000 --- a/recipes-devtools/elfutils/elfutils-0.148/uclibc-support-for-elfutils-0.148.patch +++ /dev/null | |||
@@ -1,91 +0,0 @@ | |||
1 | on uclibc systems libintl and libuargp are separate from libc. | ||
2 | so they need to be specified on commandline when we use proxy-libintl | ||
3 | then libintl is a static archive so it should be listed last since | ||
4 | elfutils does not respect disable-nls we need to link in libintl | ||
5 | |||
6 | We add a new option --enable-uclibc which will be used to control | ||
7 | the uclibc specific configurations during build. | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem> | ||
10 | |||
11 | Upstream-Status: Inappropriate [uclibc specific] | ||
12 | |||
13 | Index: elfutils-0.148/configure.ac | ||
14 | =================================================================== | ||
15 | --- elfutils-0.148.orig/configure.ac | ||
16 | +++ elfutils-0.148/configure.ac | ||
17 | @@ -55,9 +55,16 @@ AS_IF([test "$use_locks" = yes], [AC_DEF | ||
18 | |||
19 | AH_TEMPLATE([USE_LOCKS], [Defined if libraries should be thread-safe.]) | ||
20 | |||
21 | +AC_ARG_ENABLE([uclibc], | ||
22 | +AS_HELP_STRING([--enable-uclibc], [Use uclibc for system libraries]), | ||
23 | +use_uclibc=yes, use_uclibc=no) | ||
24 | +AM_CONDITIONAL(USE_UCLIBC, test "$use_uclibc" = yes) | ||
25 | +AS_IF([test "$use_uclibc" = yes], [AC_DEFINE(USE_UCLIBC)]) | ||
26 | + | ||
27 | +AH_TEMPLATE([USE_UCLIBC], [Defined if uclibc libraries are used.]) | ||
28 | + | ||
29 | dnl Add all the languages for which translations are available. | ||
30 | ALL_LINGUAS= | ||
31 | - | ||
32 | AC_PROG_CC | ||
33 | AC_PROG_RANLIB | ||
34 | AC_PROG_YACC | ||
35 | Index: elfutils-0.148/libelf/Makefile.am | ||
36 | =================================================================== | ||
37 | --- elfutils-0.148.orig/libelf/Makefile.am | ||
38 | +++ elfutils-0.148/libelf/Makefile.am | ||
39 | @@ -93,7 +93,12 @@ if !MUDFLAP | ||
40 | libelf_pic_a_SOURCES = | ||
41 | am_libelf_pic_a_OBJECTS = $(libelf_a_SOURCES:.c=.os) | ||
42 | |||
43 | + | ||
44 | libelf_so_LDLIBS = | ||
45 | +if USE_UCLIBC | ||
46 | +libelf_so_LDLIBS += -lintl -luargp | ||
47 | +endif | ||
48 | + | ||
49 | if USE_LOCKS | ||
50 | libelf_so_LDLIBS += -lpthread | ||
51 | endif | ||
52 | Index: elfutils-0.148/libdw/Makefile.am | ||
53 | =================================================================== | ||
54 | --- elfutils-0.148.orig/libdw/Makefile.am | ||
55 | +++ elfutils-0.148/libdw/Makefile.am | ||
56 | @@ -98,6 +98,11 @@ if !MUDFLAP | ||
57 | libdw_pic_a_SOURCES = | ||
58 | am_libdw_pic_a_OBJECTS = $(libdw_a_SOURCES:.c=.os) | ||
59 | |||
60 | +libdw_so_LDLIBS = | ||
61 | +if USE_UCLIBC | ||
62 | +libdw_so_LDLIBS += -lintl -luargp | ||
63 | +endif | ||
64 | + | ||
65 | libdw_so_SOURCES = | ||
66 | libdw.so: $(srcdir)/libdw.map libdw_pic.a \ | ||
67 | ../libdwfl/libdwfl_pic.a ../libebl/libebl.a \ | ||
68 | @@ -108,7 +113,7 @@ libdw.so: $(srcdir)/libdw.map libdw_pic. | ||
69 | -Wl,--enable-new-dtags,-rpath,$(pkglibdir) \ | ||
70 | -Wl,--version-script,$<,--no-undefined \ | ||
71 | -Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\ | ||
72 | - -ldl $(zip_LIBS) | ||
73 | + -ldl $(zip_LIBS) $(libdw_so_LDLIBS) | ||
74 | if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi | ||
75 | ln -fs $@ $@.$(VERSION) | ||
76 | |||
77 | Index: elfutils-0.148/libcpu/Makefile.am | ||
78 | =================================================================== | ||
79 | --- elfutils-0.148.orig/libcpu/Makefile.am | ||
80 | +++ elfutils-0.148/libcpu/Makefile.am | ||
81 | @@ -63,6 +63,10 @@ i386_parse_CFLAGS = -DNMNES="`wc -l < i3 | ||
82 | i386_lex.o: i386_parse.h | ||
83 | i386_gendis_LDADD = $(libeu) -lm $(libmudflap) | ||
84 | |||
85 | +if USE_UCLIBC | ||
86 | +i386_gendis_LDADD += -luargp -lintl | ||
87 | +endif | ||
88 | + | ||
89 | i386_parse.h: i386_parse.c ; | ||
90 | |||
91 | noinst_HEADERS = memory-access.h i386_parse.h i386_data.h | ||
diff --git a/recipes-devtools/elfutils/elfutils_0.148.bb b/recipes-devtools/elfutils/elfutils_0.148.bb index 654a715..3c0f9f0 100644 --- a/recipes-devtools/elfutils/elfutils_0.148.bb +++ b/recipes-devtools/elfutils/elfutils_0.148.bb | |||
@@ -44,9 +44,6 @@ SRC_URI += "\ | |||
44 | # Only apply when building musl based target recipe | 44 | # Only apply when building musl based target recipe |
45 | SRC_URI_append_libc-musl = " file://musl-support-for-elfutils-0.148.patch" | 45 | SRC_URI_append_libc-musl = " file://musl-support-for-elfutils-0.148.patch" |
46 | 46 | ||
47 | # Only apply when building uclibc based target recipe | ||
48 | SRC_URI_append_libc-uclibc = " file://uclibc-support-for-elfutils-0.148.patch" | ||
49 | |||
50 | # The buildsystem wants to generate 2 .h files from source using a binary it just built, | 47 | # The buildsystem wants to generate 2 .h files from source using a binary it just built, |
51 | # which can not pass the cross compiling, so let's work around it by adding 2 .h files | 48 | # which can not pass the cross compiling, so let's work around it by adding 2 .h files |
52 | # along with the do_configure_prepend() | 49 | # along with the do_configure_prepend() |
@@ -71,7 +68,6 @@ CFLAGS += "-Wno-error=stringop-overflow=" | |||
71 | 68 | ||
72 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" | 69 | EXTRA_OECONF = "--program-prefix=eu- --without-lzma" |
73 | EXTRA_OECONF_append_class-native = " --without-bzlib" | 70 | EXTRA_OECONF_append_class-native = " --without-bzlib" |
74 | EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc" | ||
75 | 71 | ||
76 | do_configure_prepend() { | 72 | do_configure_prepend() { |
77 | sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am | 73 | sed -i '/^i386_dis.h:/,+4 {/.*/d}' ${S}/libcpu/Makefile.am |
@@ -79,12 +75,11 @@ do_configure_prepend() { | |||
79 | cp ${WORKDIR}/*dis.h ${S}/libcpu | 75 | cp ${WORKDIR}/*dis.h ${S}/libcpu |
80 | } | 76 | } |
81 | 77 | ||
82 | # we can not build complete elfutils when using uclibc or musl | 78 | # we can not build complete elfutils when using musl |
83 | # but some recipes e.g. gcc 4.5 depends on libelf so we | 79 | # but some recipes e.g. gcc 4.5 depends on libelf so we |
84 | # build only libelf for uclibc and musl cases | 80 | # build only libelf for musl cases |
85 | 81 | ||
86 | EXTRA_OEMAKE_libc-musl = "-C libelf" | 82 | EXTRA_OEMAKE_libc-musl = "-C libelf" |
87 | EXTRA_OEMAKE_libc-uclibc = "-C libelf" | ||
88 | EXTRA_OEMAKE_class-native = "" | 83 | EXTRA_OEMAKE_class-native = "" |
89 | EXTRA_OEMAKE_class-nativesdk = "" | 84 | EXTRA_OEMAKE_class-nativesdk = "" |
90 | 85 | ||
diff --git a/recipes-devtools/m4/m4.inc b/recipes-devtools/m4/m4.inc index 4a83929..75d8bbe 100644 --- a/recipes-devtools/m4/m4.inc +++ b/recipes-devtools/m4/m4.inc | |||
@@ -6,5 +6,4 @@ GNU M4 also has built-in functions for including files, running shell commands, | |||
6 | inherit autotools texinfo | 6 | inherit autotools texinfo |
7 | 7 | ||
8 | EXTRA_OEMAKE += "'infodir=${infodir}'" | 8 | EXTRA_OEMAKE += "'infodir=${infodir}'" |
9 | LDFLAGS_prepend_libc-uclibc = " -lrt " | ||
10 | SRC_URI = "${GNU_MIRROR}/m4/m4-${PV}.tar.gz" | 9 | SRC_URI = "${GNU_MIRROR}/m4/m4-${PV}.tar.gz" |
diff --git a/recipes-devtools/mtools/mtools_3.9.9.bb b/recipes-devtools/mtools/mtools_3.9.9.bb index 2904ff4..d28fc48 100644 --- a/recipes-devtools/mtools/mtools_3.9.9.bb +++ b/recipes-devtools/mtools/mtools_3.9.9.bb | |||
@@ -41,8 +41,6 @@ inherit autotools texinfo | |||
41 | 41 | ||
42 | EXTRA_OECONF = "--without-x" | 42 | EXTRA_OECONF = "--without-x" |
43 | 43 | ||
44 | LDFLAGS_append_libc-uclibc = " -liconv " | ||
45 | |||
46 | BBCLASSEXTEND = "native nativesdk" | 44 | BBCLASSEXTEND = "native nativesdk" |
47 | 45 | ||
48 | PACKAGECONFIG ??= "" | 46 | PACKAGECONFIG ??= "" |
diff --git a/recipes-extended/findutils/findutils.inc b/recipes-extended/findutils/findutils.inc index bfedf87..ad36429 100644 --- a/recipes-extended/findutils/findutils.inc +++ b/recipes-extended/findutils/findutils.inc | |||
@@ -13,11 +13,4 @@ inherit autotools gettext texinfo update-alternatives upstream-version-is-even | |||
13 | ALTERNATIVE_${PN} = "find xargs" | 13 | ALTERNATIVE_${PN} = "find xargs" |
14 | ALTERNATIVE_PRIORITY = "100" | 14 | ALTERNATIVE_PRIORITY = "100" |
15 | 15 | ||
16 | # diffutils assumes non-glibc compilation with uclibc and | ||
17 | # this causes it to generate its own implementations of | ||
18 | # standard functionality. regex.c actually breaks compilation | ||
19 | # because it uses __mempcpy, there are other things (TBD: | ||
20 | # see diffutils.mk in buildroot) | ||
21 | EXTRA_OECONF_libc-uclibc = "--without-included-regex" | ||
22 | |||
23 | BBCLASSEXTEND = "native nativesdk" | 16 | BBCLASSEXTEND = "native nativesdk" |
diff --git a/recipes-support/gnutls/gnutls.inc b/recipes-support/gnutls/gnutls.inc index 428248f..6b46e54 100644 --- a/recipes-support/gnutls/gnutls.inc +++ b/recipes-support/gnutls/gnutls.inc | |||
@@ -39,7 +39,6 @@ EXTRA_OECONF = " \ | |||
39 | " | 39 | " |
40 | 40 | ||
41 | LDFLAGS_append_libc-musl = " -largp" | 41 | LDFLAGS_append_libc-musl = " -largp" |
42 | LDFLAGS_append_libc-uclibc = " -luargp -pthread" | ||
43 | 42 | ||
44 | do_configure_prepend() { | 43 | do_configure_prepend() { |
45 | for dir in . lib; do | 44 | for dir in . lib; do |