diff options
author | Peter Kjellerstedt <pkj@axis.com> | 2020-09-01 00:41:50 +0200 |
---|---|---|
committer | Peter Kjellerstedt <pkj@axis.com> | 2020-09-01 00:43:13 +0200 |
commit | f9761c01495cd52ce88e33fbc8824f882cf80288 (patch) | |
tree | e6983e0bcc88a3e19619162a163af6c96dbe6eaf /recipes-support | |
parent | a8da8eb127a56561bf633ab53bec57fb5dbba537 (diff) | |
download | meta-gplv2-f9761c01495cd52ce88e33fbc8824f882cf80288.tar.gz |
gnupg: Make it build with GCC 10 (which uses -fno-common by default)
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Diffstat (limited to 'recipes-support')
-rw-r--r-- | recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-GCC-10-which-uses-fno-common-by-d.patch | 93 | ||||
-rw-r--r-- | recipes-support/gnupg/gnupg_1.4.7.bb | 3 |
2 files changed, 95 insertions, 1 deletions
diff --git a/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-GCC-10-which-uses-fno-common-by-d.patch b/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-GCC-10-which-uses-fno-common-by-d.patch new file mode 100644 index 0000000..2f84155 --- /dev/null +++ b/recipes-support/gnupg/gnupg-1.4.7/0001-Make-it-build-with-GCC-10-which-uses-fno-common-by-d.patch | |||
@@ -0,0 +1,93 @@ | |||
1 | From 1d0141d77d4f81cfa3213370fb7eeddbf53fc085 Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Kjellerstedt <pkj@axis.com> | ||
3 | Date: Tue, 1 Sep 2020 00:29:22 +0200 | ||
4 | Subject: [PATCH] Make it build with GCC 10 (which uses -fno-common by default) | ||
5 | |||
6 | Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> | ||
7 | --- | ||
8 | g10/options.h | 3 +-- | ||
9 | include/cipher.h | 2 +- | ||
10 | include/iobuf.h | 2 +- | ||
11 | include/memory.h | 2 +- | ||
12 | include/mpi.h | 2 +- | ||
13 | tools/mpicalc.c | 1 + | ||
14 | 6 files changed, 6 insertions(+), 6 deletions(-) | ||
15 | |||
16 | diff --git a/g10/options.h b/g10/options.h | ||
17 | index c5f0f22..33ed333 100644 | ||
18 | --- a/g10/options.h | ||
19 | +++ b/g10/options.h | ||
20 | @@ -28,8 +28,7 @@ | ||
21 | #include "packet.h" | ||
22 | |||
23 | #ifndef EXTERN_UNLESS_MAIN_MODULE | ||
24 | -/* Norcraft can't cope with common symbols */ | ||
25 | -#if defined (__riscos__) && !defined (INCLUDED_BY_MAIN_MODULE) | ||
26 | +#if !defined (INCLUDED_BY_MAIN_MODULE) | ||
27 | #define EXTERN_UNLESS_MAIN_MODULE extern | ||
28 | #else | ||
29 | #define EXTERN_UNLESS_MAIN_MODULE | ||
30 | diff --git a/include/cipher.h b/include/cipher.h | ||
31 | index 168ab41..794c12b 100644 | ||
32 | --- a/include/cipher.h | ||
33 | +++ b/include/cipher.h | ||
34 | @@ -109,7 +109,7 @@ struct gcry_md_context { | ||
35 | typedef struct gcry_md_context *MD_HANDLE; | ||
36 | |||
37 | #ifndef EXTERN_UNLESS_MAIN_MODULE | ||
38 | -#if defined (__riscos__) && !defined (INCLUDED_BY_MAIN_MODULE) | ||
39 | +#if !defined (INCLUDED_BY_MAIN_MODULE) | ||
40 | #define EXTERN_UNLESS_MAIN_MODULE extern | ||
41 | #else | ||
42 | #define EXTERN_UNLESS_MAIN_MODULE | ||
43 | diff --git a/include/iobuf.h b/include/iobuf.h | ||
44 | index a1d58c9..25f682b 100644 | ||
45 | --- a/include/iobuf.h | ||
46 | +++ b/include/iobuf.h | ||
47 | @@ -73,7 +73,7 @@ struct iobuf_struct { | ||
48 | }; | ||
49 | |||
50 | #ifndef EXTERN_UNLESS_MAIN_MODULE | ||
51 | -#if defined (__riscos__) && !defined (INCLUDED_BY_MAIN_MODULE) | ||
52 | +#if !defined (INCLUDED_BY_MAIN_MODULE) | ||
53 | #define EXTERN_UNLESS_MAIN_MODULE extern | ||
54 | #else | ||
55 | #define EXTERN_UNLESS_MAIN_MODULE | ||
56 | diff --git a/include/memory.h b/include/memory.h | ||
57 | index 895d8a7..217d316 100644 | ||
58 | --- a/include/memory.h | ||
59 | +++ b/include/memory.h | ||
60 | @@ -87,7 +87,7 @@ unsigned secmem_get_flags(void); | ||
61 | #define DBG_MEMSTAT memory_stat_debug_mode | ||
62 | |||
63 | #ifndef EXTERN_UNLESS_MAIN_MODULE | ||
64 | -#if defined (__riscos__) && !defined (INCLUDED_BY_MAIN_MODULE) | ||
65 | +#if !defined (INCLUDED_BY_MAIN_MODULE) | ||
66 | #define EXTERN_UNLESS_MAIN_MODULE extern | ||
67 | #else | ||
68 | #define EXTERN_UNLESS_MAIN_MODULE | ||
69 | diff --git a/include/mpi.h b/include/mpi.h | ||
70 | index 81061d3..d529bda 100644 | ||
71 | --- a/include/mpi.h | ||
72 | +++ b/include/mpi.h | ||
73 | @@ -38,7 +38,7 @@ | ||
74 | #include "memory.h" | ||
75 | |||
76 | #ifndef EXTERN_UNLESS_MAIN_MODULE | ||
77 | -#if defined (__riscos__) && !defined (INCLUDED_BY_MAIN_MODULE) | ||
78 | +#if !defined (INCLUDED_BY_MAIN_MODULE) | ||
79 | #define EXTERN_UNLESS_MAIN_MODULE extern | ||
80 | #else | ||
81 | #define EXTERN_UNLESS_MAIN_MODULE | ||
82 | diff --git a/tools/mpicalc.c b/tools/mpicalc.c | ||
83 | index 1df27d9..647dfbd 100644 | ||
84 | --- a/tools/mpicalc.c | ||
85 | +++ b/tools/mpicalc.c | ||
86 | @@ -30,6 +30,7 @@ | ||
87 | #include <stdlib.h> | ||
88 | #include <ctype.h> | ||
89 | |||
90 | +#define INCLUDED_BY_MAIN_MODULE 1 | ||
91 | #include "util.h" | ||
92 | #include "mpi.h" | ||
93 | #include "i18n.h" | ||
diff --git a/recipes-support/gnupg/gnupg_1.4.7.bb b/recipes-support/gnupg/gnupg_1.4.7.bb index 6a950fd..6258809 100644 --- a/recipes-support/gnupg/gnupg_1.4.7.bb +++ b/recipes-support/gnupg/gnupg_1.4.7.bb | |||
@@ -20,7 +20,8 @@ SRC_URI = "${GNUPG_MIRROR}/gnupg/gnupg-${PV}.tar.bz2 \ | |||
20 | file://CVE-2013-4242.patch \ | 20 | file://CVE-2013-4242.patch \ |
21 | file://fix-ustar-check-issue.patch \ | 21 | file://fix-ustar-check-issue.patch \ |
22 | file://0001-Make-it-build-with-gettext-0.20.patch \ | 22 | file://0001-Make-it-build-with-gettext-0.20.patch \ |
23 | " | 23 | file://0001-Make-it-build-with-GCC-10-which-uses-fno-common-by-d.patch \ |
24 | " | ||
24 | 25 | ||
25 | SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c" | 26 | SRC_URI[md5sum] = "b06a141cca5cd1a55bbdd25ab833303c" |
26 | SRC_URI[sha256sum] = "69d18b7d193f62ca27ed4febcb4c9044aa0c95305d3258fe902e2fae5fc6468d" | 27 | SRC_URI[sha256sum] = "69d18b7d193f62ca27ed4febcb4c9044aa0c95305d3258fe902e2fae5fc6468d" |