diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:24:31 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:30:01 +0000 |
commit | 8ba70a1c28a4e0ee73db5308b38abc923b0be44d (patch) | |
tree | 0ed9bff8e4bd70766c81dbb559d32781bdd93ce8 /recipes-support/libiconv/libiconv-1.11.1 | |
download | meta-gplv2-8ba70a1c28a4e0ee73db5308b38abc923b0be44d.tar.gz |
Create meta-gplv2 from files from OE-Core
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-support/libiconv/libiconv-1.11.1')
-rw-r--r-- | recipes-support/libiconv/libiconv-1.11.1/autoconf.patch | 50 | ||||
-rw-r--r-- | recipes-support/libiconv/libiconv-1.11.1/shared_preloadable_libiconv_linux.patch | 26 |
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes-support/libiconv/libiconv-1.11.1/autoconf.patch b/recipes-support/libiconv/libiconv-1.11.1/autoconf.patch new file mode 100644 index 0000000..3cbf549 --- /dev/null +++ b/recipes-support/libiconv/libiconv-1.11.1/autoconf.patch | |||
@@ -0,0 +1,50 @@ | |||
1 | It adds the variables that are needed | ||
2 | for autoconf 2.65 to reconfigure libiconv and defines the m4 macros | ||
3 | directory. Its imported from OE. | ||
4 | |||
5 | Upstream-Status: Pending | ||
6 | |||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | |||
9 | Index: libiconv-1.11.1/configure.ac | ||
10 | =================================================================== | ||
11 | --- libiconv-1.11.1.orig/configure.ac | ||
12 | +++ libiconv-1.11.1/configure.ac | ||
13 | @@ -23,7 +23,7 @@ AC_CONFIG_AUX_DIR(build-aux) | ||
14 | AM_INIT_AUTOMAKE(libiconv, 1.11) | ||
15 | AC_CONFIG_HEADERS(config.h lib/config.h) | ||
16 | AC_PROG_MAKE_SET | ||
17 | - | ||
18 | +AC_CONFIG_MACRO_DIR([m4]) | ||
19 | dnl checks for basic programs | ||
20 | |||
21 | AC_PROG_CC | ||
22 | Index: libiconv-1.11.1/libcharset/configure.ac | ||
23 | =================================================================== | ||
24 | --- libiconv-1.11.1.orig/libcharset/configure.ac | ||
25 | +++ libiconv-1.11.1/libcharset/configure.ac | ||
26 | @@ -16,17 +16,17 @@ dnl along with the GNU CHARSET Library; | ||
27 | dnl write to the Free Software Foundation, Inc., 51 Franklin Street, | ||
28 | dnl Fifth Floor, Boston, MA 02110-1301, USA. | ||
29 | |||
30 | -AC_PREREQ(2.13) | ||
31 | +AC_PREREQ(2.61) | ||
32 | +AC_INIT([libcharset],[1.4] ) | ||
33 | +AC_CONFIG_SRCDIR([lib/localcharset.c]) | ||
34 | |||
35 | -PACKAGE=libcharset | ||
36 | -VERSION=1.4 | ||
37 | - | ||
38 | -AC_INIT(lib/localcharset.c) | ||
39 | AC_CONFIG_AUX_DIR(build-aux) | ||
40 | AC_CONFIG_HEADER(config.h) | ||
41 | AC_PROG_MAKE_SET | ||
42 | -AC_SUBST(PACKAGE) | ||
43 | -AC_SUBST(VERSION) | ||
44 | +dnl AC_SUBST(PACKAGE) | ||
45 | +dnl AC_SUBST(VERSION) | ||
46 | + | ||
47 | +AC_CONFIG_MACRO_DIR([m4]) | ||
48 | |||
49 | dnl checks for basic programs | ||
50 | |||
diff --git a/recipes-support/libiconv/libiconv-1.11.1/shared_preloadable_libiconv_linux.patch b/recipes-support/libiconv/libiconv-1.11.1/shared_preloadable_libiconv_linux.patch new file mode 100644 index 0000000..fb07f73 --- /dev/null +++ b/recipes-support/libiconv/libiconv-1.11.1/shared_preloadable_libiconv_linux.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | With libtool generating shared and static version of libraries needs -fPIC flags | ||
2 | without this it will not generate the commands to create shared linked library | ||
3 | Its more enforced by libtool 2.4. I have not checked it with older libtool | ||
4 | libiconv 1.11.x is relatively old release and libtool 2.4 did not exist when it | ||
5 | was released these kind of problem are more likely | ||
6 | |||
7 | Upstream-Status: Pending | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | |||
11 | Index: libiconv-1.11.1/lib/Makefile.in | ||
12 | =================================================================== | ||
13 | --- libiconv-1.11.1.orig/lib/Makefile.in | ||
14 | +++ libiconv-1.11.1/lib/Makefile.in | ||
15 | @@ -70,9 +70,9 @@ preloadable_libiconv.so : preloadable_li | ||
16 | |||
17 | preloadable_libiconv_linux.so : $(SOURCES) | ||
18 | if test -n "@GCC@"; then \ | ||
19 | - $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \ | ||
20 | + $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -rpath $(libdir) -o libpreload_iconv.la && cp .libs/libpreload_iconv.so preloadable_libiconv_linux.so; \ | ||
21 | else \ | ||
22 | - $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \ | ||
23 | + $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -rpath $(libdir) -o libpreload_iconv.la && cp .libs/libpreload_iconv.so preloadable_libiconv_linux.so; \ | ||
24 | fi | ||
25 | |||
26 | preloadable_libiconv_solaris.so : $(SOURCES) | ||