summaryrefslogtreecommitdiffstats
path: root/recipes-sato
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 12:24:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 12:30:01 +0000
commit8ba70a1c28a4e0ee73db5308b38abc923b0be44d (patch)
tree0ed9bff8e4bd70766c81dbb559d32781bdd93ce8 /recipes-sato
downloadmeta-gplv2-8ba70a1c28a4e0ee73db5308b38abc923b0be44d.tar.gz
Create meta-gplv2 from files from OE-Core
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-sato')
-rw-r--r--recipes-sato/rxvt-unicode.inc58
-rw-r--r--recipes-sato/rxvt-unicode/rxvt.desktop9
-rw-r--r--recipes-sato/rxvt-unicode/rxvt.pngbin0 -> 2847 bytes
-rw-r--r--recipes-sato/rxvt-unicode/xwc.patch26
-rw-r--r--recipes-sato/rxvt-unicode_9.20.bb8
5 files changed, 101 insertions, 0 deletions
diff --git a/recipes-sato/rxvt-unicode.inc b/recipes-sato/rxvt-unicode.inc
new file mode 100644
index 0000000..4d5daa6
--- /dev/null
+++ b/recipes-sato/rxvt-unicode.inc
@@ -0,0 +1,58 @@
1SECTION = "x11/utils"
2SUMMARY = "rxvt terminal clone supporting unicode"
3DESCRIPTION = "rxvt-unicode is a clone of the well known \
4terminal emulator rxvt, modified to store text in Unicode \
5(either UCS-2 or UCS-4) and to use locale-correct input and \
6output. It also supports mixing multiple fonts at the \
7same time, including Xft fonts."
8DEPENDS = "virtual/libx11 libxt libxft gdk-pixbuf libxmu"
9
10SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
11 file://xwc.patch \
12 file://rxvt.desktop \
13 file://rxvt.png"
14
15inherit autotools update-alternatives
16
17PROVIDES = "virtual/x-terminal-emulator"
18ALTERNATIVE_${PN} = "x-terminal-emulator"
19ALTERNATIVE_TARGET[x-terminal-emulator] = "${bindir}/rxvt"
20
21CFLAGS_append = " -fpermissive"
22
23EXTRA_OECONF = "--enable-xim \
24 --enable-utmp --enable-wtmp --enable-lastlog \
25 --with-term=rxvt --enable-keepscrolling \
26 --enable-xft --with-name=rxvt --enable-frills \
27 --enable-swapscreen --enable-transparency \
28 --with-codesets=eu --enable-pointer-blank \
29 --enable-text-blink --enable-rxvt-scroll \
30 --enable-combining --disable-perl \
31 --with-x=${STAGING_DIR_HOST}${prefix}"
32
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[startup] = "--enable-startup-notification,--disable-startup-notification,startup-notification,"
35
36do_configure_prepend () {
37 if [ ! -e ${S}/acinclude.m4 ]; then
38 cp ${S}/aclocal.m4 ${S}/acinclude.m4
39 fi
40}
41
42do_compile_prepend () {
43 echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
44 echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
45 echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
46 echo '#define HAVE_XLOCALE 1' >> config.h
47}
48
49do_install_append () {
50 install -d ${D}/${datadir}
51 install -d ${D}/${datadir}/applications
52 install -d ${D}/${datadir}/pixmaps/
53
54 install -m 0644 ${WORKDIR}/rxvt.png ${D}/${datadir}/pixmaps
55 install -m 0644 ${WORKDIR}/rxvt.desktop ${D}/${datadir}/applications
56}
57
58FILES_${PN} += "${datadir}/applications/rxvt.desktop ${datadir}/pixmaps/rxvt.png"
diff --git a/recipes-sato/rxvt-unicode/rxvt.desktop b/recipes-sato/rxvt-unicode/rxvt.desktop
new file mode 100644
index 0000000..882ea41
--- /dev/null
+++ b/recipes-sato/rxvt-unicode/rxvt.desktop
@@ -0,0 +1,9 @@
1[Desktop Entry]
2Version=1.0
3Name=Terminal
4Comment=A unicode capable rxvt clone
5Exec=rxvt
6Icon=terminal
7Terminal=false
8Type=Application
9Categories=Utility;TerminalEmulator;
diff --git a/recipes-sato/rxvt-unicode/rxvt.png b/recipes-sato/rxvt-unicode/rxvt.png
new file mode 100644
index 0000000..e56fa2e
--- /dev/null
+++ b/recipes-sato/rxvt-unicode/rxvt.png
Binary files differ
diff --git a/recipes-sato/rxvt-unicode/xwc.patch b/recipes-sato/rxvt-unicode/xwc.patch
new file mode 100644
index 0000000..16efeef
--- /dev/null
+++ b/recipes-sato/rxvt-unicode/xwc.patch
@@ -0,0 +1,26 @@
1Upstream-Status: Pending
2
3diff -ruN rxvt-unicode-9.10-orig//src/screen.C rxvt-unicode-9.10/src/screen.C
4--- rxvt-unicode-9.10-orig//src/screen.C 2011-04-19 13:34:01.327664984 +0800
5+++ rxvt-unicode-9.10/src/screen.C 2011-04-19 13:34:47.037665001 +0800
6@@ -3152,7 +3152,7 @@
7 return false;
8 }
9
10-#if 0
11+#if HAVE_XWC
12 XTextProperty ct;
13
14 if (XwcTextListToTextProperty (dpy, &selection.text, 1, XStringStyle, &ct) >= 0)
15@@ -3734,9 +3734,11 @@
16 }
17 else
18 #endif
19+#ifdef HAVE_XWC
20 if (XwcTextListToTextProperty (dpy, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
21 freect = 1;
22 else
23+#endif
24 {
25 /* if we failed to convert then send it raw */
26 ct.value = (unsigned char *)cl;
diff --git a/recipes-sato/rxvt-unicode_9.20.bb b/recipes-sato/rxvt-unicode_9.20.bb
new file mode 100644
index 0000000..3480ec7
--- /dev/null
+++ b/recipes-sato/rxvt-unicode_9.20.bb
@@ -0,0 +1,8 @@
1require rxvt-unicode.inc
2
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432"
6
7SRC_URI[md5sum] = "4a5b823f08d21036f94a6c51e94d025b"
8SRC_URI[sha256sum] = "e73e13fe64b59fd3c8e6e20c00f149d388741f141b8155e4700d3ed40aa94b4e"