diff options
author | Peter Kjellerstedt <pkj@axis.com> | 2018-04-26 01:34:46 +0200 |
---|---|---|
committer | Peter Kjellerstedt <pkj@axis.com> | 2018-04-26 01:34:46 +0200 |
commit | 1f34027fbefbe24b4edd56fd1797e5f23a4ea50c (patch) | |
tree | b83af490fe9c9d84f8ba5df7ad96d4c1805476ba /recipes-sato/rxvt-unicode | |
parent | be45b95616c3bcf9a048c7d76db8ab08009140f3 (diff) | |
download | meta-gplv2-1f34027fbefbe24b4edd56fd1797e5f23a4ea50c.tar.gz |
rxvt-unicode: Make it build with C++11
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Diffstat (limited to 'recipes-sato/rxvt-unicode')
-rw-r--r-- | recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch | 24 | ||||
-rw-r--r-- | recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb | 2 |
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch b/recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch new file mode 100644 index 0000000..408d6a0 --- /dev/null +++ b/recipes-sato/rxvt-unicode/rxvt-unicode/0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | From a92a8b8e7a197a112f41e41ccac77541fd887eb9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Kjellerstedt <pkj@axis.com> | ||
3 | Date: Thu, 26 Apr 2018 01:25:06 +0200 | ||
4 | Subject: [PATCH] libptytty: Correct a typo to make it build with C++11 | ||
5 | |||
6 | Upstream-Status: Backport | ||
7 | Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> | ||
8 | --- | ||
9 | libptytty/src/estl.h | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | diff --git a/libptytty/src/estl.h b/libptytty/src/estl.h | ||
13 | index 9552238..4e47392 100644 | ||
14 | --- a/libptytty/src/estl.h | ||
15 | +++ b/libptytty/src/estl.h | ||
16 | @@ -67,7 +67,7 @@ private: | ||
17 | { | ||
18 | #if __cplusplus >= 201103L | ||
19 | return std::is_trivially_assignable<T, T>::value | ||
20 | - && std::is_trivially_constructable<T>::value | ||
21 | + && std::is_trivially_constructible<T>::value | ||
22 | && std::is_trivially_copyable<T>::value | ||
23 | && std::is_trivially_destructible<T>::value; | ||
24 | #elif ECB_GCC_VERSION(4,4) | ||
diff --git a/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb b/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb index 3480ec7..1f83559 100644 --- a/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb +++ b/recipes-sato/rxvt-unicode/rxvt-unicode_9.20.bb | |||
@@ -4,5 +4,7 @@ LICENSE = "GPLv2+" | |||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
5 | file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432" | 5 | file://src/main.C;beginline=1;endline=31;md5=775485398a09fa7aee6f90464af88432" |
6 | 6 | ||
7 | SRC_URI += "file://0001-libptytty-Correct-a-typo-to-make-it-build-with-C-11.patch" | ||
8 | |||
7 | SRC_URI[md5sum] = "4a5b823f08d21036f94a6c51e94d025b" | 9 | SRC_URI[md5sum] = "4a5b823f08d21036f94a6c51e94d025b" |
8 | SRC_URI[sha256sum] = "e73e13fe64b59fd3c8e6e20c00f149d388741f141b8155e4700d3ed40aa94b4e" | 10 | SRC_URI[sha256sum] = "e73e13fe64b59fd3c8e6e20c00f149d388741f141b8155e4700d3ed40aa94b4e" |