summaryrefslogtreecommitdiffstats
path: root/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-12-17 16:59:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-18 00:08:29 +0000
commitb70edeaaa1696e5047cf0a27cbdddde2dd608a1d (patch)
tree2273c05d3be62799902f290516f4b0d618777b5e /recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
parent25898f0fbd44ea7636bd59549fb8b3989d6efea2 (diff)
downloadmeta-gplv2-b70edeaaa1696e5047cf0a27cbdddde2dd608a1d.tar.gz
mc: fix builds with gettext 0.20
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch')
-rw-r--r--recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch b/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
new file mode 100644
index 0000000..dbf18ca
--- /dev/null
+++ b/recipes-extended/mc/mc/0001-Fix-builds-wit-the-gettext-0.20.patch
@@ -0,0 +1,52 @@
1From 56aef108be94019c7828c14f0c4849336f811847 Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Tue, 17 Dec 2019 16:34:06 +0100
4Subject: [PATCH] Fix builds wit the gettext 0.20
5
6Upstream-Status: Inappropriate [fixing an old version]
7Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
8---
9 Makefile.am | 2 +-
10 configure.ac | 2 +-
11 src/Makefile.am | 2 +-
12 3 files changed, 3 insertions(+), 3 deletions(-)
13
14diff --git a/Makefile.am b/Makefile.am
15index ab4f9b7..b27ab4a 100644
16--- a/Makefile.am
17+++ b/Makefile.am
18@@ -1,7 +1,7 @@
19 ## Process this file with automake to create Makefile.in.
20 AUTOMAKE_OPTIONS = 1.5
21
22-SUBDIRS = intl po lib src doc contrib misc
23+SUBDIRS = po lib src doc contrib misc
24
25 EXTRA_DIST =
26
27diff --git a/configure.ac b/configure.ac
28index c05902d..0430714 100644
29--- a/configure.ac
30+++ b/configure.ac
31@@ -88,7 +88,7 @@ fi
32 dnl
33 dnl Internationalization
34 dnl
35-AM_GNU_GETTEXT(no-libtool, need-ngettext)
36+AM_GNU_GETTEXT([external],no-libtool, need-ngettext)
37 AM_GNU_GETTEXT_VERSION(0.14.3)
38
39 if test "x$USE_INCLUDED_LIBINTL" = xyes; then
40diff --git a/src/Makefile.am b/src/Makefile.am
41index 2da86c3..1859f0d 100644
42--- a/src/Makefile.am
43+++ b/src/Makefile.am
44@@ -52,7 +52,7 @@ else
45 mc_LDADD += $(GLIB_LIBS)
46 endif
47
48-mc_LDADD += $(PCRE_LIBS) $(LIBICONV) $(INTLLIBS)
49+mc_LDADD += $(PCRE_LIBS) $(INTLLIBS)
50
51 SRC_mc_conssaver = \
52 cons.handler.c consaver/cons.saver.h