summaryrefslogtreecommitdiffstats
path: root/recipes-extended/gzip
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 12:24:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 12:30:01 +0000
commit8ba70a1c28a4e0ee73db5308b38abc923b0be44d (patch)
tree0ed9bff8e4bd70766c81dbb559d32781bdd93ce8 /recipes-extended/gzip
downloadmeta-gplv2-8ba70a1c28a4e0ee73db5308b38abc923b0be44d.tar.gz
Create meta-gplv2 from files from OE-Core
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-extended/gzip')
-rw-r--r--recipes-extended/gzip/gzip-1.3.12/dup-def-fix.patch48
-rw-r--r--recipes-extended/gzip/gzip-1.3.12/m4-extensions-fix.patch56
-rw-r--r--recipes-extended/gzip/gzip.inc33
-rw-r--r--recipes-extended/gzip/gzip_1.3.12.bb15
4 files changed, 152 insertions, 0 deletions
diff --git a/recipes-extended/gzip/gzip-1.3.12/dup-def-fix.patch b/recipes-extended/gzip/gzip-1.3.12/dup-def-fix.patch
new file mode 100644
index 0000000..d9e8d21
--- /dev/null
+++ b/recipes-extended/gzip/gzip-1.3.12/dup-def-fix.patch
@@ -0,0 +1,48 @@
1gzip uses gnulib, whose header conflict with glibc. This patch rename some function to avoid conflict.
2
3Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
4
5Upstream-Status: Inappropriate [licensing]
6
7Index: gzip-1.3.12/gzip.c
8===================================================================
9--- gzip-1.3.12.orig/gzip.c 2010-08-13 10:29:38.000000000 +0800
10+++ gzip-1.3.12/gzip.c 2010-08-13 10:29:44.000000000 +0800
11@@ -1637,7 +1637,7 @@
12 }
13 }
14
15- if (futimens (ofd, ofname, timespec) != 0)
16+ if (futimens_gnulib (ofd, ofname, timespec) != 0)
17 {
18 int e = errno;
19 WARN ((stderr, "%s: ", program_name));
20Index: gzip-1.3.12/lib/utimens.c
21===================================================================
22--- gzip-1.3.12.orig/lib/utimens.c 2010-08-13 10:33:47.000000000 +0800
23+++ gzip-1.3.12/lib/utimens.c 2010-08-13 10:34:02.000000000 +0800
24@@ -75,7 +75,7 @@
25 Return 0 on success, -1 (setting errno) on failure. */
26
27 int
28-futimens (int fd ATTRIBUTE_UNUSED,
29+futimens_gnulib (int fd ATTRIBUTE_UNUSED,
30 char const *file, struct timespec const timespec[2])
31 {
32 /* Some Linux-based NFS clients are buggy, and mishandle time stamps
33@@ -185,5 +185,5 @@
34 int
35 utimens (char const *file, struct timespec const timespec[2])
36 {
37- return futimens (-1, file, timespec);
38+ return futimens_gnulib (-1, file, timespec);
39 }
40Index: gzip-1.3.12/lib/utimens.h
41===================================================================
42--- gzip-1.3.12.orig/lib/utimens.h 2010-08-13 10:14:57.000000000 +0800
43+++ gzip-1.3.12/lib/utimens.h 2010-08-13 10:21:45.000000000 +0800
44@@ -1,3 +1,3 @@
45 #include <time.h>
46-int futimens (int, char const *, struct timespec const [2]);
47+int futimens_gnulib (int, char const *, struct timespec const [2]);
48 int utimens (char const *, struct timespec const [2]);
diff --git a/recipes-extended/gzip/gzip-1.3.12/m4-extensions-fix.patch b/recipes-extended/gzip/gzip-1.3.12/m4-extensions-fix.patch
new file mode 100644
index 0000000..6b2f698
--- /dev/null
+++ b/recipes-extended/gzip/gzip-1.3.12/m4-extensions-fix.patch
@@ -0,0 +1,56 @@
1remove AC_USE_SYSTEM_EXTENSIONS to fix the autoconf error "AC_REQUIRE: circular
2dependency of AC_GNU_SOURCE"
3
4Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
5
6Upstream-Status: Inappropriate [licensing]
7
8Index: gzip-1.3.12/m4/extensions.m4
9===================================================================
10--- gzip-1.3.12.orig/m4/extensions.m4 2010-08-16 14:18:16.000000000 +0800
11+++ gzip-1.3.12/m4/extensions.m4 2010-08-16 14:21:54.000000000 +0800
12@@ -12,44 +12,6 @@
13 # enough in this area it's likely we'll need to redefine
14 # AC_USE_SYSTEM_EXTENSIONS for quite some time.
15
16-# AC_USE_SYSTEM_EXTENSIONS
17-# ------------------------
18-# Enable extensions on systems that normally disable them,
19-# typically due to standards-conformance issues.
20-AC_DEFUN([AC_USE_SYSTEM_EXTENSIONS],
21-[
22- AC_BEFORE([$0], [AC_COMPILE_IFELSE])
23- AC_BEFORE([$0], [AC_RUN_IFELSE])
24-
25- AC_REQUIRE([AC_GNU_SOURCE])
26- AC_REQUIRE([AC_AIX])
27- AC_REQUIRE([AC_MINIX])
28-
29- AH_VERBATIM([__EXTENSIONS__],
30-[/* Enable extensions on Solaris. */
31-#ifndef __EXTENSIONS__
32-# undef __EXTENSIONS__
33-#endif
34-#ifndef _POSIX_PTHREAD_SEMANTICS
35-# undef _POSIX_PTHREAD_SEMANTICS
36-#endif
37-#ifndef _TANDEM_SOURCE
38-# undef _TANDEM_SOURCE
39-#endif])
40- AC_CACHE_CHECK([whether it is safe to define __EXTENSIONS__],
41- [ac_cv_safe_to_define___extensions__],
42- [AC_COMPILE_IFELSE(
43- [AC_LANG_PROGRAM([
44-# define __EXTENSIONS__ 1
45- AC_INCLUDES_DEFAULT])],
46- [ac_cv_safe_to_define___extensions__=yes],
47- [ac_cv_safe_to_define___extensions__=no])])
48- test $ac_cv_safe_to_define___extensions__ = yes &&
49- AC_DEFINE([__EXTENSIONS__])
50- AC_DEFINE([_POSIX_PTHREAD_SEMANTICS])
51- AC_DEFINE([_TANDEM_SOURCE])
52-])
53-
54 # gl_USE_SYSTEM_EXTENSIONS
55 # ------------------------
56 # Enable extensions on systems that normally disable them,
diff --git a/recipes-extended/gzip/gzip.inc b/recipes-extended/gzip/gzip.inc
new file mode 100644
index 0000000..04f8f95
--- /dev/null
+++ b/recipes-extended/gzip/gzip.inc
@@ -0,0 +1,33 @@
1SUMMARY = "Standard GNU compressor"
2DESCRIPTION = "GNU Gzip is a popular data compression program originally written by Jean-loup Gailly for the GNU \
3project. Mark Adler wrote the decompression part"
4HOMEPAGE = "http://www.gnu.org/software/gzip/"
5SECTION = "console/utils"
6# change to GPLv3+ in 2007/07. Previous GPLv2 version is 1.3.12
7
8inherit autotools texinfo
9export DEFS="NO_ASM"
10
11EXTRA_OEMAKE_class-target = "GREP=${base_bindir}/grep"
12EXTRA_OECONF_append_libc-musl = " gl_cv_func_fflush_stdin=yes "
13
14do_install_append () {
15 if [ "${base_bindir}" != "${bindir}" ]; then
16 # Rename and move files into /bin (FHS), which is typical place for gzip
17 install -d ${D}${base_bindir}
18 mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip
19 mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip
20 mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat
21 mv ${D}${bindir}/uncompress ${D}${base_bindir}/uncompress
22 fi
23}
24
25inherit update-alternatives
26
27ALTERNATIVE_PRIORITY = "100"
28ALTERNATIVE_${PN} = "gunzip gzip zcat"
29ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
30ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
31ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
32
33export CONFIG_SHELL="/bin/sh"
diff --git a/recipes-extended/gzip/gzip_1.3.12.bb b/recipes-extended/gzip/gzip_1.3.12.bb
new file mode 100644
index 0000000..e406282
--- /dev/null
+++ b/recipes-extended/gzip/gzip_1.3.12.bb
@@ -0,0 +1,15 @@
1require gzip.inc
2
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
5 file://gzip.h;endline=22;md5=c0934ad1900d927f86556153d4c76d23 \
6 file://lzw.h;endline=19;md5=c273e09a02edd9801cc74d39683049e9 "
7
8SRC_URI = "${GNU_MIRROR}/gzip/gzip-${PV}.tar.gz \
9 file://m4-extensions-fix.patch \
10 file://dup-def-fix.patch"
11
12SRC_URI[md5sum] = "b5bac2d21840ae077e0217bc5e4845b1"
13SRC_URI[sha256sum] = "3f565be05f7f3d1aff117c030eb7c738300510b7d098cedea796ca8e4cd587af"
14
15PR = "r2"