diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:24:31 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-02 12:30:01 +0000 |
commit | 8ba70a1c28a4e0ee73db5308b38abc923b0be44d (patch) | |
tree | 0ed9bff8e4bd70766c81dbb559d32781bdd93ce8 /recipes-extended/gawk | |
download | meta-gplv2-8ba70a1c28a4e0ee73db5308b38abc923b0be44d.tar.gz |
Create meta-gplv2 from files from OE-Core
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-extended/gawk')
3 files changed, 152 insertions, 0 deletions
diff --git a/recipes-extended/gawk/gawk-3.1.5/0001-gawk-fix-non-glibc-gcc-4-compilation.patch b/recipes-extended/gawk/gawk-3.1.5/0001-gawk-fix-non-glibc-gcc-4-compilation.patch new file mode 100644 index 0000000..bc9201b --- /dev/null +++ b/recipes-extended/gawk/gawk-3.1.5/0001-gawk-fix-non-glibc-gcc-4-compilation.patch | |||
@@ -0,0 +1,67 @@ | |||
1 | From 53496e2e306b16ac59801553f775bcca164e6a39 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <git@andred.net> | ||
3 | Date: Wed, 14 Sep 2016 16:20:37 +0100 | ||
4 | Subject: [PATCH] fix gcc >= 4 compilation | ||
5 | |||
6 | | ../gawk-3.1.5/hard-locale.h: In function 'hard_locale': | ||
7 | | ../gawk-3.1.5/hard-locale.h:43:20: error: invalid storage class for function 'xmalloc' | ||
8 | | static ptr_t xmalloc PARAMS ((size_t n)); | ||
9 | | ^~~~~~~ | ||
10 | |||
11 | | ../gawk-3.1.5/hard-locale.h:45:22: warning: implicit declaration of function 'xmalloc' [-Wimplicit-function-declaration] | ||
12 | | char *locale = xmalloc (strlen (p) + 1); | ||
13 | | ^~~~~~~ | ||
14 | | ../gawk-3.1.5/hard-locale.h:45:22: warning: initialization makes pointer from integer without a cast [-Wint-conversion] | ||
15 | | ../gawk-3.1.5/dfa.c: At top level: | ||
16 | | ../gawk-3.1.5/dfa.c:125:14: error: conflicting types for 'xmalloc' | ||
17 | | static ptr_t xmalloc PARAMS ((size_t n)); | ||
18 | | ^~~~~~~ | ||
19 | | In file included from ../gawk-3.1.5/dfa.c:112:0: | ||
20 | | ../gawk-3.1.5/hard-locale.h:45:22: note: previous implicit declaration of 'xmalloc' was here | ||
21 | | char *locale = xmalloc (strlen (p) + 1); | ||
22 | | ^~~~~~~ | ||
23 | |||
24 | Upstream-Status: Inappropriate [required for gawk 3.1.5 (GPLv2) recipe only] | ||
25 | |||
26 | Signed-off-by: André Draszik <git@andred.net> | ||
27 | --- | ||
28 | dfa.c | 2 +- | ||
29 | hard-locale.h | 2 -- | ||
30 | 2 files changed, 1 insertion(+), 3 deletions(-) | ||
31 | |||
32 | diff --git a/dfa.c b/dfa.c | ||
33 | index 71e3736..97f6045 100644 | ||
34 | --- a/dfa.c | ||
35 | +++ b/dfa.c | ||
36 | @@ -109,6 +109,7 @@ extern void free(); | ||
37 | |||
38 | #include "regex.h" | ||
39 | #include "dfa.h" | ||
40 | +static ptr_t xmalloc PARAMS ((size_t n)); | ||
41 | #include "hard-locale.h" | ||
42 | |||
43 | /* HPUX, define those as macros in sys/param.h */ | ||
44 | @@ -122,7 +123,6 @@ extern void free(); | ||
45 | static void dfamust PARAMS ((struct dfa *dfa)); | ||
46 | |||
47 | static ptr_t xcalloc PARAMS ((size_t n, size_t s)); | ||
48 | -static ptr_t xmalloc PARAMS ((size_t n)); | ||
49 | static ptr_t xrealloc PARAMS ((ptr_t p, size_t n)); | ||
50 | #ifdef DEBUG | ||
51 | static void prtok PARAMS ((token t)); | ||
52 | diff --git a/hard-locale.h b/hard-locale.h | ||
53 | index 0f4986b..9ee57e0 100644 | ||
54 | --- a/hard-locale.h | ||
55 | +++ b/hard-locale.h | ||
56 | @@ -40,8 +40,6 @@ hard_locale (int category) | ||
57 | if (strcmp (p, "C") == 0 || strcmp (p, "POSIX") == 0) | ||
58 | hard = 0; | ||
59 | # else | ||
60 | - static ptr_t xmalloc PARAMS ((size_t n)); | ||
61 | - | ||
62 | char *locale = xmalloc (strlen (p) + 1); | ||
63 | strcpy (locale, p); | ||
64 | |||
65 | -- | ||
66 | 2.9.3 | ||
67 | |||
diff --git a/recipes-extended/gawk/gawk-3.1.5/gawk-3.1.5_fix_for_automake-1.12.patch b/recipes-extended/gawk/gawk-3.1.5/gawk-3.1.5_fix_for_automake-1.12.patch new file mode 100644 index 0000000..c42c33c --- /dev/null +++ b/recipes-extended/gawk/gawk-3.1.5/gawk-3.1.5_fix_for_automake-1.12.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | Upstream-Status: Pending | ||
2 | |||
3 | automake 1.12 has depricated automatic de-ANSI-fication support | ||
4 | |||
5 | this patch avoids these kinds of errors: | ||
6 | |||
7 | | configure.ac:127: error: automatic de-ANSI-fication support has been removed | ||
8 | | /srv/home/nitin/builds/build-gcc47/tmp/sysroots/x86_64-linux/usr/share/aclocal-1.12/protos.m4:12: AM_C_PROTOTYPES is expanded from... | ||
9 | | configure.ac:127: the top level | ||
10 | | autom4te: m4 failed with exit status: 1 | ||
11 | ... | ||
12 | | Makefile.am:27: error: automatic de-ANSI-fication support has been removed | ||
13 | |||
14 | Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> | ||
15 | 2012/05/04 | ||
16 | |||
17 | Index: gawk-3.1.5/configure.ac | ||
18 | =================================================================== | ||
19 | --- gawk-3.1.5.orig/configure.ac | ||
20 | +++ gawk-3.1.5/configure.ac | ||
21 | @@ -124,7 +124,6 @@ fi | ||
22 | |||
23 | dnl check for C compiler for automake | ||
24 | AM_PROG_CC_STDC | ||
25 | -AM_C_PROTOTYPES | ||
26 | |||
27 | dnl Cygwin doesn't like to get libs with full paths | ||
28 | dnl since that overrides linking against DLLs. | ||
29 | Index: gawk-3.1.5/Makefile.am | ||
30 | =================================================================== | ||
31 | --- gawk-3.1.5.orig/Makefile.am | ||
32 | +++ gawk-3.1.5/Makefile.am | ||
33 | @@ -24,7 +24,7 @@ | ||
34 | ## process this file with automake to produce Makefile.in | ||
35 | |||
36 | # Automatic de-ANSI-fication if needed, make .bz2 files also. | ||
37 | -AUTOMAKE_OPTIONS = ansi2knr dist-bzip2 | ||
38 | +AUTOMAKE_OPTIONS = dist-bzip2 | ||
39 | |||
40 | # This undocumented variable insures that aclocal runs | ||
41 | # correctly after changing configure.ac | ||
diff --git a/recipes-extended/gawk/gawk_3.1.5.bb b/recipes-extended/gawk/gawk_3.1.5.bb new file mode 100644 index 0000000..63fd32f --- /dev/null +++ b/recipes-extended/gawk/gawk_3.1.5.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "GNU awk text processing utility" | ||
2 | DESCRIPTION = "The GNU version of awk, a text processing utility. \ | ||
3 | Awk interprets a special-purpose programming language to do \ | ||
4 | quick and easy text pattern matching and reformatting jobs." | ||
5 | HOMEPAGE = "www.gnu.org/software/gawk" | ||
6 | BUGTRACKER = "bug-gawk@gnu.org" | ||
7 | SECTION = "console/utils" | ||
8 | |||
9 | # gawk <= 3.1.5: GPLv2 | ||
10 | # gawk >= 3.1.6: GPLv3 | ||
11 | LICENSE = "GPLv2" | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | ||
13 | |||
14 | RDEPENDS_gawk += "gawk-common" | ||
15 | RDEPENDS_pgawk += "gawk-common" | ||
16 | PR = "r2" | ||
17 | |||
18 | SRC_URI = "\ | ||
19 | ${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \ | ||
20 | file://gawk-3.1.5_fix_for_automake-1.12.patch \ | ||
21 | file://0001-gawk-fix-non-glibc-gcc-4-compilation.patch \ | ||
22 | " | ||
23 | |||
24 | SRC_URI[md5sum] = "4760325489479cac17fe0114b8f62f30" | ||
25 | SRC_URI[sha256sum] = "463dcb9d0ca398b1d4f5a332f6cd9cec56441265fca616f2ea1b44d459e9f0f8" | ||
26 | |||
27 | inherit autotools gettext texinfo update-alternatives | ||
28 | |||
29 | PACKAGES += "gawk-common pgawk" | ||
30 | |||
31 | FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk" | ||
32 | FILES_gawk-common += "${datadir}/awk/* ${libexecdir}/awk/*" | ||
33 | FILES_pgawk = "${bindir}/pgawk*" | ||
34 | |||
35 | ALTERNATIVE_${PN} = "awk" | ||
36 | ALTERNATIVE_TARGET[awk] = "${bindir}/gawk" | ||
37 | ALTERNATIVE_PRIORITY = "100" | ||
38 | |||
39 | CFLAGS += "-D PROTOTYPES" | ||
40 | |||
41 | do_install_append() { | ||
42 | # remove the link since we don't package it | ||
43 | rm ${D}${bindir}/awk | ||
44 | } | ||