summaryrefslogtreecommitdiffstats
path: root/recipes-extended/findutils/findutils.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 12:24:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-02 12:30:01 +0000
commit8ba70a1c28a4e0ee73db5308b38abc923b0be44d (patch)
tree0ed9bff8e4bd70766c81dbb559d32781bdd93ce8 /recipes-extended/findutils/findutils.inc
downloadmeta-gplv2-8ba70a1c28a4e0ee73db5308b38abc923b0be44d.tar.gz
Create meta-gplv2 from files from OE-Core
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-extended/findutils/findutils.inc')
-rw-r--r--recipes-extended/findutils/findutils.inc23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-extended/findutils/findutils.inc b/recipes-extended/findutils/findutils.inc
new file mode 100644
index 0000000..bfedf87
--- /dev/null
+++ b/recipes-extended/findutils/findutils.inc
@@ -0,0 +1,23 @@
1SUMMARY = "find, locate, and xargs binaries"
2DESCRIPTION = "The GNU Find Utilities are the basic directory searching utilities of the GNU operating system. \
3These programs are typically used in conjunction with other programs to provide modular and powerful directory \
4search and file locating capabilities to other commands."
5HOMEPAGE = "http://www.gnu.org/software/findutils/"
6BUGTRACKER = "http://savannah.gnu.org/bugs/?group=findutils"
7SECTION = "console/utils"
8
9SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz"
10
11inherit autotools gettext texinfo update-alternatives upstream-version-is-even
12
13ALTERNATIVE_${PN} = "find xargs"
14ALTERNATIVE_PRIORITY = "100"
15
16# diffutils assumes non-glibc compilation with uclibc and
17# this causes it to generate its own implementations of
18# standard functionality. regex.c actually breaks compilation
19# because it uses __mempcpy, there are other things (TBD:
20# see diffutils.mk in buildroot)
21EXTRA_OECONF_libc-uclibc = "--without-included-regex"
22
23BBCLASSEXTEND = "native nativesdk"