summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/elfutils/elfutils/dso-link-change.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-07 17:00:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-07 17:00:29 +0000
commit1383ecbde214764bac0d6923ec8743b4462a377a (patch)
tree0e8ee6ece1266fd6cd88ea17822a3f241215768f /recipes-devtools/elfutils/elfutils/dso-link-change.patch
parent8ba70a1c28a4e0ee73db5308b38abc923b0be44d (diff)
downloadmeta-gplv2-1383ecbde214764bac0d6923ec8743b4462a377a.tar.gz
readline/elfutils: Add missing files
Add files which were missing from the initial import. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'recipes-devtools/elfutils/elfutils/dso-link-change.patch')
-rw-r--r--recipes-devtools/elfutils/elfutils/dso-link-change.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-devtools/elfutils/elfutils/dso-link-change.patch b/recipes-devtools/elfutils/elfutils/dso-link-change.patch
new file mode 100644
index 0000000..d0cd3ed
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils/dso-link-change.patch
@@ -0,0 +1,32 @@
1Upstream-Status: Pending
2
3# This patch makes the link to the dependencies of libdw explicit, as recent
4# ld no longer implicitly links them. See
5# http://lists.fedoraproject.org/pipermail/devel/2010-March/133601.html as
6# a similar example of the error message you can encounter without this patch,
7# and https://fedoraproject.org/wiki/UnderstandingDSOLinkChange and
8# https://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking for more
9# details.
10
11--- elfutils-0.148.orig/src/Makefile.am
12+++ elfutils-0.148/src/Makefile.am
13@@ -86,7 +86,7 @@ libdw = ../libdw/libdw.a $(zip_LIBS) $(l
14 libelf = ../libelf/libelf.a
15 else
16 libasm = ../libasm/libasm.so
17-libdw = ../libdw/libdw.so
18+libdw = ../libdw/libdw.so $(zip_LIBS) $(libelf) $(libebl) -ldl
19 libelf = ../libelf/libelf.so
20 endif
21 libebl = ../libebl/libebl.a
22--- elfutils-0.148.orig/tests/Makefile.am
23+++ elfutils-0.148/tests/Makefile.am
24@@ -172,7 +172,7 @@ libdw = ../libdw/libdw.a $(zip_LIBS) $(l
25 libelf = ../libelf/libelf.a
26 libasm = ../libasm/libasm.a
27 else
28-libdw = ../libdw/libdw.so
29+libdw = ../libdw/libdw.so $(zip_LIBS) $(libelf) $(libebl) -ldl
30 libelf = ../libelf/libelf.so
31 libasm = ../libasm/libasm.so
32 endif