summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2017-06-23 12:32:53 +0200
committerRoss Burton <ross.burton@intel.com>2017-06-23 14:29:08 +0100
commitd96ec8f6895d34cc9b05d9a0101ac496db324b18 (patch)
tree9c9652e8a9dd37cefc5de38f88996966e41c3f1e
parent334171d7b00e61b58041f2d4f4df1f8038ad61d4 (diff)
downloadmeta-gplv2-d96ec8f6895d34cc9b05d9a0101ac496db324b18.tar.gz
gnutls: make it independent on gnutls.inc from oe-core
* also remove correct_rpl_gettimeofday_signature.patch like in commit e01e7c543a559c8926d72159b5cd55db0c661434 Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Thu Jun 15 23:15:00 2017 +0100 meta: Remove further uclibc remnants (inc. patches and site files) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--recipes-support/gnutls/gnutls.inc57
-rw-r--r--recipes-support/gnutls/gnutls_3.3.27.bb8
2 files changed, 58 insertions, 7 deletions
diff --git a/recipes-support/gnutls/gnutls.inc b/recipes-support/gnutls/gnutls.inc
new file mode 100644
index 0000000..4a5c3df
--- /dev/null
+++ b/recipes-support/gnutls/gnutls.inc
@@ -0,0 +1,57 @@
1SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "ftp://ftp.gnutls.org/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz"
21
22inherit autotools texinfo binconfig pkgconfig gettext lib_package gtk-doc
23
24PACKAGECONFIG ??= "libidn zlib"
25
26PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn"
27PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
28PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
29PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
30PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
31
32EXTRA_OECONF = " \
33 --enable-doc \
34 --disable-libdane \
35 --disable-guile \
36 --disable-rpath \
37 --enable-local-libopts \
38 --enable-openssl-compatibility \
39 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
40"
41
42LDFLAGS_append_libc-musl = " -largp"
43LDFLAGS_append_libc-uclibc = " -luargp -pthread"
44
45do_configure_prepend() {
46 for dir in . lib; do
47 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
48 done
49}
50
51PACKAGES =+ "${PN}-openssl ${PN}-xx"
52
53FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
54FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
55FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
56
57BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-support/gnutls/gnutls_3.3.27.bb b/recipes-support/gnutls/gnutls_3.3.27.bb
index 9a8cd40..a1dcdb5 100644
--- a/recipes-support/gnutls/gnutls_3.3.27.bb
+++ b/recipes-support/gnutls/gnutls_3.3.27.bb
@@ -1,12 +1,9 @@
1require recipes-support/gnutls/gnutls.inc 1require gnutls.inc
2 2
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ 3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343" 4 file://COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
5 5
6FILESEXTRAPATHS_prepend = "${THISDIR}/${BPN}:${COREBASE}/meta/recipes-support/${BPN}/${BPN}:"
7
8SRC_URI += " \ 6SRC_URI += " \
9 file://correct_rpl_gettimeofday_signature.patch \
10 file://configure.ac-fix-sed-command.patch \ 7 file://configure.ac-fix-sed-command.patch \
11 file://use-pkg-config-to-locate-zlib.patch \ 8 file://use-pkg-config-to-locate-zlib.patch \
12" 9"
@@ -18,6 +15,3 @@ SRC_URI[sha256sum] = "8dfda16c158ef5c134010d51d1a91d02aa5d43b8cb711b1572650a7ffb
18PACKAGECONFIG[libidn] = "" 15PACKAGECONFIG[libidn] = ""
19# but it still has the libidn dependency, without this option 16# but it still has the libidn dependency, without this option
20EXTRA_OECONF += "--disable-crywrap" 17EXTRA_OECONF += "--disable-crywrap"
21
22# This version doesn't support this option added in newer gnutls
23EXTRA_OECONF_remove = "--without-libunistring-prefix"