summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-02-12 00:00:29 -0800
committerRoss Burton <ross.burton@intel.com>2018-02-15 11:15:14 +0000
commit81e0da1028255f703029169ec50bcea23c9622c0 (patch)
tree5f900c86c61c00afefe1626e8b4a912b0c4641e1
parenta0f8716d07324e945f0462b82f9309fa0934af17 (diff)
downloadmeta-gplv2-81e0da1028255f703029169ec50bcea23c9622c0.tar.gz
make: Do not assume glibc glob internals
glibc 2.27 hides them Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch36
-rw-r--r--recipes-devtools/make/make_3.81.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch b/recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch
new file mode 100644
index 0000000..755be0b
--- /dev/null
+++ b/recipes-devtools/make/make-3.81/0002-glob-Do-not-assume-glibc-glob-internals.patch
@@ -0,0 +1,36 @@
1From 9858702dbd1e137262c06765919937660879f63c Mon Sep 17 00:00:00 2001
2From: Paul Eggert <eggert@cs.ucla.edu>
3Date: Sun, 24 Sep 2017 09:12:58 -0400
4Subject: [PATCH 2/2] glob: Do not assume glibc glob internals.
5
6It has been proposed that glibc glob start using gl_lstat,
7which the API allows it to do. GNU 'make' should not get in
8the way of this. See:
9https://sourceware.org/ml/libc-alpha/2017-09/msg00409.html
10
11* dir.c (local_lstat): New function, like local_stat.
12(dir_setup_glob): Use it to initialize gl_lstat too, as the API
13requires.
14---
15Upstream-Status: Backport
16which is so small that it's effectively public domain.
17
18 configure.ac | 3 +--
19 1 file changed, 1 insertion(+), 2 deletions(-)
20
21Index: make-3.81/configure.in
22===================================================================
23--- make-3.81.orig/configure.in
24+++ make-3.81/configure.in
25@@ -348,10 +348,9 @@ AC_CACHE_VAL(make_cv_sys_gnu_glob, [
26 #include <glob.h>
27 #include <fnmatch.h>
28
29-#define GLOB_INTERFACE_VERSION 1
30 #if !defined _LIBC && defined __GNU_LIBRARY__ && __GNU_LIBRARY__ > 1
31 # include <gnu-versions.h>
32-# if _GNU_GLOB_INTERFACE_VERSION == GLOB_INTERFACE_VERSION
33+if _GNU_GLOB_INTERFACE_VERSION == 1 || _GNU_GLOB_INTERFACE_VERSION == 2
34 gnu glob
35 # endif
36 #endif
diff --git a/recipes-devtools/make/make_3.81.bb b/recipes-devtools/make/make_3.81.bb
index b8a79b0..9fe22a8 100644
--- a/recipes-devtools/make/make_3.81.bb
+++ b/recipes-devtools/make/make_3.81.bb
@@ -9,6 +9,7 @@ require make.inc
9 9
10SRC_URI += "file://make_fix_for_automake-1.12.patch" 10SRC_URI += "file://make_fix_for_automake-1.12.patch"
11SRC_URI += "file://makeinfo.patch" 11SRC_URI += "file://makeinfo.patch"
12SRC_URI += "file://0002-glob-Do-not-assume-glibc-glob-internals.patch"
12 13
13SRC_URI[md5sum] = "354853e0b2da90c527e35aabb8d6f1e6" 14SRC_URI[md5sum] = "354853e0b2da90c527e35aabb8d6f1e6"
14SRC_URI[sha256sum] = "f3e69023771e23908f5d5592954d8271d3d6af09693cecfd29cee6fde8550dc8" 15SRC_URI[sha256sum] = "f3e69023771e23908f5d5592954d8271d3d6af09693cecfd29cee6fde8550dc8"