summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2017-04-24 16:29:54 +0200
committerRoss Burton <ross.burton@intel.com>2017-04-25 12:18:32 +0100
commitfc0e3eae0f0669e6780ed69680cd065a77baca24 (patch)
tree036e53a96b3e7bcdd4543d413d4cd64ddff5eece
parentde001bd6bfcec943d274b649c62be6848cc9c3e6 (diff)
downloadmeta-gplv2-fc0e3eae0f0669e6780ed69680cd065a77baca24.tar.gz
gnutls: add older gnutls compatible with nettle
* gnutls depends on nettle-3.1* since 3.4.0: The requirement for nettle was bumped from 3.0 to 3.1 in gnutls_3_4_0 https://gitlab.com/gnutls/gnutls/commit/c84129af91b21d33ffe086e507632771b0e76498 and from 2.7 to 3.0 a bit earlier also in gnutls_3_4_0 https://gitlab.com/gnutls/gnutls/commit/3fa80cf68919f07b3351b2722278ba463d6e731c * add recipe for last release in 3.3 branch which is compatible with nettle 2.7.1 used in meta-gplv2 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--recipes-support/gnutls/gnutls/configure.ac-fix-sed-command.patch31
-rw-r--r--recipes-support/gnutls/gnutls_3.3.27.bb23
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-support/gnutls/gnutls/configure.ac-fix-sed-command.patch b/recipes-support/gnutls/gnutls/configure.ac-fix-sed-command.patch
new file mode 100644
index 0000000..44a9934
--- /dev/null
+++ b/recipes-support/gnutls/gnutls/configure.ac-fix-sed-command.patch
@@ -0,0 +1,31 @@
1From eb93aa7b986c84da60a3db40afb29d1a70c50223 Mon Sep 17 00:00:00 2001
2From: Robert Yang <liezhi.yang@windriver.com>
3Date: Sat, 17 Jan 2015 17:02:15 +0000
4Subject: [PATCH] configure.ac: fix sed command
5
6The "sed 's/.bak//g'" matchs "bitbake", which would cause strange errors
7when the S contains "bitbake", fix to "sed 's/\.bak$//'`"
8
9Upstream-Status: Pending
10
11Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
12---
13 configure.ac | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/configure.ac b/configure.ac
17index c6818a0..1c4582d 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -466,7 +466,7 @@ if test "$NEED_LIBOPTS_DIR" = "true";then
21 dnl replace libopts-generated files with distributed backups, if present
22 missing_baks=
23 for i in ${srcdir}/src/*-args.c.bak ${srcdir}/src/*-args.h.bak; do
24- nam=`echo $i|sed 's/.bak//g'`
25+ nam=`echo $i|sed 's/\.bak$//'`
26 if test -f $i;then
27 cp -f $i $nam
28 else
29--
302.0.1
31
diff --git a/recipes-support/gnutls/gnutls_3.3.27.bb b/recipes-support/gnutls/gnutls_3.3.27.bb
new file mode 100644
index 0000000..c98da34
--- /dev/null
+++ b/recipes-support/gnutls/gnutls_3.3.27.bb
@@ -0,0 +1,23 @@
1require recipes-support/gnutls/gnutls.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
5
6FILESEXTRAPATHS_prepend = "${COREBASE}/meta/recipes-support/${BPN}/${BPN}:"
7
8SRC_URI += " \
9 file://correct_rpl_gettimeofday_signature.patch \
10 file://configure.ac-fix-sed-command.patch \
11 file://use-pkg-config-to-locate-zlib.patch \
12"
13SRC_URI[md5sum] = "8ee8cebd7f7575b11f232766a21c31d3"
14SRC_URI[sha256sum] = "8dfda16c158ef5c134010d51d1a91d02aa5d43b8cb711b1572650a7ffb56b17f"
15
16# This version doesn't support this option added in newer gnutls
17# ERROR: gnutls-3.3.27-r0 do_configure: QA Issue: gnutls: configure was passed unrecognised options: --with-idn [unknown-configure-option]
18PACKAGECONFIG[libidn] = ""
19# but it still has the libidn dependency, without this option
20EXTRA_OECONF += "--disable-crywrap"
21
22# This version doesn't support this option added in newer gnutls
23EXTRA_OECONF_remove = "--without-libunistring-prefix"