summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2018-04-26 02:32:32 +0200
committerPeter Kjellerstedt <pkj@axis.com>2018-04-26 03:01:15 +0200
commita7d6c0a59aa3f23b1a8cda80e37ddfbb5f63d32d (patch)
tree8cf555500daa2a554206231cda5aef44ffd9cc86
parent37da5c27c567ac3145347470793c7ec101593ca8 (diff)
downloadmeta-gplv2-a7d6c0a59aa3f23b1a8cda80e37ddfbb5f63d32d.tar.gz
rsync: Make it build with compile time hardening enabled
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
-rw-r--r--recipes-devtools/rsync/rsync-2.6.9/0001-Make-it-build-with-compile-time-hardening-enabled.patch32
-rw-r--r--recipes-devtools/rsync/rsync_2.6.9.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-devtools/rsync/rsync-2.6.9/0001-Make-it-build-with-compile-time-hardening-enabled.patch b/recipes-devtools/rsync/rsync-2.6.9/0001-Make-it-build-with-compile-time-hardening-enabled.patch
new file mode 100644
index 0000000..e368024
--- /dev/null
+++ b/recipes-devtools/rsync/rsync-2.6.9/0001-Make-it-build-with-compile-time-hardening-enabled.patch
@@ -0,0 +1,32 @@
1From 8b032db07981a88141984201736c9c6d4fffeb9a Mon Sep 17 00:00:00 2001
2From: Peter Kjellerstedt <pkj@axis.com>
3Date: Thu, 26 Apr 2018 02:29:22 +0200
4Subject: [PATCH] Make it build with compile time hardening enabled
5
6This avoids the following error:
7
8 clientserver.c: In function 'rsync_module':
9 clientserver.c:681:4: error: format not a string literal and no
10 format arguments [-Werror=format-security]
11 rprintf(FERROR, err_msg);
12 ^~~~~~~
13
14Upstream-Status: Inappropriate [legacy version]
15Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
16---
17 clientserver.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/clientserver.c b/clientserver.c
21index 1cb6a09..0aafb8b 100644
22--- a/clientserver.c
23+++ b/clientserver.c
24@@ -678,7 +678,7 @@ static int rsync_module(int f_in, int f_out, int i, char *addr, char *host)
25
26 if (!ret || err_msg) {
27 if (err_msg)
28- rprintf(FERROR, err_msg);
29+ rprintf(FERROR, "%s", err_msg);
30 else
31 option_error();
32 msleep(400);
diff --git a/recipes-devtools/rsync/rsync_2.6.9.bb b/recipes-devtools/rsync/rsync_2.6.9.bb
index 17f1d31..5c6c9d9 100644
--- a/recipes-devtools/rsync/rsync_2.6.9.bb
+++ b/recipes-devtools/rsync/rsync_2.6.9.bb
@@ -1,6 +1,7 @@
1require rsync.inc 1require rsync.inc
2 2
3SRC_URI += "file://rsync-2.6.9-fname-obo.patch \ 3SRC_URI += "file://rsync-2.6.9-fname-obo.patch \
4 file://0001-Make-it-build-with-compile-time-hardening-enabled.patch \
4 file://rsyncd.conf \ 5 file://rsyncd.conf \
5" 6"
6 7