summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-07 17:00:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-07 17:00:29 +0000
commit1383ecbde214764bac0d6923ec8743b4462a377a (patch)
tree0e8ee6ece1266fd6cd88ea17822a3f241215768f
parent8ba70a1c28a4e0ee73db5308b38abc923b0be44d (diff)
downloadmeta-gplv2-1383ecbde214764bac0d6923ec8743b4462a377a.tar.gz
readline/elfutils: Add missing files
Add files which were missing from the initial import. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--recipes-core/readline/files/config-dirent-symbols.patch34
-rw-r--r--recipes-devtools/elfutils/elfutils/Fix_elf_cvt_gunhash.patch29
-rw-r--r--recipes-devtools/elfutils/elfutils/dso-link-change.patch32
3 files changed, 95 insertions, 0 deletions
diff --git a/recipes-core/readline/files/config-dirent-symbols.patch b/recipes-core/readline/files/config-dirent-symbols.patch
new file mode 100644
index 0000000..cfff03c
--- /dev/null
+++ b/recipes-core/readline/files/config-dirent-symbols.patch
@@ -0,0 +1,34 @@
1Fix the names of the STRUCT_DIRENT_D symbols to match the names used by both
2configure and the source code.
3
4Upstream-Status: Submitted (http://lists.gnu.org/archive/html/bug-readline/2014-05/msg00008.html)
5Signed-off-by: Ross Burton <ross.burton@intel.com>
6
7From e48656811550774892fd4e0f4b3c7d418422da52 Mon Sep 17 00:00:00 2001
8From: Ross Burton <ross.burton@intel.com>
9Date: Tue, 27 May 2014 22:32:31 +0100
10Subject: [PATCH] config.h.in: fix names of STRUCT_DIRENT_D symbols
11
12---
13 config.h.in | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/config.h.in b/config.h.in
17index a67e43e..a42acc5 100644
18--- a/config.h.in
19+++ b/config.h.in
20@@ -244,9 +244,9 @@
21
22 #undef HAVE_GETPW_DECLS
23
24-#undef STRUCT_DIRENT_HAS_D_INO
25+#undef HAVE_STRUCT_DIRENT_D_INO
26
27-#undef STRUCT_DIRENT_HAS_D_FILENO
28+#undef HAVE_STRUCT_DIRENT_D_FILENO
29
30 #undef HAVE_BSD_SIGNALS
31
32--
331.7.10.4
34
diff --git a/recipes-devtools/elfutils/elfutils/Fix_elf_cvt_gunhash.patch b/recipes-devtools/elfutils/elfutils/Fix_elf_cvt_gunhash.patch
new file mode 100644
index 0000000..f861e89
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils/Fix_elf_cvt_gunhash.patch
@@ -0,0 +1,29 @@
1Fix elf_cvt_gunhash if dest and src are same.
2
3Upstream-Status: Pending
4
5The 'dest' and 'src' can be same, we need to save the value of src32[2]
6before swaping it.
7
8Signed-off-by: Baoshan Pang <BaoShan.Pang@windriver.com>
9diff --git a/libelf/gnuhash_xlate.h b/libelf/gnuhash_xlate.h
10index 6faf113..04d9ca1 100644
11--- a/libelf/gnuhash_xlate.h
12+++ b/libelf/gnuhash_xlate.h
13@@ -40,6 +40,7 @@ elf_cvt_gnuhash (void *dest, const void *src, size_t len, int encode)
14 words. We must detangle them here. */
15 Elf32_Word *dest32 = dest;
16 const Elf32_Word *src32 = src;
17+ Elf32_Word save_src32_2 = src32[2]; // dest could be equal to src
18
19 /* First four control words, 32 bits. */
20 for (unsigned int cnt = 0; cnt < 4; ++cnt)
21@@ -50,7 +51,7 @@ elf_cvt_gnuhash (void *dest, const void *src, size_t len, int encode)
22 len -= 4;
23 }
24
25- Elf32_Word bitmask_words = encode ? src32[2] : dest32[2];
26+ Elf32_Word bitmask_words = encode ? save_src32_2 : dest32[2];
27
28 /* Now the 64 bit words. */
29 Elf64_Xword *dest64 = (Elf64_Xword *) &dest32[4];
diff --git a/recipes-devtools/elfutils/elfutils/dso-link-change.patch b/recipes-devtools/elfutils/elfutils/dso-link-change.patch
new file mode 100644
index 0000000..d0cd3ed
--- /dev/null
+++ b/recipes-devtools/elfutils/elfutils/dso-link-change.patch
@@ -0,0 +1,32 @@
1Upstream-Status: Pending
2
3# This patch makes the link to the dependencies of libdw explicit, as recent
4# ld no longer implicitly links them. See
5# http://lists.fedoraproject.org/pipermail/devel/2010-March/133601.html as
6# a similar example of the error message you can encounter without this patch,
7# and https://fedoraproject.org/wiki/UnderstandingDSOLinkChange and
8# https://fedoraproject.org/wiki/Features/ChangeInImplicitDSOLinking for more
9# details.
10
11--- elfutils-0.148.orig/src/Makefile.am
12+++ elfutils-0.148/src/Makefile.am
13@@ -86,7 +86,7 @@ libdw = ../libdw/libdw.a $(zip_LIBS) $(l
14 libelf = ../libelf/libelf.a
15 else
16 libasm = ../libasm/libasm.so
17-libdw = ../libdw/libdw.so
18+libdw = ../libdw/libdw.so $(zip_LIBS) $(libelf) $(libebl) -ldl
19 libelf = ../libelf/libelf.so
20 endif
21 libebl = ../libebl/libebl.a
22--- elfutils-0.148.orig/tests/Makefile.am
23+++ elfutils-0.148/tests/Makefile.am
24@@ -172,7 +172,7 @@ libdw = ../libdw/libdw.a $(zip_LIBS) $(l
25 libelf = ../libelf/libelf.a
26 libasm = ../libasm/libasm.a
27 else
28-libdw = ../libdw/libdw.so
29+libdw = ../libdw/libdw.so $(zip_LIBS) $(libelf) $(libebl) -ldl
30 libelf = ../libelf/libelf.so
31 libasm = ../libasm/libasm.so
32 endif