summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-05-03 08:41:18 +0200
committerRoss Burton <ross.burton@arm.com>2021-05-07 11:47:07 +0100
commit1ee1a73070d91e0c727f9d0db11943a61765c8d9 (patch)
tree702f4539f8b3a4f68d134924be7f1cdfe1425fc1
parente4da38dd796b258a1b7c82221e03c0033092a8ba (diff)
downloadmeta-gplv2-1ee1a73070d91e0c727f9d0db11943a61765c8d9.tar.gz
elfutils: ignore format-truncation and stringop-overflow issues to fix build with gcc-113.4_M1
* works around: http://errors.yoctoproject.org/Errors/Details/580076/ elfutils-0.148/src/ar.c:1088:56: error: '%-*ld' directive output may be truncated writing between 6 and 10 bytes into a region of size 7 [-Werror=format-truncation=] 1088 | snprintf (tmpbuf, sizeof (tmpbuf), ofmt ? "%-*lo" : "%-*ld", bufsize, val); | ^~~~~ elfutils-0.148/src/ar.c:1088:55: note: directive argument in the range [0, 4294967295] 1088 | snprintf (tmpbuf, sizeof (tmpbuf), ofmt ? "%-*lo" : "%-*ld", bufsize, val); | ^~~~~~~ http://errors.yoctoproject.org/Errors/Details/580078/ elfutils-0.148/tests/addrcfi.c:90:16: error: 'dwarf_frame_register' accessing 96 bytes in a region of size 64 [-Werror=stringop-overflow=] 90 | int result = dwarf_frame_register (stuff->frame, regno, ops_mem, &ops, &nops); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@arm.com>
-rw-r--r--recipes-devtools/elfutils/elfutils_0.148.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-devtools/elfutils/elfutils_0.148.bb b/recipes-devtools/elfutils/elfutils_0.148.bb
index 1f07a28..654a715 100644
--- a/recipes-devtools/elfutils/elfutils_0.148.bb
+++ b/recipes-devtools/elfutils/elfutils_0.148.bb
@@ -61,6 +61,14 @@ inherit autotools gettext
61# but 0.175 has different license, so to be safe don't backport the fix, just ignore the issue 61# but 0.175 has different license, so to be safe don't backport the fix, just ignore the issue
62CFLAGS += "-Wno-error=missing-attributes" 62CFLAGS += "-Wno-error=missing-attributes"
63 63
64# There is a fix in 0.171 version (commit b10d7eb74064c5906f031cd17c0f82041c6a4ca1)
65# but 0.171 has different license, so to be safe don't backport the fix, just ignore the issue
66CFLAGS += "-Wno-error=format-truncation="
67
68# There is a fix in 0.182 version (commit 5621fe5443da23112170235dd5cac161e5c75e65)
69# but 0.182 has different license, so to be safe don't backport the fix, just ignore the issue
70CFLAGS += "-Wno-error=stringop-overflow="
71
64EXTRA_OECONF = "--program-prefix=eu- --without-lzma" 72EXTRA_OECONF = "--program-prefix=eu- --without-lzma"
65EXTRA_OECONF_append_class-native = " --without-bzlib" 73EXTRA_OECONF_append_class-native = " --without-bzlib"
66EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc" 74EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"