summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/hypervisor/hypervisor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization/hypervisor/hypervisor_git.bb')
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
new file mode 100644
index 0000000..dc86406
--- /dev/null
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -0,0 +1,90 @@
1DESCRIPTION = "Freescale embedded hypervisor"
2SECTION = "embedded-hv"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0"
5
6PR = "r3"
7
8DEPENDS = "u-boot-mkimage-native"
9
10inherit deploy
11
12S = "${WORKDIR}/git"
13
14# TODO: fix dtc to use the already built package
15SRC_URI = " \
16 git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor \
17 git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig \
18 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos \
19 git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \
20 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk \
21 file://81-fsl-embedded-hv.rules \
22 "
23
24SRCREV_FORMAT="hypervisor"
25SRCREV = "e6092cdf2a225c66c1ea46b1151eb828da29d139"
26SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac"
27SRCREV_libos = "5268371581f3ef3959be2a53235edfa6a8c6aa7c"
28SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0"
29SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533"
30
31EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
32
33DEFCONFIG = "defconfig"
34DEFCONFIG_powerpc64 = "64bit_defconfig"
35
36COMPATIBLE_HOST_fslmachine = ".*"
37COMPATIBLE_HOST ?= "(none)"
38
39inherit cml1
40do_configure () {
41 oe_runmake ${DEFCONFIG}
42}
43
44PKG_HV_HYPERTRK_SUPPORT = "n"
45do_compile () {
46 if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ]
47 then
48 oe_runmake silentoldconfig
49 export HV_DIR=$PWD
50 cd hypertrk
51 oe_runmake deploy
52 cd ..
53 fi
54
55 oe_runmake
56 oe_runmake partman
57}
58
59do_install () {
60 install -d ${D}/${bindir}
61 install ${S}/output/bin/linux/partman ${D}/${bindir}/partman
62
63 install -d ${D}${sysconfdir}/udev/rules.d
64 install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d
65
66 install -d ${D}/boot/hv
67 install ${S}/output/.config ${D}/boot/hv/hypervisor.config
68 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
69 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
70 ${D}/boot/hv/
71}
72
73do_deploy () {
74 install -d ${DEPLOYDIR}/hv/
75 install ${S}/output/.config ${DEPLOYDIR}/hv/hypervisor.config
76 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
77 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
78 ${DEPLOYDIR}/hv/
79}
80addtask deploy before do_build after do_install
81
82do_deploy_append() {
83 rm -f ${S}/../hv
84}
85
86INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
87ALLOW_EMPTY_${PN} = "1"
88PACKAGES_prepend = "${PN}-image ${PN}-partman "
89FILES_${PN}-image = "/boot/"
90FILES_${PN}-partman = "${bindir}/partman"