summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/hypervisor/hypervisor_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization/hypervisor/hypervisor_git.bb')
-rw-r--r--recipes-virtualization/hypervisor/hypervisor_git.bb91
1 files changed, 91 insertions, 0 deletions
diff --git a/recipes-virtualization/hypervisor/hypervisor_git.bb b/recipes-virtualization/hypervisor/hypervisor_git.bb
new file mode 100644
index 0000000..ff89bfa
--- /dev/null
+++ b/recipes-virtualization/hypervisor/hypervisor_git.bb
@@ -0,0 +1,91 @@
1DESCRIPTION = "Freescale embedded hypervisor"
2SECTION = "embedded-hv"
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://README;endline=22;md5=0655bbc3b7d7166c30c87208b4e23cf0"
5
6PR = "r3"
7
8DEPENDS = "u-boot-mkimage-native"
9
10inherit deploy
11
12S = "${WORKDIR}/git"
13
14# TODO: fix dtc to use the already built package
15SRC_URI = " \
16 git://git.freescale.com/ppc/sdk/hypervisor/hypervisor.git;name=hypervisor \
17 git://git.freescale.com/ppc/sdk/hypervisor/kconfig.git;name=kconfig;destsuffix=git/kconfig \
18 git://git.freescale.com/ppc/sdk/hypervisor/libos.git;name=libos;destsuffix=git/libos \
19 git://www.jdl.com/software/dtc.git;name=dtc;destsuffix=dtc \
20 git://git.freescale.com/ppc/sdk/hypertrk.git;name=hypertrk;destsuffix=git/hypertrk \
21 file://0001-fix-sizeof-pointer-memaccess-error.patch \
22 file://81-fsl-embedded-hv.rules \
23 "
24
25SRCREV_FORMAT="hypervisor"
26SRCREV = "e6092cdf2a225c66c1ea46b1151eb828da29d139"
27SRCREV_kconfig = "a56025d4da992b856796b0eccac2e410d751dbac"
28SRCREV_libos = "5268371581f3ef3959be2a53235edfa6a8c6aa7c"
29SRCREV_dtc = "033089f29099bdfd5c2d6986cdb9fd07b16cfde0"
30SRCREV_hypertrk = "975c98b562186afbd3bbf103ae54b96cf9b3e533"
31
32EXTRA_OEMAKE = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
33
34DEFCONFIG = "defconfig"
35DEFCONFIG_powerpc64 = "64bit_defconfig"
36
37COMPATIBLE_HOST_fslmachine = ".*"
38COMPATIBLE_HOST ?= "(none)"
39
40inherit cml1
41do_configure () {
42 oe_runmake ${DEFCONFIG}
43}
44
45PKG_HV_HYPERTRK_SUPPORT = "n"
46do_compile () {
47 if [ "${PKG_HV_HYPERTRK_SUPPORT}" = "y" ]
48 then
49 oe_runmake silentoldconfig
50 export HV_DIR=$PWD
51 cd hypertrk
52 oe_runmake deploy
53 cd ..
54 fi
55
56 oe_runmake
57 oe_runmake partman
58}
59
60do_install () {
61 install -d ${D}/${bindir}
62 install ${S}/output/bin/linux/partman ${D}/${bindir}/partman
63
64 install -d ${D}${sysconfdir}/udev/rules.d
65 install -m 0644 ${WORKDIR}/81-fsl-embedded-hv.rules ${D}${sysconfdir}/udev/rules.d
66
67 install -d ${D}/boot/hv
68 install ${S}/output/.config ${D}/boot/hv/hypervisor.config
69 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
70 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
71 ${D}/boot/hv/
72}
73
74do_deploy () {
75 install -d ${DEPLOYDIR}/hv/
76 install ${S}/output/.config ${DEPLOYDIR}/hv/hypervisor.config
77 install -m 644 ${S}/output/bin/hv ${S}/output/bin/hv.map \
78 ${S}/output/bin/hv.uImage ${S}/output/bin/hv.bin \
79 ${DEPLOYDIR}/hv/
80}
81addtask deploy before do_build after do_install
82
83do_deploy_append() {
84 rm -f ${S}/../hv
85}
86
87INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
88ALLOW_EMPTY_${PN} = "1"
89PACKAGES_prepend = "${PN}-image ${PN}-partman "
90FILES_${PN}-image = "/boot/"
91FILES_${PN}-partman = "${bindir}/partman"