summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/hv-cfg/hv-cfg_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization/hv-cfg/hv-cfg_git.bb')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 0000000..2c6bb85
--- /dev/null
+++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r6"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11"
12
13DEPENDS += "dtc-native"
14
15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18COMPATIBLE_HOST_fslmachine = ".*"
19COMPATIBLE_HOST ?= "(none)"
20
21inherit deploy
22
23SRCREV = "d037ab9d5b9ecd58e10a7dac2b601d781ed9b5bf"
24SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git"
25
26S = "${WORKDIR}/git"
27
28do_install () {
29 make install
30
31 M=`echo ${MACHINE} | sed s/-64b//g`
32 install -d ${D}/boot/hv-cfg
33 cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
34}
35
36do_deploy () {
37 M=`echo ${MACHINE} | sed s/-64b//g`
38 install -d ${DEPLOYDIR}/hv-cfg
39 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
40}
41addtask deploy after do_install
42
43PACKAGES += "${PN}-image"
44FILES_${PN}-image += "/boot"
45
46ALLOW_EMPTY_${PN} = "1"