summaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/hv-cfg/hv-cfg_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization/hv-cfg/hv-cfg_git.bb')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 0000000..599bce2
--- /dev/null
+++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r6"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11"
12
13DEPENDS += "dtc-native"
14
15# this package is specific to the machine itself
16INHIBIT_DEFAULT_DEPS = "1"
17PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19inherit deploy
20
21SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;nobranch=1"
22SRCREV = "f79080739851b3a3dfcd435f2ef1572459a4313c"
23
24S = "${WORKDIR}/git"
25
26do_install () {
27 make install
28
29 M=`echo ${MACHINE} | sed s/-64b//g`
30 if [ "t1042rdb" = "${M}" ];then
31 M=t1040rdb
32 fi
33 install -d ${D}/boot/hv-cfg
34 cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
35}
36
37do_deploy () {
38 M=`echo ${MACHINE} | sed s/-64b//g`
39 if [ "t1042rdb" = "${M}" ];then
40 M=t1040rdb
41 fi
42 install -d ${DEPLOYDIR}/hv-cfg
43 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
44}
45addtask deploy after do_install
46
47PACKAGES += "${PN}-image"
48FILES_${PN}-image += "/boot"
49
50COMPATIBLE_HOST_qoriq-ppc = ".*"
51COMPATIBLE_HOST ?= "(none)"
52ALLOW_EMPTY_${PN} = "1"