summaryrefslogtreecommitdiffstats
path: root/recipes-tools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-tools')
-rw-r--r--recipes-tools/hv-cfg/hv-cfg_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-tools/hv-cfg/hv-cfg_git.bb b/recipes-tools/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 0000000..7a17c64
--- /dev/null
+++ b/recipes-tools/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "Hypervisor Config"
2SECTION = "hv-cfg"
3LICENSE = "BSD"
4PR = "r1"
5
6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
8 file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
9 file://p3060qds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
10 file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
11 file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
12"
13
14# this package is specific to the machine itself
15INHIBIT_DEFAULT_DEPS = "1"
16PACKAGE_ARCH = "${MACHINE_ARCH}"
17
18inherit deploy
19
20SRCREV = "${AUTOREV}"
21SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git"
22
23S = "${WORKDIR}/git"
24
25do_deploy () {
26 make install
27
28 M=`echo ${MACHINE} | sed s/-64b//g`
29 mkdir -p ${DEPLOY_DIR_IMAGE}/hv-cfg
30 cp -r ${S}/${M}/${M} ${DEPLOY_DIR_IMAGE}/hv-cfg
31}
32addtask deploy after do_install
33
34ALLOW_EMPTY_${PN} = "1"