summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/pkc-host/pkc-host_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/pkc-host/pkc-host_git.bb')
-rw-r--r--recipes-kernel/pkc-host/pkc-host_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/pkc-host/pkc-host_git.bb b/recipes-kernel/pkc-host/pkc-host_git.bb
new file mode 100644
index 0000000..2d5e316
--- /dev/null
+++ b/recipes-kernel/pkc-host/pkc-host_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "pkc host driver"
2SECTION = "pkc-host"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=6a26ed8e76a8ea2e019c525369ed0f03"
5
6inherit module qoriq_build_64bit_kernel
7RDEPENDS_${PN} += "cryptodev-module"
8
9# Currently pkc-host does not support RSA_KEYGEN, remove this
10# if it is fixed.
11REQUIRED_DISTRO_FEATURES = "c29x_pkc"
12
13SRC_URI = "git://git.freescale.com/ppc/sdk/pkc-host.git;nobranch=1"
14SRCREV = "cae512c94e2a26cc6b0d6393d307cdea2d7282c9"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
19
20do_install() {
21 install -d ${D}/lib/modules/c2x0
22 install -d ${D}/etc/crypto
23 install -d ${D}/${bindir}
24 cp ${S}/*.ko ${D}/lib/modules/c2x0
25 cp ${S}/crypto.cfg ${D}/etc/crypto
26 cp ${S}/images/pkc-firmware.bin ${D}/etc/crypto
27 cp ${S}/perf/mini_calc/mini_calc ${D}/${bindir}
28 cp ${S}/apps/cli/cli ${D}/${bindir}
29 cp ${S}/perf/c29x_driver_perf_profile.sh ${D}/${bindir}
30}
31
32
33FILES_${PN} += "${bindir}/mini_calc ${bindir}/cli ${bindir}/c29x_driver_perf_profile.sh /etc/crypto/crypto.cfg /etc/crypto/pkc-firmware.bin"