summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/ceetm/ceetm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/ceetm/ceetm_git.bb')
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
new file mode 100644
index 0000000..266261e
--- /dev/null
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "CEETM TC QDISC"
2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
4
5DEPENDS="virtual/kernel"
6
7inherit module qoriq_build_64bit_kernel
8
9SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;nobranch=1"
10SRCREV = "ecf55c9ca0cd42a212653e1f99c19cd611e3a008"
11
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}"
15export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16
17do_install(){
18 mkdir -p ${D}/usr/driver/ceetm
19 mkdir -p ${D}/${libdir}/tc
20 cp ${S}/bin/ceetm.ko ${D}/usr/driver/ceetm
21 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/.
22}
23
24FILES_${PN} += "/usr/driver/ceetm ${libdir}/tc"
25INHIBIT_PACKAGE_STRIP = "1"