summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/asf/asf_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/asf/asf_git.bb')
-rw-r--r--recipes-kernel/asf/asf_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-kernel/asf/asf_git.bb b/recipes-kernel/asf/asf_git.bb
new file mode 100644
index 0000000..8070f5a
--- /dev/null
+++ b/recipes-kernel/asf/asf_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;nobranch=1"
7SRCREV = "16eb472d6b2b34c8b605a86c469611bc8ddec1c9"
8
9
10inherit module qoriq_build_64bit_kernel
11
12S = "${WORKDIR}/git/asfmodule"
13
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
15export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
16
17INHIBIT_PACKAGE_STRIP = "1"
18
19do_install(){
20 install -d ${D}/${libexecdir}
21 install -d ${D}/lib/modules/${KERNEL_VERSION}/asf
22 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
23 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
24 cp -rf ${S}/../scripts ${D}/${libexecdir}/
25}
26
27FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
28RDEPENDS_${PN} += "ipsec-tools"
29