summaryrefslogtreecommitdiffstats
path: root/recipes-extended/skmm-ep/skmm-ep_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/skmm-ep/skmm-ep_git.bb')
-rw-r--r--recipes-extended/skmm-ep/skmm-ep_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-extended/skmm-ep/skmm-ep_git.bb b/recipes-extended/skmm-ep/skmm-ep_git.bb
new file mode 100644
index 0000000..fcbd2ed
--- /dev/null
+++ b/recipes-extended/skmm-ep/skmm-ep_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "SKMM application for PCIe endpoint"
2SECTION = "skmm-ep"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=39e58bedc879163c9338596e52df5b1f"
5
6DEPENDS = "libedit openssl virtual/kernel"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/skmm-ep.git;nobranch=1 \
11 file://add-two-missing-header-files.patch \
12"
13SRCREV = "27156a6621c8f6d7f98210b1ca5cd97bde926875"
14
15COMPATIBLE_MACHINE = "(p4080ds|t4240qds|c293pcie)"
16
17S = "${WORKDIR}/git"
18
19EXTRA_OEMAKE = 'MACHINE=${MACHINE}'
20
21export LIBEDIT_CFLAGS="$(pkg-config --cflags libedit)"
22export LIBEDIT_LDFLAGS="$(pkg-config --libs --static libedit)"
23
24do_compile () {
25 export ARCH=${TARGET_ARCH}
26 oe_runmake
27}
28
29do_install () {
30 oe_runmake ARCH=${TARGET_ARCH} install DESTDIR=${D}
31}