summaryrefslogtreecommitdiffstats
path: root/recipes-extended/cst/cst_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/cst/cst_git.bb')
-rw-r--r--recipes-extended/cst/cst_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-extended/cst/cst_git.bb b/recipes-extended/cst/cst_git.bb
new file mode 100644
index 0000000..177f23c
--- /dev/null
+++ b/recipes-extended/cst/cst_git.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "CST Tool"
2SECTION = "cst"
3LICENSE = "BSD"
4
5# TODO: fix license - this file is not a license
6LIC_FILES_CHKSUM = "file://RELEASENOTES;beginline=8;endline=43;md5=5a7b22a2c96b5f94e0498c5f413aa8d3"
7
8DEPENDS += "openssl"
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git"
11SRCREV = "e4035cbf54ed481147c6ae65c741ef75dc9ec37f"
12
13S = "${WORKDIR}/git"
14
15EXTRA_OEMAKE = 'OPENSSL_LIB_PATH=${STAGING_LIBDIR} OPENSSL_INC_PATH=${STAGING_INCDIR} CC="${CC}" LD="${CC}" LDFLAGS="${LDFLAGS}"'
16
17do_install () {
18 install -d ${D}/${bindir}/cst
19 install -m 755 ${S}/gen_keys ${D}/${bindir}/cst/
20 install -m 755 ${S}/gen_otpmk ${D}/${bindir}/cst/
21 install -m 755 ${S}/uni_cfsign ${D}/${bindir}/cst/
22 install -m 755 ${S}/uni_sign ${D}/${bindir}/cst/
23 cp -rf ${S}/input_files ${D}/${bindir}/cst
24}
25
26BBCLASSEXTEND = "native nativesdk"
27PARALLEL_MAKE = ""
28
29FILES_${PN}-dbg += "${bindir}/cst/.debug"