summaryrefslogtreecommitdiffstats
path: root/recipes-extended/cst/cst_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/cst/cst_git.bb')
-rw-r--r--recipes-extended/cst/cst_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-extended/cst/cst_git.bb b/recipes-extended/cst/cst_git.bb
new file mode 100644
index 0000000..e9f1b6f
--- /dev/null
+++ b/recipes-extended/cst/cst_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "utility for security boot"
2SECTION = "cst"
3LICENSE = "BSD"
4
5# TODO: fix license - this file is not a license
6LIC_FILES_CHKSUM = "file://RELEASENOTES;beginline=8;endline=43;md5=5a7b22a2c96b5f94e0498c5f413aa8d3"
7
8DEPENDS += "openssl"
9
10inherit kernel-arch
11
12SRC_URI = "git://git.freescale.com/ppc/sdk/cst.git;nobranch=1"
13SRCREV = "2d35e98539c0daa2bc8049e3bd44994d3d93bbe7"
14
15S = "${WORKDIR}/git"
16
17EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
18
19PARALLEL_MAKE = ""
20
21do_install () {
22 oe_runmake install DESTDIR=${D} BIN_DEST_DIR=${bindir}
23}
24
25FILES_${PN}-dbg += "${bindir}/cst/.debug"
26BBCLASSEXTEND = "native nativesdk"