summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa/fm-ucode/fm-ucode_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa/fm-ucode/fm-ucode_git.bb')
-rw-r--r--recipes-dpaa/fm-ucode/fm-ucode_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-dpaa/fm-ucode/fm-ucode_git.bb b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
new file mode 100644
index 0000000..1bb7098
--- /dev/null
+++ b/recipes-dpaa/fm-ucode/fm-ucode_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Fman microcode binary"
2SECTION = "fm-ucode"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c"
5
6PR = "r1"
7
8inherit deploy
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/fm-ucode.git;nobranch=1"
11SRCREV = "4cda2e3f36408ded79022cf599260add07769786"
12
13S = "${WORKDIR}/git"
14
15REGLEX ?= "${MACHINE}"
16REGLEX_t1042 = "t1040"
17REGLEX_b4420 = "b4860"
18REGLEX_t4160 = "t4240"
19
20do_install () {
21 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
22 install -d ${D}/boot
23 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${D}/boot/
24}
25
26do_deploy () {
27 UCODE=`echo ${REGLEX} | sed -e 's,-.*$,,' -e 's,[a-zA-Z]*$,,'`
28 install -d ${DEPLOYDIR}/
29 install -m 644 fsl_fman_ucode_${UCODE}*.bin ${DEPLOYDIR}/
30}
31addtask deploy before do_build after do_install
32
33PACKAGES += "${PN}-image"
34FILES_${PN}-image += "/boot"
35ALLOW_EMPTY_${PN} = "1"
36COMPATIBLE_MACHINE = "(p1023rdb|e500mc|e5500|e5500-64b|e6500|e6500-64b)"
37