summaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-connectivity/openssl/openssl_1.0.1i.bbappend')
-rw-r--r--recipes-connectivity/openssl/openssl_1.0.1i.bbappend64
1 files changed, 64 insertions, 0 deletions
diff --git a/recipes-connectivity/openssl/openssl_1.0.1i.bbappend b/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
new file mode 100644
index 0000000..1e0781e
--- /dev/null
+++ b/recipes-connectivity/openssl/openssl_1.0.1i.bbappend
@@ -0,0 +1,64 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/openssl-fsl:"
2
3RDEPENDS_${PN}_class-target += "cryptodev-module"
4
5# base package is taken from Freescale repository
6SRCBRANCH = "OpenSSL_1_0_1-stable"
7SRC_URI = "git://git.openssl.org/openssl.git;branch=${SRCBRANCH} \
8 file://0001-remove-double-initialization-of-cryptodev-engine.patch \
9 file://0002-eng_cryptodev-add-support-for-TLS-algorithms-offload.patch \
10 file://0003-cryptodev-fix-algorithm-registration.patch \
11 file://0004-linux-pcc-make-it-more-robust-and-recognize-KERNEL_B.patch \
12 file://0005-ECC-Support-header-for-Cryptodev-Engine.patch \
13 file://0006-Fixed-private-key-support-for-DH.patch \
14 file://0007-Fixed-private-key-support-for-DH.patch \
15 file://0008-Initial-support-for-PKC-in-cryptodev-engine.patch \
16 file://0009-Added-hwrng-dev-file-as-source-of-RNG.patch \
17 file://0010-Asynchronous-interface-added-for-PKC-cryptodev-inter.patch \
18 file://0011-Add-RSA-keygen-operation-and-support-gendsa-command-.patch \
19 file://0012-RSA-Keygen-Fix.patch \
20 file://0013-Removed-local-copy-of-curve_t-type.patch \
21 file://0014-Modulus-parameter-is-not-populated-by-dhparams.patch \
22 file://0015-SW-Backoff-mechanism-for-dsa-keygen.patch \
23 file://0016-Fixed-DH-keygen-pair-generator.patch \
24 file://0017-cryptodev-add-support-for-aes-gcm-algorithm-offloadi.patch \
25 file://Makefiles-ptest.patch \
26 file://ptest-deps.patch \
27 file://run-ptest \
28 "
29
30SRCREV = "2b456034457b58454aae3998a2765b6a5b9bc837"
31
32SRC_URI += "file://configure-targets.patch \
33 file://shared-libs.patch \
34 file://oe-ldflags.patch \
35 file://engines-install-in-libdir-ssl.patch \
36 file://openssl-fix-link.patch \
37 file://debian/version-script.patch \
38 file://debian/pic.patch \
39 file://debian/c_rehash-compat.patch \
40 file://debian/ca.patch \
41 file://debian/make-targets.patch \
42 file://debian/no-rpath.patch \
43 file://debian/man-dir.patch \
44 file://debian/man-section.patch \
45 file://debian/no-symbolic.patch \
46 file://debian/debian-targets.patch \
47 file://openssl_fix_for_x32.patch \
48 file://fix-cipher-des-ede3-cfb1.patch \
49 file://openssl-avoid-NULL-pointer-dereference-in-EVP_DigestInit_ex.patch \
50 file://openssl-avoid-NULL-pointer-dereference-in-dh_pub_encode.patch \
51 file://initial-aarch64-bits.patch \
52 file://find.pl \
53 file://openssl-fix-des.pod-error.patch \
54 "
55S = "${WORKDIR}/git"
56
57# Digest offloading through cryptodev is not recommended because of the
58# performance penalty of the Openssl engine interface. Openssl generates a huge
59# number of calls to digest functions for even a small amount of work data.
60# For example there are 70 calls to cipher code and over 10000 to digest code
61# when downloading only 10 files of 700 bytes each.
62# Do not build OpenSSL with cryptodev digest support until engine digest
63# interface gets some rework:
64CFLAG := "${@'${CFLAG}'.replace('-DUSE_CRYPTODEV_DIGESTS', '')}"