summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 2b6f1a0..4f1c61f 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -11,10 +11,10 @@ DEPENDS = "boot-format-native libgcc ${@base_contains('TCMODE', 'external-fsl',
11 11
12inherit deploy 12inherit deploy
13 13
14SRCBRANCH = "sdk-v1.4.x" 14SRCBRANCH = "sdk-v1.5.x"
15SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \ 15SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH} \
16 file://Fix-the-depend-race-issue.patch" 16 file://Fix-the-depend-race-issue.patch"
17SRCREV = "831b30de4b768f0b3b7dbfa11739b14cea612d7e" 17SRCREV = "5438fc1ca159c8f5724272efd1289e6d49771e69"
18 18
19python () { 19python () {
20 if d.getVar("TCMODE", True) == "external-fsl": 20 if d.getVar("TCMODE", True) == "external-fsl":
@@ -82,15 +82,15 @@ do_compile () {
82 if [ "x${UBOOT_TARGET}" != "x" ]; then 82 if [ "x${UBOOT_TARGET}" != "x" ]; then
83 # some boards' nand image was named as u-boot-with-spl 83 # some boards' nand image was named as u-boot-with-spl
84 if [ "${UBOOT_TARGET}" = "u-boot-nand" ];then 84 if [ "${UBOOT_TARGET}" = "u-boot-nand" ];then
85 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P1024RDB|P2020RDB|P1022DS|P1025RDB|BSC913)";then 85 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS|BSC913)";then
86 UBOOT_SOURCE=u-boot-with-spl 86 UBOOT_SOURCE=u-boot-with-spl
87 fi 87 fi
88 elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then 88 elif [ "${UBOOT_TARGET}" = "u-boot-spi" ];then
89 if echo $board |egrep -q "(P1020RDB|P1021RDB|P2020RDB|P1022DS)";then 89 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS)";then
90 UBOOT_SOURCE=u-boot-with-spl 90 UBOOT_SOURCE=u-boot-with-spl
91 fi 91 fi
92 elif [ "${UBOOT_TARGET}" = "u-boot-sd" ];then 92 elif [ "${UBOOT_TARGET}" = "u-boot-sd" ];then
93 if echo $board |egrep -q "(P1020RDB|P1021RDB|P2020RDB|P1022DS)";then 93 if echo $board |egrep -q "(P1010RDB|P1020RDB|P1021RDB|P2020RDB|P1022DS)";then
94 UBOOT_SOURCE=u-boot-with-spl 94 UBOOT_SOURCE=u-boot-with-spl
95 fi 95 fi
96 fi 96 fi