summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rcw/rcw_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/rcw/rcw_git.bb')
-rw-r--r--recipes-bsp/rcw/rcw_git.bb37
1 files changed, 13 insertions, 24 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 5714ed0..57f305a 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -1,47 +1,36 @@
1DESCRIPTION = "Reset Control Words (RCW)" 1SUMMARY = "Reset Configuration Word"
2SECTION = "rcw" 2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "BSD" 3LICENSE = "BSD"
4PR = "r8" 4PR = "r8"
5 5
6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e" 6LIC_FILES_CHKSUM = "file://rcw.py;beginline=8;endline=28;md5=9ba0b28922dd187b06b6c8ebcfdd208e"
7 7
8# this package is specific to the machine itself
9INHIBIT_DEFAULT_DEPS = "1"
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
12inherit deploy 8inherit deploy
13 9
14SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;nobranch=1" 10SRCBRANCH = "master"
15SRCREV = "3e89f378ed70e9b856756de8c3dbdfccb045fa0c" 11SRCREV = "426f7a6535d93dac76f5125035e0938a85e778d2"
12SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git;branch=${SRCBRANCH} \
13 file://rcw-make-BOARDS-DESTDIR-overidable-in-Makefile.patch \
14"
16 15
17S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
18 17
19export PYTHON 18EXTRA_OEMAKE = "BOARDS=${@d.getVar('MACHINE', True).replace('-64b','')} DESTDIR=${D}/boot/rcw/"
20 19
21do_install () { 20do_install () {
22 make install 21 oe_runmake install
23
24 M=`echo ${MACHINE} | sed s/-64b//g`
25 if [ "t1042rdb" = "${M}" ] || [ "t1042rdb-pi" = "${M}" ];then
26 M=t1042rdb_pi
27 fi
28 install -d ${D}/boot/rcw
29 cp -r ${S}/${M}/${M}/* ${D}/boot/rcw
30} 22}
31 23
32do_deploy () { 24do_deploy () {
33 M=`echo ${MACHINE} | sed s/-64b//g`
34 if [ "t1042rdb" = "${M}" ] || [ "t1042rdb-pi" = "${M}" ];then
35 M=t1042rdb_pi
36 fi
37 install -d ${DEPLOYDIR}/rcw 25 install -d ${DEPLOYDIR}/rcw
38 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw 26 cp -r ${D}/boot/rcw/* ${DEPLOYDIR}/rcw/
39} 27}
40addtask deploy after do_install 28addtask deploy after do_install
41 29
42PACKAGES += "${PN}-image" 30PACKAGES += "${PN}-image"
43FILES_${PN}-image += "/boot" 31FILES_${PN}-image += "/boot"
44 32
45COMPATIBLE_HOST_qoriq-ppc = ".*"
46COMPATIBLE_HOST ?= "(none)"
47ALLOW_EMPTY_${PN} = "1" 33ALLOW_EMPTY_${PN} = "1"
34
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36COMPATIBLE_MACHINE = "(qoriq-ppc)"