summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/qe-ucode/qe-ucode_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/qe-ucode/qe-ucode_git.bb')
-rw-r--r--recipes-bsp/qe-ucode/qe-ucode_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb
new file mode 100644
index 0000000..028d9bc
--- /dev/null
+++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "qe microcode binary"
2SECTION = "qe-ucode"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://EULA;md5=60037ccba533a5995e8d1a838d85799c"
5
6python () {
7 if not d.getVar("QE_UCODE", True):
8 machine = d.getVar("MACHINE", True)
9 raise bb.parse.SkipPackage("QE_UCODE not set in \
10 meta-fsl-ppc/conf/machine/%s.conf" % machine)
11}
12
13inherit deploy
14
15SRC_URI = "git://git.freescale.com/ppc/sdk/qe-ucode.git;nobranch=1"
16SRCREV= "49efc94b553de5c2a9bd28093592eff0068e161c"
17
18S = "${WORKDIR}/git"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 644 ${QE_UCODE} ${D}/boot/
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/boot
27 install -m 644 ${QE_UCODE} ${DEPLOYDIR}/boot/
28}
29addtask deploy before do_build after do_install
30
31PACKAGES += "${PN}-image"
32FILES_${PN}-image += "/boot/*"
33ALLOW_EMPTY_${PN} = "1"
34COMPATIBLE_MACHINE = "(p1021rdb|p1025twr|t1)"
35