summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/boot-format/boot-format_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/boot-format/boot-format_git.bb')
-rw-r--r--recipes-bsp/boot-format/boot-format_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-bsp/boot-format/boot-format_git.bb b/recipes-bsp/boot-format/boot-format_git.bb
new file mode 100644
index 0000000..2d9f9b1
--- /dev/null
+++ b/recipes-bsp/boot-format/boot-format_git.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Boot format utility for booting from eSDHC/eSPI"
2LICENSE = "GPLv2"
3PR = "r6"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git;nobranch=1 \
7 file://flags.patch"
8SRCREV = "4eb81a6797ef4e58bf7d9b2d58afb37a21c1f550"
9
10S = "${WORKDIR}/git"
11EXTRA_OEMAKE = 'CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"'
12
13do_install(){
14 oe_runmake DESTDIR=${D} PREFIX=${prefix} install
15}
16
17PACKAGES =+ "${PN}-config"
18FILES_${PN}-config += "${datadir}/*"
19
20BBCLASSEXTEND = "native nativesdk"