summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/apptrk/apptrk_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/apptrk/apptrk_git.bb')
-rw-r--r--recipes-bsp/apptrk/apptrk_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb
new file mode 100644
index 0000000..09d5de5
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk_git.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Userspace debug agent for PA CodeWarrior"
2LICENSE = "Freescale-EULA"
3LIC_FILES_CHKSUM = "file://COPYING;md5=95560debfde180684364319811cc1421"
4
5DEPENDS = "elfutils"
6
7SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;nobranch=1"
8SRCREV = "cbed10997c5e2a4aaa004fb0e1efec858bf1bbe1"
9
10S = "${WORKDIR}/git"
11
12CFLAGS += " -I${STAGING_INCDIR} -ISource/Linux -ISource/Portable \
13 -ISource/Linux_PA -ISource/PA -DPPC \
14"
15CFLAGS_append_powerpc64 = " -DENABLE_64BIT_SUPPORT"
16
17do_install() {
18 install -d ${D}/usr/bin
19 oe_runmake install DESTDIR=${D}
20}