summaryrefslogtreecommitdiffstats
path: root/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf18
1 files changed, 18 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 0000000..a4d4add
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,18 @@
1# We have a packages directory, add to BBFILES
2BBPATH .= ":${LAYERDIR}"
3
4BBFILES += "${LAYERDIR}/recipes-*/*/*.bb*"
5BBFILES += "${LAYERDIR}/images/*.bb*"
6BBFILES += "${LAYERDIR}/classes/*.bb*"
7
8BBFILE_COLLECTIONS += "fsl-ppc"
9BBFILE_PATTERN_fsl-ppc = "^${LAYERDIR}/"
10BBFILE_PRIORITY_fsl-ppc = "5"
11
12LICENSE_PATH += "${LAYERDIR}/custom-licenses"
13
14# Let us add layer-specific bbappends which are only applied when that
15# layer is included in our configuration
16BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
17 for layer in BBFILE_COLLECTIONS.split())}"
18