summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/cryptodev/cryptodev_1.5.bb17
-rw-r--r--recipes-kernel/cryptodev/files/makefile_fixup.patch26
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev_1.5.bb b/recipes-kernel/cryptodev/cryptodev_1.5.bb
new file mode 100644
index 0000000..0696e2a
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev_1.5.bb
@@ -0,0 +1,17 @@
1SECTION = "devel"
2SUMMARY = "Linux Cryptodev KERNEL MODULE"
3DESCRIPTION = "The Cryptodev package contains the kernel /dev/crypto module"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6RCONFLICTS_${PN} = "ocf-linux"
7
8inherit module
9
10SRCREV = "1c24a0aa996630518d47826a2e3fea129ea094c7"
11
12SRC_URI = "git://repo.or.cz/cryptodev-linux.git;protocol=git \
13 file://makefile_fixup.patch"
14
15EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" PREFIX="${D}"'
16
17S = "${WORKDIR}/git"
diff --git a/recipes-kernel/cryptodev/files/makefile_fixup.patch b/recipes-kernel/cryptodev/files/makefile_fixup.patch
new file mode 100644
index 0000000..323aacd
--- /dev/null
+++ b/recipes-kernel/cryptodev/files/makefile_fixup.patch
@@ -0,0 +1,26 @@
1diff --git a/Makefile b/Makefile
2index 2be8825..b36d68c 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -1,6 +1,7 @@
6 KBUILD_CFLAGS += -I$(src)
7 KERNEL_DIR = /lib/modules/$(shell uname -r)/build
8 VERSION = 1.5
9+PREFIX =
10
11 cryptodev-objs = ioctl.o main.o cryptlib.o authenc.o zc.o util.o
12
13@@ -12,10 +13,10 @@ build: version.h
14 version.h: Makefile
15 @echo "#define VERSION \"$(VERSION)\"" > version.h
16
17-install:
18+modules_install:
19 make -C $(KERNEL_DIR) SUBDIRS=`pwd` modules_install
20- @echo "Installing cryptodev.h in /usr/include/crypto ..."
21- @install -D crypto/cryptodev.h /usr/include/crypto/cryptodev.h
22+ @echo "Installing cryptodev.h in $(PREFIX)/usr/include/crypto ..."
23+ @install -D crypto/cryptodev.h $(PREFIX)/usr/include/crypto/cryptodev.h
24
25 clean:
26 make -C $(KERNEL_DIR) SUBDIRS=`pwd` clean