summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/fsl.conf2
-rw-r--r--conf/machine/e500mc.inc1
-rw-r--r--conf/machine/e500v2.inc1
-rw-r--r--conf/machine/e5500-64b.inc1
-rw-r--r--conf/machine/e5500.inc1
-rw-r--r--recipes-devtools/qemu/qemu_1.0.bb39
6 files changed, 43 insertions, 2 deletions
diff --git a/conf/distro/fsl.conf b/conf/distro/fsl.conf
index 0b0e17f..b923415 100644
--- a/conf/distro/fsl.conf
+++ b/conf/distro/fsl.conf
@@ -29,8 +29,6 @@ DISTRO_EXTRA_RDEPENDS_append_qemux86-64 = " ${POKYQEMUDEPS}"
29 29
30TCLIBCAPPEND = "" 30TCLIBCAPPEND = ""
31 31
32QEMU_TARGETS ?= "ppc"
33
34PREMIRRORS ?= "\ 32PREMIRRORS ?= "\
35bzr://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \ 33bzr://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
36cvs://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \ 34cvs://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \
diff --git a/conf/machine/e500mc.inc b/conf/machine/e500mc.inc
index acb55c3..9f7ed31 100644
--- a/conf/machine/e500mc.inc
+++ b/conf/machine/e500mc.inc
@@ -8,6 +8,7 @@ MACHINE_FEATURES_RRECOMMENDS = ""
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" 8PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
9PREFERRED_VERSION_virtual/kernel ?= "3.0.34" 9PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
10PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" 10PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers"
11PREFERRED_VERSION_qemu = "1.0+fsl"
11 12
12KERNEL_IMAGETYPE ?= "uImage" 13KERNEL_IMAGETYPE ?= "uImage"
13# disable the images below for now 14# disable the images below for now
diff --git a/conf/machine/e500v2.inc b/conf/machine/e500v2.inc
index 2b83795..da515da 100644
--- a/conf/machine/e500v2.inc
+++ b/conf/machine/e500v2.inc
@@ -6,6 +6,7 @@ MACHINE_EXTRA_RRECOMMENDS = ""
6PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" 6PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
7PREFERRED_VERSION_virtual/kernel ?= "3.0.34" 7PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
8PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" 8PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers"
9PREFERRED_VERSION_qemu = "1.0+fsl"
9 10
10KERNEL_IMAGETYPE ?= "uImage" 11KERNEL_IMAGETYPE ?= "uImage"
11# disable the images below for now 12# disable the images below for now
diff --git a/conf/machine/e5500-64b.inc b/conf/machine/e5500-64b.inc
index 79639f6..709880e 100644
--- a/conf/machine/e5500-64b.inc
+++ b/conf/machine/e5500-64b.inc
@@ -9,6 +9,7 @@ MACHINE_FEATURES_RRECOMMENDS = ""
9PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" 9PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
10PREFERRED_VERSION_virtual/kernel ?= "3.0.34" 10PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
11PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" 11PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers"
12PREFERRED_VERSION_qemu = "1.0+fsl"
12 13
13KERNEL_IMAGETYPE ?= "uImage" 14KERNEL_IMAGETYPE ?= "uImage"
14# disable the images below for now 15# disable the images below for now
diff --git a/conf/machine/e5500.inc b/conf/machine/e5500.inc
index b89041b..75c333a 100644
--- a/conf/machine/e5500.inc
+++ b/conf/machine/e5500.inc
@@ -8,6 +8,7 @@ MACHINE_FEATURES_RRECOMMENDS = ""
8PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" 8PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk"
9PREFERRED_VERSION_virtual/kernel ?= "3.0.34" 9PREFERRED_VERSION_virtual/kernel ?= "3.0.34"
10PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" 10PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers"
11PREFERRED_VERSION_qemu = "1.0+fsl"
11 12
12KERNEL_IMAGETYPE ?= "uImage" 13KERNEL_IMAGETYPE ?= "uImage"
13# disable the images below for now 14# disable the images below for now
diff --git a/recipes-devtools/qemu/qemu_1.0.bb b/recipes-devtools/qemu/qemu_1.0.bb
new file mode 100644
index 0000000..7a6e545
--- /dev/null
+++ b/recipes-devtools/qemu/qemu_1.0.bb
@@ -0,0 +1,39 @@
1require recipes-devtools/qemu/qemu.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
5
6# This means v1.0 with FSL specific patches applied
7PV = "1.0+fsl"
8
9DEPENDS += "dtc"
10
11SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git"
12SRCREV = "${AUTOREV}"
13
14S = "${WORKDIR}/git"
15
16QEMU_TARGETS = "ppc"
17PPC_OECONF = '${SDL} --disable-werror --disable-vnc --audio-drv-list="" --audio-card-list="" --disable-bluez --disable-curl'
18EXTRA_OECONF_powerpc = "--target-list=ppc-softmmu ${PPC_OECONF}"
19EXTRA_OECONF_powerpc64 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
20
21do_configure_append () {
22 grep 'CONFIG_FDT=y' config-host.mak
23}
24
25# gets around qemu.inc trying to install powerpc_rom.bin
26do_install_prepend() {
27 touch ${WORKDIR}/powerpc_rom.bin
28}
29
30do_install_append() {
31 rm ${WORKDIR}/powerpc_rom.bin
32}
33
34# This is only meant to be build to run on the target
35# for the given arch types listed, otherwise don't let
36# the package get built. COMPATIBLE_HOST would not work
37# because it was too generic
38COMPATIBLE_MACHINE = "a^"
39COMPATIBLE_MACHINE_libc-glibc_fslmachine = ".*"