diff options
-rw-r--r-- | conf/distro/fsl.conf | 2 | ||||
-rw-r--r-- | conf/machine/e500mc.inc | 1 | ||||
-rw-r--r-- | conf/machine/e500v2.inc | 1 | ||||
-rw-r--r-- | conf/machine/e5500-64b.inc | 1 | ||||
-rw-r--r-- | conf/machine/e5500.inc | 1 | ||||
-rw-r--r-- | recipes-devtools/qemu/qemu_1.0.bb | 39 |
6 files changed, 43 insertions, 2 deletions
diff --git a/conf/distro/fsl.conf b/conf/distro/fsl.conf index 0b0e17f..b923415 100644 --- a/conf/distro/fsl.conf +++ b/conf/distro/fsl.conf | |||
@@ -29,8 +29,6 @@ DISTRO_EXTRA_RDEPENDS_append_qemux86-64 = " ${POKYQEMUDEPS}" | |||
29 | 29 | ||
30 | TCLIBCAPPEND = "" | 30 | TCLIBCAPPEND = "" |
31 | 31 | ||
32 | QEMU_TARGETS ?= "ppc" | ||
33 | |||
34 | PREMIRRORS ?= "\ | 32 | PREMIRRORS ?= "\ |
35 | bzr://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \ | 33 | bzr://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \ |
36 | cvs://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \ | 34 | cvs://.*/.* http://downloads.yoctoproject.org/mirror/sources/ \n \ |
diff --git a/conf/machine/e500mc.inc b/conf/machine/e500mc.inc index acb55c3..9f7ed31 100644 --- a/conf/machine/e500mc.inc +++ b/conf/machine/e500mc.inc | |||
@@ -8,6 +8,7 @@ MACHINE_FEATURES_RRECOMMENDS = "" | |||
8 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" | 8 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" |
9 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" | 9 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" |
10 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" | 10 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" |
11 | PREFERRED_VERSION_qemu = "1.0+fsl" | ||
11 | 12 | ||
12 | KERNEL_IMAGETYPE ?= "uImage" | 13 | KERNEL_IMAGETYPE ?= "uImage" |
13 | # disable the images below for now | 14 | # disable the images below for now |
diff --git a/conf/machine/e500v2.inc b/conf/machine/e500v2.inc index 2b83795..da515da 100644 --- a/conf/machine/e500v2.inc +++ b/conf/machine/e500v2.inc | |||
@@ -6,6 +6,7 @@ MACHINE_EXTRA_RRECOMMENDS = "" | |||
6 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" | 6 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" |
7 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" | 7 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" |
8 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" | 8 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" |
9 | PREFERRED_VERSION_qemu = "1.0+fsl" | ||
9 | 10 | ||
10 | KERNEL_IMAGETYPE ?= "uImage" | 11 | KERNEL_IMAGETYPE ?= "uImage" |
11 | # disable the images below for now | 12 | # disable the images below for now |
diff --git a/conf/machine/e5500-64b.inc b/conf/machine/e5500-64b.inc index 79639f6..709880e 100644 --- a/conf/machine/e5500-64b.inc +++ b/conf/machine/e5500-64b.inc | |||
@@ -9,6 +9,7 @@ MACHINE_FEATURES_RRECOMMENDS = "" | |||
9 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" | 9 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" |
10 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" | 10 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" |
11 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" | 11 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" |
12 | PREFERRED_VERSION_qemu = "1.0+fsl" | ||
12 | 13 | ||
13 | KERNEL_IMAGETYPE ?= "uImage" | 14 | KERNEL_IMAGETYPE ?= "uImage" |
14 | # disable the images below for now | 15 | # disable the images below for now |
diff --git a/conf/machine/e5500.inc b/conf/machine/e5500.inc index b89041b..75c333a 100644 --- a/conf/machine/e5500.inc +++ b/conf/machine/e5500.inc | |||
@@ -8,6 +8,7 @@ MACHINE_FEATURES_RRECOMMENDS = "" | |||
8 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" | 8 | PREFERRED_PROVIDER_virtual/kernel ?= "linux-qoriq-sdk" |
9 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" | 9 | PREFERRED_VERSION_virtual/kernel ?= "3.0.34" |
10 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" | 10 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-qoriq-sdk-headers" |
11 | PREFERRED_VERSION_qemu = "1.0+fsl" | ||
11 | 12 | ||
12 | KERNEL_IMAGETYPE ?= "uImage" | 13 | KERNEL_IMAGETYPE ?= "uImage" |
13 | # disable the images below for now | 14 | # disable the images below for now |
diff --git a/recipes-devtools/qemu/qemu_1.0.bb b/recipes-devtools/qemu/qemu_1.0.bb new file mode 100644 index 0000000..7a6e545 --- /dev/null +++ b/recipes-devtools/qemu/qemu_1.0.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | require recipes-devtools/qemu/qemu.inc | ||
2 | |||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ | ||
4 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" | ||
5 | |||
6 | # This means v1.0 with FSL specific patches applied | ||
7 | PV = "1.0+fsl" | ||
8 | |||
9 | DEPENDS += "dtc" | ||
10 | |||
11 | SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git" | ||
12 | SRCREV = "${AUTOREV}" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | QEMU_TARGETS = "ppc" | ||
17 | PPC_OECONF = '${SDL} --disable-werror --disable-vnc --audio-drv-list="" --audio-card-list="" --disable-bluez --disable-curl' | ||
18 | EXTRA_OECONF_powerpc = "--target-list=ppc-softmmu ${PPC_OECONF}" | ||
19 | EXTRA_OECONF_powerpc64 = "--target-list=ppc64-softmmu ${PPC_OECONF}" | ||
20 | |||
21 | do_configure_append () { | ||
22 | grep 'CONFIG_FDT=y' config-host.mak | ||
23 | } | ||
24 | |||
25 | # gets around qemu.inc trying to install powerpc_rom.bin | ||
26 | do_install_prepend() { | ||
27 | touch ${WORKDIR}/powerpc_rom.bin | ||
28 | } | ||
29 | |||
30 | do_install_append() { | ||
31 | rm ${WORKDIR}/powerpc_rom.bin | ||
32 | } | ||
33 | |||
34 | # This is only meant to be build to run on the target | ||
35 | # for the given arch types listed, otherwise don't let | ||
36 | # the package get built. COMPATIBLE_HOST would not work | ||
37 | # because it was too generic | ||
38 | COMPATIBLE_MACHINE = "a^" | ||
39 | COMPATIBLE_MACHINE_libc-glibc_fslmachine = ".*" | ||