summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-tools/rcw/rcw_git.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/recipes-tools/rcw/rcw_git.bb b/recipes-tools/rcw/rcw_git.bb
index af8db7d..ff1b99f 100644
--- a/recipes-tools/rcw/rcw_git.bb
+++ b/recipes-tools/rcw/rcw_git.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "Reset Control Words (RCW)" 1DESCRIPTION = "Reset Control Words (RCW)"
2SECTION = "rcw" 2SECTION = "rcw"
3LICENSE = "BSD" 3LICENSE = "BSD"
4PR = "r3" 4PR = "r4"
5 5
6LIC_FILES_CHKSUM = " \ 6LIC_FILES_CHKSUM = " \
7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ 7 file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
@@ -21,13 +21,22 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/rcw.git"
21 21
22S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
23 23
24do_deploy () { 24do_install () {
25 make install 25 make install
26 26
27 M=`echo ${MACHINE} | sed s/-64b//g` 27 M=`echo ${MACHINE} | sed s/-64b//g`
28 install -d ${D}/boot/rcw
29 cp -r ${S}/${M}/${M}/* ${D}/boot/rcw
30}
31
32do_deploy () {
33 M=`echo ${MACHINE} | sed s/-64b//g`
28 install -d ${DEPLOYDIR}/rcw 34 install -d ${DEPLOYDIR}/rcw
29 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw 35 cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/rcw
30} 36}
31addtask deploy after do_install 37addtask deploy after do_install
32 38
39PACKAGES += "${PN}-image"
40FILES_${PN}-image += "/boot"
41
33ALLOW_EMPTY_${PN} = "1" 42ALLOW_EMPTY_${PN} = "1"