summaryrefslogtreecommitdiffstats
path: root/recipes-tools
diff options
context:
space:
mode:
authorStuart Yoder <stuart.yoder@freescale.com>2012-10-10 03:28:28 +0000
committerMatthew McClintock <msm@freescale.com>2012-12-04 13:16:52 -0600
commit8574faf4ca824c07c0b185a2758e725fce94a773 (patch)
tree38956a42dff17f3f9dc4199df21771616b83e1a3 /recipes-tools
parent57411fa9a4be78cdf539b8f65cde5f502752a113 (diff)
downloadmeta-fsl-ppc-8574faf4ca824c07c0b185a2758e725fce94a773.tar.gz
lxc: remove hwaddr from vlan config
-to get vlan working with the FSL SDK we need to remove the hwaddr. This was found by trial and error. Upstream discussion is started as to when the hwaddr might be needed, but for now remove it Signed-off-by: Stuart Yoder <stuart.yoder@freescale.com>
Diffstat (limited to 'recipes-tools')
-rw-r--r--recipes-tools/lxc/lxc_0.8.0-rc1.bb3
-rw-r--r--recipes-tools/lxc/remove_vlan_hwaddr.patch11
2 files changed, 13 insertions, 1 deletions
diff --git a/recipes-tools/lxc/lxc_0.8.0-rc1.bb b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
index e6ed2d6..c8d90ae 100644
--- a/recipes-tools/lxc/lxc_0.8.0-rc1.bb
+++ b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
@@ -3,7 +3,7 @@ SECTION = "console/utils"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" 4LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
5PRIORITY = "optional" 5PRIORITY = "optional"
6PR = "r2" 6PR = "r3"
7DEPENDS = "libxml2 libcap" 7DEPENDS = "libxml2 libcap"
8RDEPENDS_${PN} = " \ 8RDEPENDS_${PN} = " \
9 rsync \ 9 rsync \
@@ -23,6 +23,7 @@ SRC_URI = "http://lxc.sourceforge.net/download/lxc/${PN}-${PV}.tar.gz \
23 file://noldconfig.patch \ 23 file://noldconfig.patch \
24 file://libmounts.patch \ 24 file://libmounts.patch \
25 file://busybox_remove_dhcp.patch \ 25 file://busybox_remove_dhcp.patch \
26 file://remove_vlan_hwaddr.patch \
26 " 27 "
27 28
28SRC_URI[md5sum] ="06ceecf4dbe1be988fc903ad8dd34d29" 29SRC_URI[md5sum] ="06ceecf4dbe1be988fc903ad8dd34d29"
diff --git a/recipes-tools/lxc/remove_vlan_hwaddr.patch b/recipes-tools/lxc/remove_vlan_hwaddr.patch
new file mode 100644
index 0000000..d3883bd
--- /dev/null
+++ b/recipes-tools/lxc/remove_vlan_hwaddr.patch
@@ -0,0 +1,11 @@
1diff --git a/doc/examples/lxc-vlan.conf.in b/doc/examples/lxc-vlan.conf.in
2index 4404439..231d618 100644
3--- a/doc/examples/lxc-vlan.conf.in
4+++ b/doc/examples/lxc-vlan.conf.in
5@@ -4,6 +4,5 @@ lxc.network.type = vlan
6 lxc.network.vlan.id = 1234
7 lxc.network.flags = up
8 lxc.network.link = eth0
9-lxc.network.hwaddr = 4a:49:43:49:79:bd
10 lxc.network.ipv4 = 1.2.3.4/24
11 lxc.network.ipv6 = 2003:db8:1:0:214:1234:fe0b:3596