summaryrefslogtreecommitdiffstats
path: root/recipes-tools
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-10-16 00:34:24 +0000
committerMatthew McClintock <msm@freescale.com>2012-12-04 13:16:52 -0600
commit3909056b2096ff2989d5ae58f3f92fe10c93c193 (patch)
tree2982932d3406d108f6b6ad11845575f3fbf4fbef /recipes-tools
parent51d5a9f9b96e8e32560bfe6eb4e08080157ec768 (diff)
downloadmeta-fsl-ppc-3909056b2096ff2989d5ae58f3f92fe10c93c193.tar.gz
lxc_0.8.0-rc1.bb: point lxc at kernel source
Fixes: | powerpc-fsl-linux-gcc: error: default/arch/powerpc/include/asm/unistd.h: No such file or directory | powerpc-fsl-linux-gcc: fatal error: no input files | compilation terminated. | attach.c:45:19: fatal error: setns.h: No such file or directory | compilation terminated. | make[3]: [setns.h] Error 1 (ignored) | powerpc-fsl-linux-gcc -E --sysroot=/opt/yocto/cache-build/p4080ds/build_p4080ds_release/tmp/sysroots/p4080ds -m32 -mhard-float -mcpu=e500mc -dM default/arch/powerpc/include/asm/unistd.h |grep setns > setns.h | make[3]: *** [liblxc_so-attach.o] Error 1 | make[3]: *** Waiting for unfinished jobs.... | powerpc-fsl-linux-gcc: error: default/arch/powerpc/include/asm/unistd.h: No such file or directory | powerpc-fsl-linux-gcc: fatal error: no input files | compilation terminated. | make[3]: [setns.h] Error 1 (ignored) | make[3]: Leaving directory `/opt/yocto/cache-build/p4080ds/build_p4080ds_release/tmp/work/ppce500mc-fsl-linux/lxc-0.8.0-rc1-r4/lxc-0.8.0-rc1/src/lxc' | make[2]: *** [all-recursive] Error 1 | make[2]: Leaving directory `/opt/yocto/cache-build/p4080ds/build_p4080ds_release/tmp/work/ppce500mc-fsl-linux/lxc-0.8.0-rc1-r4/lxc-0.8.0-rc1/src' | make[1]: *** [all] Error 2 | make[1]: Leaving directory `/opt/yocto/cache-build/p4080ds/build_p4080ds_release/tmp/work/ppce500mc-fsl-linux/lxc-0.8.0-rc1-r4/lxc-0.8.0-rc1/src' | make: *** [all-recursive] Error 1 | ERROR: oe_runmake failed Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'recipes-tools')
-rw-r--r--recipes-tools/lxc/lxc_0.8.0-rc1.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-tools/lxc/lxc_0.8.0-rc1.bb b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
index 64f36b3..accc16f 100644
--- a/recipes-tools/lxc/lxc_0.8.0-rc1.bb
+++ b/recipes-tools/lxc/lxc_0.8.0-rc1.bb
@@ -3,8 +3,8 @@ SECTION = "console/utils"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" 4LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
5PRIORITY = "optional" 5PRIORITY = "optional"
6PR = "r4" 6PR = "r5"
7DEPENDS = "libxml2 libcap" 7DEPENDS = "libxml2 libcap virtual/kernel"
8RDEPENDS_${PN} = " \ 8RDEPENDS_${PN} = " \
9 rsync \ 9 rsync \
10 gzip \ 10 gzip \
@@ -31,7 +31,7 @@ SRC_URI[sha256sum] = "32bf83902c07387646c55de440d6d12cf61bd54c97417109c2d1ac47d1
31 31
32S = "${WORKDIR}/${PN}-${PV}" 32S = "${WORKDIR}/${PN}-${PV}"
33 33
34EXTRA_OECONF = "--disable-doc --disable-rpath" 34EXTRA_OECONF = "--disable-doc --disable-rpath --with-linuxdir=${STAGING_KERNEL_DIR}"
35 35
36inherit autotools 36inherit autotools
37 37