diff options
author | Matthew McClintock <msm@freescale.com> | 2011-12-28 12:35:26 -0600 |
---|---|---|
committer | Matthew McClintock <msm@freescale.com> | 2011-12-28 12:46:06 -0600 |
commit | 9a2511bc1713bae09ffe4430644082e10039701a (patch) | |
tree | c7d8c051854970c5e70d83b0e67fb9e622654587 /recipes-tools/hv-cfg | |
parent | 24b3d99c00244f87ca3d31b2ee00028d0c3ed812 (diff) | |
download | meta-fsl-ppc-9a2511bc1713bae09ffe4430644082e10039701a.tar.gz |
Initial add of hv-cfg using public git
Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'recipes-tools/hv-cfg')
-rw-r--r-- | recipes-tools/hv-cfg/hv-cfg_git.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-tools/hv-cfg/hv-cfg_git.bb b/recipes-tools/hv-cfg/hv-cfg_git.bb new file mode 100644 index 0000000..7a17c64 --- /dev/null +++ b/recipes-tools/hv-cfg/hv-cfg_git.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | DESCRIPTION = "Hypervisor Config" | ||
2 | SECTION = "hv-cfg" | ||
3 | LICENSE = "BSD" | ||
4 | PR = "r1" | ||
5 | |||
6 | LIC_FILES_CHKSUM = " \ | ||
7 | file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
8 | file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
9 | file://p3060qds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
10 | file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
11 | file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \ | ||
12 | " | ||
13 | |||
14 | # this package is specific to the machine itself | ||
15 | INHIBIT_DEFAULT_DEPS = "1" | ||
16 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
17 | |||
18 | inherit deploy | ||
19 | |||
20 | SRCREV = "${AUTOREV}" | ||
21 | SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | do_deploy () { | ||
26 | make install | ||
27 | |||
28 | M=`echo ${MACHINE} | sed s/-64b//g` | ||
29 | mkdir -p ${DEPLOY_DIR_IMAGE}/hv-cfg | ||
30 | cp -r ${S}/${M}/${M} ${DEPLOY_DIR_IMAGE}/hv-cfg | ||
31 | } | ||
32 | addtask deploy after do_install | ||
33 | |||
34 | ALLOW_EMPTY_${PN} = "1" | ||