summaryrefslogtreecommitdiffstats
path: root/recipes-tools/boot-format
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-12-28 12:25:38 -0600
committerMatthew McClintock <msm@freescale.com>2011-12-28 12:25:38 -0600
commit3ce956c1013cfce4e19ed451924bb0f12598482b (patch)
treea8fdd26938c7a57613693c03c970635bdb0e9ebd /recipes-tools/boot-format
parentc8f3c2be590c47405f37c1fe0848eca7af5db44d (diff)
downloadmeta-fsl-ppc-3ce956c1013cfce4e19ed451924bb0f12598482b.tar.gz
Add boot-format recipe using public git
Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'recipes-tools/boot-format')
-rw-r--r--recipes-tools/boot-format/boot-format_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-tools/boot-format/boot-format_git.bb b/recipes-tools/boot-format/boot-format_git.bb
new file mode 100644
index 0000000..a8b1bb5
--- /dev/null
+++ b/recipes-tools/boot-format/boot-format_git.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Boot format utility for booting from eSDHC/eSPI"
2LICENSE = "GPL"
3PR = "r2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/boot-format.git\
7 "
8SRCREV = "aca17b98516ef1869e7f2d98e865bce9226e8bba"
9
10S = "${WORKDIR}/git"
11EXTRA_OEMAKE = 'CC="${CC}"'
12
13do_install(){
14 oe_runmake DESTDIR=${D} PREFIX=${prefix} install
15}
16
17PACKAGES =+ "${PN}-config"
18FILES_${PN}-config += "${datadir}/*"
19
20BBCLASSEXTEND = "native nativesdk"