summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-01-05 18:32:20 +0800
committerZhenhua Luo <zhenhua.luo@freescale.com>2015-01-07 10:12:22 +0800
commit999651a453e1a57771ff0213375bc0fb784fd6a2 (patch)
treeae585892cc114f72ca5567fe130c382a663db7ea /recipes-kernel
parent1f00cf61802ce1918710a97b6f7c6b0c30484073 (diff)
downloadmeta-fsl-ppc-999651a453e1a57771ff0213375bc0fb784fd6a2.tar.gz
linux-qoriq: update revision to 6619b8b
This update to fsl sdk v1.7 release. For detailed changes, see: http://git.freescale.com/git/cgit.cgi/ppc/sdk/linux.git/ Remove the patches which were applied in the repository. Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/files/configure-T1040-for-FMAN-V3L.patch217
-rw-r--r--recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch16
-rw-r--r--recipes-kernel/linux/files/remove-Altivec-from-T1040-64-bit-defconfig.patch27
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bb4
4 files changed, 9 insertions, 255 deletions
diff --git a/recipes-kernel/linux/files/configure-T1040-for-FMAN-V3L.patch b/recipes-kernel/linux/files/configure-T1040-for-FMAN-V3L.patch
deleted file mode 100644
index 9c7ab2a..0000000
--- a/recipes-kernel/linux/files/configure-T1040-for-FMAN-V3L.patch
+++ /dev/null
@@ -1,217 +0,0 @@
1From acbdc62578c0cde48847a306a0d02a26d3a9ea8a Mon Sep 17 00:00:00 2001
2From: Bob Cochran <yocto@mindchasers.com>
3Date: Fri, 31 Oct 2014 22:50:19 -0400
4Subject: [meta-fsl-ppc][PATCH] linux-qoriq: Configure T1040 for FMAN V3L
5
6Although the flag existed in Kconfig for FMAN_V3L, it was not set by
7default. Also, the T1040 and FMAN V3L only support four O/H ports, so remove
8the last two from the DTS files. Otherwise, MAJOR FM Errors will be
9reported during FMAN probing / init.
10
11Signed-off-by: Bob Cochran <yocto@mindchasers.com>
12---
13 arch/powerpc/boot/dts/fsl/qoriq-fman3l-0.dtsi | 138 ++++++++++++++++++++++++
14 arch/powerpc/boot/dts/fsl/t1040si-post.dtsi | 10 +-
15 arch/powerpc/configs/t1040_32bit_smp_defconfig | 1 +
16 arch/powerpc/configs/t1040_64bit_smp_defconfig | 1 +
17 4 files changed, 141 insertions(+), 9 deletions(-)
18 create mode 100644 arch/powerpc/boot/dts/fsl/qoriq-fman3l-0.dtsi
19
20diff --git a/arch/powerpc/boot/dts/fsl/qoriq-fman3l-0.dtsi b/arch/powerpc/boot/dts/fsl/qoriq-fman3l-0.dtsi
21new file mode 100644
22index 0000000..b4f6cd6
23--- /dev/null
24+++ b/arch/powerpc/boot/dts/fsl/qoriq-fman3l-0.dtsi
25@@ -0,0 +1,138 @@
26+/*
27+ * QorIQ FMan v3 device tree stub [ controller @ offset 0x400000 ]
28+ *
29+ * Copyright 2012 Freescale Semiconductor Inc.
30+ *
31+ * Redistribution and use in source and binary forms, with or without
32+ * modification, are permitted provided that the following conditions are met:
33+ * * Redistributions of source code must retain the above copyright
34+ * notice, this list of conditions and the following disclaimer.
35+ * * Redistributions in binary form must reproduce the above copyright
36+ * notice, this list of conditions and the following disclaimer in the
37+ * documentation and/or other materials provided with the distribution.
38+ * * Neither the name of Freescale Semiconductor nor the
39+ * names of its contributors may be used to endorse or promote products
40+ * derived from this software without specific prior written permission.
41+ *
42+ *
43+ * ALTERNATIVELY, this software may be distributed under the terms of the
44+ * GNU General Public License ("GPL") as published by the Free Software
45+ * Foundation, either version 2 of that License or (at your option) any
46+ * later version.
47+ *
48+ * THIS SOFTWARE IS PROVIDED BY Freescale Semiconductor ``AS IS'' AND ANY
49+ * EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
50+ * WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
51+ * DISCLAIMED. IN NO EVENT SHALL Freescale Semiconductor BE LIABLE FOR ANY
52+ * DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
53+ * (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
54+ * LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
55+ * ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
56+ * (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
57+ * SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
58+ */
59+
60+fman0: fman@400000 {
61+ #address-cells = <1>;
62+ #size-cells = <1>;
63+ cell-index = <0>;
64+ compatible = "fsl,fman", "simple-bus";
65+ ranges = <0 0x400000 0x100000>;
66+ reg = <0x400000 0x100000>;
67+ clock-frequency = <0>;
68+ interrupts = <
69+ 96 2 0 0
70+ 16 2 1 1>;
71+
72+ cc {
73+ compatible = "fsl,fman-cc";
74+ };
75+
76+ muram@0 {
77+ compatible = "fsl,fman-muram";
78+ reg = <0x0 0x60000>;
79+ };
80+
81+ bmi@80000 {
82+ compatible = "fsl,fman-bmi";
83+ reg = <0x80000 0x400>;
84+ };
85+
86+ qmi@80400 {
87+ compatible = "fsl,fman-qmi";
88+ reg = <0x80400 0x400>;
89+ };
90+
91+ fman0_oh1: port@82000 {
92+ cell-index = <0>;
93+ compatible = "fsl,fman-port-oh";
94+ reg = <0x82000 0x1000>;
95+ };
96+
97+ fman0_oh2: port@83000 {
98+ cell-index = <1>;
99+ compatible = "fsl,fman-port-oh";
100+ reg = <0x83000 0x1000>;
101+ };
102+
103+ fman0_oh3: port@84000 {
104+ cell-index = <2>;
105+ compatible = "fsl,fman-port-oh";
106+ reg = <0x84000 0x1000>;
107+ };
108+
109+ fman0_oh4: port@85000 {
110+ cell-index = <3>;
111+ compatible = "fsl,fman-port-oh";
112+ reg = <0x85000 0x1000>;
113+ };
114+
115+ policer@c0000 {
116+ compatible = "fsl,fman-policer";
117+ reg = <0xc0000 0x1000>;
118+ };
119+
120+ keygen@c1000 {
121+ compatible = "fsl,fman-keygen";
122+ reg = <0xc1000 0x1000>;
123+ };
124+
125+ dma@c2000 {
126+ compatible = "fsl,fman-dma";
127+ reg = <0xc2000 0x1000>;
128+ };
129+
130+ fpm@c3000 {
131+ compatible = "fsl,fman-fpm";
132+ reg = <0xc3000 0x1000>;
133+ };
134+
135+ parser@c7000 {
136+ compatible = "fsl,fman-parser";
137+ reg = <0xc7000 0x1000>;
138+ };
139+
140+ vsps@dc000 {
141+ compatible = "fsl,fman-vsps";
142+ reg = <0xdc000 0x1000>;
143+ };
144+
145+ mdio@fc000 {
146+ #address-cells = <1>;
147+ #size-cells = <0>;
148+ compatible = "fsl,fman-memac-mdio";
149+ reg = <0xfc000 0x1000>;
150+ };
151+
152+ mdio@fd000 {
153+ #address-cells = <1>;
154+ #size-cells = <0>;
155+ compatible = "fsl,fman-memac-mdio";
156+ reg = <0xfd000 0x1000>;
157+ };
158+
159+ ptp_timer0: rtc@fe000 {
160+ compatible = "fsl,fman-rtc";
161+ reg = <0xfe000 0x1000>;
162+ };
163+};
164diff --git a/arch/powerpc/boot/dts/fsl/t1040si-post.dtsi b/arch/powerpc/boot/dts/fsl/t1040si-post.dtsi
165index 75d7462..d391471 100644
166--- a/arch/powerpc/boot/dts/fsl/t1040si-post.dtsi
167+++ b/arch/powerpc/boot/dts/fsl/t1040si-post.dtsi
168@@ -584,7 +584,7 @@ sata@221000 {
169 /include/ "qoriq-pme-0.dtsi"
170 /include/ "qoriq-qman1.dtsi"
171 /include/ "qoriq-bman1.dtsi"
172-/include/ "qoriq-fman3-0.dtsi"
173+/include/ "qoriq-fman3l-0.dtsi"
174 /include/ "qoriq-fman3-0-1g-0.dtsi"
175 /include/ "qoriq-fman3-0-1g-1.dtsi"
176 /include/ "qoriq-fman3-0-1g-2.dtsi"
177@@ -627,14 +627,6 @@ sata@221000 {
178 port@85000 {
179 fsl,qman-channel-id = <0x80c>;
180 };
181- /* offline - 5 */
182- port@86000 {
183- fsl,qman-channel-id = <0x80d>;
184- };
185- /* offline - 6 */
186- port@87000 {
187- fsl,qman-channel-id = <0x80e>;
188- };
189 mdio@fd000 {
190 status = "disabled";
191 };
192diff --git a/arch/powerpc/configs/t1040_32bit_smp_defconfig b/arch/powerpc/configs/t1040_32bit_smp_defconfig
193index a401e7c..43bf3c78 100644
194--- a/arch/powerpc/configs/t1040_32bit_smp_defconfig
195+++ b/arch/powerpc/configs/t1040_32bit_smp_defconfig
196@@ -105,6 +105,7 @@ CONFIG_NETDEVICES=y
197 CONFIG_FSL_PQ_MDIO=y
198 CONFIG_FSL_XGMAC_MDIO=y
199 CONFIG_FMAN_T4240=y
200+CONFIG_FMAN_V3L=y
201 CONFIG_FSL_DPAA_ETH=y
202 CONFIG_E1000=y
203 CONFIG_E1000E=y
204diff --git a/arch/powerpc/configs/t1040_64bit_smp_defconfig b/arch/powerpc/configs/t1040_64bit_smp_defconfig
205index c2005f2..99c05a5 100644
206--- a/arch/powerpc/configs/t1040_64bit_smp_defconfig
207+++ b/arch/powerpc/configs/t1040_64bit_smp_defconfig
208@@ -111,6 +111,7 @@ CONFIG_DUMMY=y
209 CONFIG_FSL_PQ_MDIO=y
210 CONFIG_FSL_XGMAC_MDIO=y
211 CONFIG_FMAN_T4240=y
212+CONFIG_FMAN_V3L=y
213 CONFIG_FSL_DPAA_ETH=y
214 CONFIG_E1000E=y
215 CONFIG_VITESSE_PHY=y
216--
2171.7.9.5
diff --git a/recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch b/recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch
index 7b4b39c..635c2bb 100644
--- a/recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch
+++ b/recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch
@@ -14,14 +14,14 @@ This has been tested on t1040rdb-64b. .
14 14
15Signed-off-by: Bob Cochran <yocto@mindchasers.com> 15Signed-off-by: Bob Cochran <yocto@mindchasers.com>
16--- 16---
17 arch/powerpc/configs/t1040_32bit_smp_defconfig | 2 +- 17 arch/powerpc/configs/corenet32_fmanv3_smp_defconfig | 2 +-
18 arch/powerpc/configs/t1040_64bit_smp_defconfig | 2 +- 18 arch/powerpc/configs/corenet64_fmanv3_smp_defconfig | 2 +-
19 2 files changed, 2 insertions(+), 2 deletions(-) 19 2 files changed, 2 insertions(+), 2 deletions(-)
20 20
21diff --git a/arch/powerpc/configs/t1040_32bit_smp_defconfig b/arch/powerpc/configs/t1040_32bit_smp_defconfig 21diff --git a/arch/powerpc/configs/corenet32_fmanv3_smp_defconfig b/arch/powerpc/configs/corenet32_fmanv3_smp_defconfig
22index a401e7c..5542248 100644 22index a401e7c..5542248 100644
23--- a/arch/powerpc/configs/t1040_32bit_smp_defconfig 23--- a/arch/powerpc/configs/corenet32_fmanv3_smp_defconfig
24+++ b/arch/powerpc/configs/t1040_32bit_smp_defconfig 24+++ b/arch/powerpc/configs/corenet32_fmanv3_smp_defconfig
25@@ -1,6 +1,6 @@ 25@@ -1,6 +1,6 @@
26 CONFIG_PPC_85xx=y 26 CONFIG_PPC_85xx=y
27 CONFIG_SMP=y 27 CONFIG_SMP=y
@@ -30,10 +30,10 @@ index a401e7c..5542248 100644
30 CONFIG_EXPERIMENTAL=y 30 CONFIG_EXPERIMENTAL=y
31 CONFIG_SYSVIPC=y 31 CONFIG_SYSVIPC=y
32 CONFIG_POSIX_MQUEUE=y 32 CONFIG_POSIX_MQUEUE=y
33diff --git a/arch/powerpc/configs/t1040_64bit_smp_defconfig b/arch/powerpc/configs/t1040_64bit_smp_defconfig 33diff --git a/arch/powerpc/configs/corenet64_fmanv3_smp_defconfig b/arch/powerpc/configs/corenet64_fmanv3_smp_defconfig
34index 1b987d9..bc0dacf 100644 34index 1b987d9..bc0dacf 100644
35--- a/arch/powerpc/configs/t1040_64bit_smp_defconfig 35--- a/arch/powerpc/configs/corenet64_fmanv3_smp_defconfig
36+++ b/arch/powerpc/configs/t1040_64bit_smp_defconfig 36+++ b/arch/powerpc/configs/corenet64_fmanv3_smp_defconfig
37@@ -2,7 +2,7 @@ CONFIG_PPC64=y 37@@ -2,7 +2,7 @@ CONFIG_PPC64=y
38 CONFIG_PPC_BOOK3E_64=y 38 CONFIG_PPC_BOOK3E_64=y
39 CONFIG_ALTIVEC=y 39 CONFIG_ALTIVEC=y
diff --git a/recipes-kernel/linux/files/remove-Altivec-from-T1040-64-bit-defconfig.patch b/recipes-kernel/linux/files/remove-Altivec-from-T1040-64-bit-defconfig.patch
deleted file mode 100644
index e6cc881..0000000
--- a/recipes-kernel/linux/files/remove-Altivec-from-T1040-64-bit-defconfig.patch
+++ /dev/null
@@ -1,27 +0,0 @@
1From e018761d719e41e3bf108cafafcb5138527752e2 Mon Sep 17 00:00:00 2001
2From: Bob Cochran <yocto@mindchasers.com>
3Date: Fri, 31 Oct 2014 16:49:57 -0400
4Subject: [meta-fsl-ppc][PATCH] linux-qoriq: Remove Altivec from T1040 64-bit defconfig
5
6T1040 uses an E5500 processor, and E5500 doesn't have an Altivec unit
7
8Signed-off-by: Bob Cochran <yocto@mindchasers.com>
9---
10 arch/powerpc/configs/t1040_64bit_smp_defconfig | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/arch/powerpc/configs/t1040_64bit_smp_defconfig b/arch/powerpc/configs/t1040_64bit_smp_defconfig
14index 1b987d9..c2005f2 100644
15--- a/arch/powerpc/configs/t1040_64bit_smp_defconfig
16+++ b/arch/powerpc/configs/t1040_64bit_smp_defconfig
17@@ -1,6 +1,6 @@
18 CONFIG_PPC64=y
19 CONFIG_PPC_BOOK3E_64=y
20-CONFIG_ALTIVEC=y
21+# CONFIG_ALTIVEC is not set
22 CONFIG_SMP=y
23 CONFIG_NR_CPUS=24
24 CONFIG_SYSVIPC=y
25--
261.7.9.5
27
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bb b/recipes-kernel/linux/linux-qoriq_3.12.bb
index 5f9bc17..a590231 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bb
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bb
@@ -5,9 +5,7 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \
5 file://Fix-for-CVE-2014-5045-fs-umount-on-symlink-leak.patch \ 5 file://Fix-for-CVE-2014-5045-fs-umount-on-symlink-leak.patch \
6 file://Fix-CVE-2014-5077-sctp-inherit-auth-capable-on-INIT-collisions.patch \ 6 file://Fix-CVE-2014-5077-sctp-inherit-auth-capable-on-INIT-collisions.patch \
7 file://Fix-CVE-2014-5471_CVE-2014-5472.patch \ 7 file://Fix-CVE-2014-5471_CVE-2014-5472.patch \
8 file://remove-Altivec-from-T1040-64-bit-defconfig.patch \
9 file://configure-T1040-for-FMAN-V3L.patch \
10 file://modify-defconfig-t1040-nr-cpus.patch \ 8 file://modify-defconfig-t1040-nr-cpus.patch \
11" 9"
12SRCREV = "c29fe1a733308cbe592b3af054a97be1b91cf2dd" 10SRCREV = "6619b8b55796cdf0cec04b66a71288edd3057229"
13 11