summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorBob Cochran <yocto@mindchasers.com>2014-11-13 23:05:20 -0500
committerZhenhua Luo <zhenhua.luo@freescale.com>2014-12-04 21:25:46 +0800
commit486a72425f2f6e25efd9bfdbb9638fb58e90a85f (patch)
treec2a8d176c7709b50389d1bc1ffb76a1f243b942d /recipes-kernel
parentaeb28ed76b764b3fd18a43aeb3ae93e76d51bf43 (diff)
downloadmeta-fsl-ppc-486a72425f2f6e25efd9bfdbb9638fb58e90a85f.tar.gz
linux-qoriq: change defconfig for T1040 to match number of cpus
Having a number higher than necessary for NR_CPUS wastes memory by instantiating unnecessary structures in RAM. An example is in the DPAA where DPAA_ETH_TX_QUEUES is defined based on NR_CPUS and used to create dozens of extra qman_fq structures. Using the prior value of 24, which was left over from the T4240 created an additonal 60 frame queue structures alone. This has been tested on t1040rdb-64b. Signed-off-by: Bob Cochran <yocto@mindchasers.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch47
-rw-r--r--recipes-kernel/linux/linux-qoriq_3.12.bb1
2 files changed, 48 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch b/recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch
new file mode 100644
index 0000000..7b4b39c
--- /dev/null
+++ b/recipes-kernel/linux/files/modify-defconfig-t1040-nr-cpus.patch
@@ -0,0 +1,47 @@
1From 8545129540a5862b22aad03badb2a9f93bf29117 Mon Sep 17 00:00:00 2001
2From: Bob Cochran <yocto@mindchasers.com>
3Date: Mon, 3 Nov 2014 22:45:35 -0500
4Subject: [meta-fsl-ppc][PATCH] linux-qoriq: Change defconfig for T1040 to
5 match number of CPUS
6
7Having a number higher than necessary for NR_CPUS wastes memory by
8instantiating unnecessary structures in RAM. An example is in the DPAA where
9DPAA_ETH_TX_QUEUES is defined based on NR_CPUS and used to create
10dozens of extra qman_fq structures. Using the prior value of 24, which was
11left over from the T4240 created an additonal 60 frame queue structures alone.
12
13This has been tested on t1040rdb-64b. .
14
15Signed-off-by: Bob Cochran <yocto@mindchasers.com>
16---
17 arch/powerpc/configs/t1040_32bit_smp_defconfig | 2 +-
18 arch/powerpc/configs/t1040_64bit_smp_defconfig | 2 +-
19 2 files changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/arch/powerpc/configs/t1040_32bit_smp_defconfig b/arch/powerpc/configs/t1040_32bit_smp_defconfig
22index a401e7c..5542248 100644
23--- a/arch/powerpc/configs/t1040_32bit_smp_defconfig
24+++ b/arch/powerpc/configs/t1040_32bit_smp_defconfig
25@@ -1,6 +1,6 @@
26 CONFIG_PPC_85xx=y
27 CONFIG_SMP=y
28-CONFIG_NR_CPUS=8
29+CONFIG_NR_CPUS=4
30 CONFIG_EXPERIMENTAL=y
31 CONFIG_SYSVIPC=y
32 CONFIG_POSIX_MQUEUE=y
33diff --git a/arch/powerpc/configs/t1040_64bit_smp_defconfig b/arch/powerpc/configs/t1040_64bit_smp_defconfig
34index 1b987d9..bc0dacf 100644
35--- a/arch/powerpc/configs/t1040_64bit_smp_defconfig
36+++ b/arch/powerpc/configs/t1040_64bit_smp_defconfig
37@@ -2,7 +2,7 @@ CONFIG_PPC64=y
38 CONFIG_PPC_BOOK3E_64=y
39 CONFIG_ALTIVEC=y
40 CONFIG_SMP=y
41-CONFIG_NR_CPUS=24
42+CONFIG_NR_CPUS=4
43 CONFIG_SYSVIPC=y
44 CONFIG_POSIX_MQUEUE=y
45 CONFIG_IRQ_DOMAIN_DEBUG=y
46--
471.7.9.5
diff --git a/recipes-kernel/linux/linux-qoriq_3.12.bb b/recipes-kernel/linux/linux-qoriq_3.12.bb
index 39c4a7b..5f9bc17 100644
--- a/recipes-kernel/linux/linux-qoriq_3.12.bb
+++ b/recipes-kernel/linux/linux-qoriq_3.12.bb
@@ -7,6 +7,7 @@ SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git;nobranch=1 \
7 file://Fix-CVE-2014-5471_CVE-2014-5472.patch \ 7 file://Fix-CVE-2014-5471_CVE-2014-5472.patch \
8 file://remove-Altivec-from-T1040-64-bit-defconfig.patch \ 8 file://remove-Altivec-from-T1040-64-bit-defconfig.patch \
9 file://configure-T1040-for-FMAN-V3L.patch \ 9 file://configure-T1040-for-FMAN-V3L.patch \
10 file://modify-defconfig-t1040-nr-cpus.patch \
10" 11"
11SRCREV = "c29fe1a733308cbe592b3af054a97be1b91cf2dd" 12SRCREV = "c29fe1a733308cbe592b3af054a97be1b91cf2dd"
12 13