summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2011-11-28 11:34:17 -0600
committerMatthew McClintock <msm@freescale.com>2011-11-28 11:34:17 -0600
commit2ca022e045dca9cdc634e98d1a0185a327e72178 (patch)
tree2b85d8048e2d09d13540132e237fa1cd05d59789 /recipes-kernel
parent88f3d2ee358df79fc45cc74414baa3cbd457d745 (diff)
downloadmeta-fsl-ppc-2ca022e045dca9cdc634e98d1a0185a327e72178.tar.gz
Add mkdir -p to target install dir so it exists
Signed-off-by: Matthew McClintock <msm@freescale.com>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/u-boot/u-boot_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-kernel/u-boot/u-boot_git.bb b/recipes-kernel/u-boot/u-boot_git.bb
index 9cc761d..de907b3 100644
--- a/recipes-kernel/u-boot/u-boot_git.bb
+++ b/recipes-kernel/u-boot/u-boot_git.bb
@@ -65,6 +65,7 @@ do_install(){
65 esac 65 esac
66 66
67 if [ -f ${S}/${UBOOT_TARGET}.bin ]; then 67 if [ -f ${S}/${UBOOT_TARGET}.bin ]; then
68 mkdir -p ${S}/${board}/${UBOOT_TARGET}.bin ${D}/boot/
68 install ${S}/${board}/${UBOOT_TARGET}.bin ${D}/boot/${UBOOT_TARGET}-${MACHINE}-${PV}-${PR}.bin 69 install ${S}/${board}/${UBOOT_TARGET}.bin ${D}/boot/${UBOOT_TARGET}-${MACHINE}-${PV}-${PR}.bin
69 ln -sf ${UBOOT_TARGET}-${MACHINE}-${PV}-${PR}.bin ${D}/boot/${UBOOT_TARGET}.bin 70 ln -sf ${UBOOT_TARGET}-${MACHINE}-${PV}-${PR}.bin ${D}/boot/${UBOOT_TARGET}.bin
70 fi 71 fi